Liferay Connector to SAML 2.0

  • Enterprise Subscribers Only: Find out how to get a subscription.

Security Assertion Markup Language 2.0 (SAML 2.0) is a version of the SAML OASIS standard for exchanging authentication and authorization data between security domains. SAML 2.0 is an XML-based protocol that uses security tokens containing assertions to pass information about a principal (usually an end-user) between an identity provider and a web service. SAML 2.0 enables web-based authentication and authorization scenarios including single sign-on (SSO). This app enables Liferay to act as a SAML 2.0 Identity Provider (IdP) or Service Provider (SP). It is built on top of OpenSAML and uses the Java Keystore for providing certificates/credentials for security. Once this app is installed, additional configuration is required to adapt the app with your local SAML environment and configuration. Visit the Documentation link to learn more about SAML and its configuration options.

Supported SAML Providers: PingFederate, ADFS, Shibboleth, Siteminder and OpenAM.

Fix Pack Requirements:

  • Liferay Connector to SAML 2.0 2.1.3 requires the installation of the Liferay Portal 6.2 EE Portal-154 Fix Pack or higher.
  • Liferay Connector to SAML 2.0 3.1.2 requires the installation of the Liferay Digital Enterprise 7.0 Fix Pack 90 or higher.
  • Liferay Connector to SAML 2.0 4.0.0+ requires the installation of the Liferay DXP 7.1 Fix Pack 3 or higher
Últimos cambios
  • LPS-104435 Update publishing scripts to run against the master branch
  • LPS-66389 Move SAML plugin code into appropriate modules (per parent story)
  • LPS-76221 Disable automatic translations and copies using the Lang Builder in portal builds
  • LPS-77699 Update Translations
  • LPS-78772 Formatting of tags in *.jsp should be consistent
  • LPS-80459 SAML SLO doesn't show server name, JSP cannot compile on 6.1.20
  • LPS-81106 Update SF to apply commercial copyright for private apps
  • LPS-82343 Consolidate language keys
  • LPS-84119 SourceFormatter improvements
  • LPS-85052 Upgrade to opensaml 3.0 library
  • LPS-88853 Upgrade login process to support multiple SAML IdPs
  • LRCI-699 Semantic ver and modules semanic versioning are failing on dxp profiles
  • LRQA-45313 ReleaseInfo - 7.2 M1
  • LRQA-51488 Clarifying strings
  • RELEASE-2168 Generate LPKG with build-release-marketplace-apps & smoke test

Clientes que vieron esto tambien compraron