Liferay Enterprise Search Security

  • Enterprise Subscribers Only: Find out how to get a subscription.

The Liferay Enterprise Search Security app allows you to connect Liferay DXP to an Elasticsearch 6 cluster securely. From Elastic's website, "With Security, you can password-protect your data as well as implement more advanced security measures such as encrypting communications, role-based access control, IP filtering, and auditing." More information about Elasticsearch security can be found at https://www.elastic.co/guide/en/elasticsearch/reference/6.8/configuring-security.html.

To learn about compatibility, see the compatibility matrix: https://help.liferay.com/hc/en-us/articles/360016511651#Liferay-Enterprise-Search.

Elastic, Elasticsearch, and X-Pack are trademarks of Elasticsearch BV, registered in the U.S. and in other countries.

Latest Changes
  • LPS-103302 Use ListUtil.fromArray instead of ListUtil.toList
  • LPS-107697 Default value of configuration with escaped character can not be unescaped when read
  • LPS-112251 NoNodeAvailableException occurs and Elasticsearch PKI authentication is not working unless the native realm...
  • LPS-119196 Configurable escapes backslash in non multivalued attributes
  • LPS-122403 Add check to append Automatic Copy to lang keys
  • LPS-151205 Configuring the TLS protocol version and cipher suites for the connection through JVM properties on DXP ver...
  • LPS-74544 SourceFormatter improvements
  • LPS-75049 Drop support for "provided" configuration in gradle-plugins-defaults and move to "compileOnly"
  • LPS-77425 Create a task to increase all major versions of modules and portal artifacts
  • LPS-77679 Create X-Pack Security module
  • LPS-77699 Update Translations
  • LPS-78977 Update language keys for X-Pack
  • LPS-79562 As a developer, I would like a test to automatically check that the Bundle-Version in master is a major ver...
  • LPS-79679 SourceFormatter improvements
  • LPS-81106 Update SF to apply commercial copyright for private apps
  • LPS-82343 Consolidate language keys
  • LPS-86408 Set default Java version to 1.8 for OSGi projects
  • LPS-95413 Remove lib/development/biz.aQute.bnd.jar

Customers Who Viewed This Also Bought