Liferay Connector to Elasticsearch 6

  • Enterprise Subscribers Only: Find out how to get a subscription.

Liferay Connector to Elasticsearch 6 connects Liferay Portal or Liferay DXP to the Elasticsearch 6.1.x through 6.8.x search engine. This client application is a drop-in replacement for the default Elasticsearch 2.x connector that ships with the Foundation app suite in Liferay Digital Experience Platform 7.0.

Liferay Connector to Elasticsearch 6 1.1.0+ requires the installation of the Liferay Digital Experience Platform 7.0 Fix Pack 79 or higher and connects Liferay Portal or Liferay DXP to Elasticsearch 6.1.x through 6.8.x search engine.

The previous versions of Liferay Connector to Elasticsearch 6 connects Liferay Portal or Liferay DXP to Elasticsearch 6.1.x and requires the installation of the Liferay Digital Experience Platform 7.0 Fix Pack 42 or higher.

In Liferay 7.1 and 7.2, this app is installed by default and updated through Liferay DXP Fix Packs and Liferay Portal CE GA releases. Using Liferay Marketplace to update the app on Liferay 7.1 or 7.2 will cause an error.

Latest Changes
  • LPS-101883 IndexDefinition must be a portal-search-spi interface (not portal-search-elasticsearch6-spi) so application...
  • LPS-107697 Default value of configuration with escaped character can not be unescaped when read
  • LPS-111637 NoSuchMethodError is thrown when uploading a .xls file
  • LPS-75049 Drop support for "provided" configuration in gradle-plugins-defaults and move to "compileOnly"
  • LPS-75377 As a System Administrator I can browse the available system settings following a semantic organization that...
  • LPS-77425 Create a task to increase all major versions of modules and portal artifacts
  • LPS-77429 Expose Elasticsearch api to add a preference to SearchRequestBuilder object
  • LPS-77699 Update Translations
  • LPS-78232 Elasticsearch 6: apps/portal-search-elasticsearch6
  • LPS-78305 Remove exported packages from portal-configuration-metatype
  • LPS-78576 Update language keys for Elasticsearch Configuration
  • LPS-78979 Typo in Elasticsearch language key
  • LPS-79294 Language key value was reverted by translation sync
  • LPS-79679 SourceFormatter improvements
  • LPS-80332 Add suite bnd bundle instruction
  • LPS-82343 Consolidate language keys
  • LPS-86408 Set default Java version to 1.8 for OSGi projects
  • LPS-86861 As a Search Admin, I want to upgrade to Elasticsearch 6.5
  • LPS-87590 Add Kazakh as a Community Language
  • LPS-92816 Remove 'Synchronized Search' setting which has no impact on Embedded connection since Elasticsearch 6
  • LPS-94161 As a Developer, I can implement Index Definitions for automatic creation of application driven indexes
  • LPS-94555 Add Tamil as a Community Language
  • LPS-95413 Remove lib/development/biz.aQute.bnd.jar
  • LRQA-51488 Clarifying strings

Customers Who Viewed This Also Bought