论坛

主页 » Liferay Portal » English » 3. Development

组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Juhi Kumari
Always getting the same userId in template
2013年2月5日 下午10:44
答复

Juhi Kumari

等级: Expert

帖子: 347

加入日期: 2011年12月12日

最近的帖子

Hi,
I want the loged-in user id in my web content template. For this in template I use
1#set($userId = $getterUtil.getLong($request.get("theme-display").get("user-id")))
2or
3#set ($uId = $getterUtil.getLong($request.remote-user))

But it always return user id of Test Test only . Don't know where I am missing??
If any idea please share!!!!

Regards
Juhi
Jitendra Rajput
RE: Always getting the same userId in template
2013年2月5日 下午10:51
答复

Jitendra Rajput

等级: Liferay Master

帖子: 873

加入日期: 2011年1月7日

最近的帖子

I guess UserId is default variable it should be directly available . No need to get it from request .
try to print $user_id
Juhi Kumari
RE: Always getting the same userId in template
2013年2月5日 下午11:12
答复

Juhi Kumari

等级: Expert

帖子: 347

加入日期: 2011年12月12日

最近的帖子

Hi Jitendra,

Thanks for your reply. But Its not working..emoticon

Regards
Juhi
Jitendra Rajput
RE: Always getting the same userId in template
2013年2月5日 下午11:18
答复

Jitendra Rajput

等级: Liferay Master

帖子: 873

加入日期: 2011年1月7日

最近的帖子

Did you tried by setting below property in portal-ext ?

journal.template.velocity.restricted.variables=
Juhi Kumari
RE: Always getting the same userId in template
2013年2月5日 下午11:20
答复

Juhi Kumari

等级: Expert

帖子: 347

加入日期: 2011年12月12日

最近的帖子

Hi,
Already I did that one, then only I am getting same userId always.

Regards
Juhi
James Falkner
RE: Always getting the same userId in template
2013年2月5日 下午11:37
答复

James Falkner

Community Moderator

等级: Liferay Legend

帖子: 1406

加入日期: 2010年9月17日

最近的帖子

Juhi Kumari:
Hi,
Already I did that one, then only I am getting same userId always.

Regards
Juhi


You need to uncheck the "Cacheable" option when editing the template.
Juhi Kumari
RE: Always getting the same userId in template
2013年2月6日 上午1:09
答复

Juhi Kumari

等级: Expert

帖子: 347

加入日期: 2011年12月12日

最近的帖子

Hi James,

Thanks for your reply. Now its working fine.

Regards
Juhi