组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Bruno Santos
Web Content Publishing - Misbehaviour
2010年7月18日 下午1:21
答复

Bruno Santos

等级: New Member

帖子: 17

加入日期: 2010年6月30日

最近的帖子

Hello all,

I have found a behaviour on the CMS Web content creation and publishing that I think is serious. When we are creating a web content we can never have it as draft after having it published. For example, I create a web content and publish it, after that I change it and only save it, after that I can only save it and never publish it again. I get the following error: Another user has made changes since you started editing. Please copy your changes and try again. When the only user using liferay backoffice is me :S. I should be able to publish again right? Do you think I should file this as a bug?


Regards
Samuel Kong
RE: Web Content Publishing - Misbehaviour
2010年7月18日 下午9:32
答复

Samuel Kong

LIFERAY STAFF

等级: Liferay Legend

帖子: 1433

加入日期: 2008年3月10日

最近的帖子

That's not a bug. Once an article has been published, it can not be unpublished. If you want, you can create a new version of the article. The new version of the article will start off as a draft.
Jorge Ferrer
RE: Web Content Publishing - Misbehaviour
2010年7月19日 上午12:26
答复

Jorge Ferrer

LIFERAY STAFF

等级: Liferay Legend

帖子: 2768

加入日期: 2006年8月31日

最近的帖子

Hi Bruno,

Also, check Liferay 6, we've redesigned how versioning and the approval process work and it's now much more intuitive.
Ming Chien Ng
RE: Web Content Publishing - Misbehaviour
2011年5月5日 上午3:06
答复

Ming Chien Ng

等级: New Member

帖子: 10

加入日期: 2011年1月6日

最近的帖子

Hi,

I'm facing the same problem and using Liferay 6 like you mentioned

This is what I did and try to make some senses on this logic :

1) Published a web content
2) Edit web content, make changes and published right away > OK
3) Edit web content, make changes and saved as draft and then published right away > OK
4) Edit web content, make changes and saved as draft and exit
5) Go back to web content, publish > NOT OK nor saved as draft

Why?

Can you explain what's the reason and logic behind this publishing bit ...please..
In additional to that, save as draft button is not disabled, so is hard to make users to understand why they can't use it since is there enabled.
Get what I'm trying to say here?

Hope to hear from you soon! emoticon

Thanks!
Hitoshi Ozawa
RE: Web Content Publishing - Misbehaviour
2011年5月5日 上午4:53
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

I'm facing the same problem and using Liferay 6 like you mentioned


Ming, I think your problem is different from Bruno. Bruno just want to republish. Samuel replied that this can not be done because of the specification.

What you brought up seems like a bug.

4) Edit web content, make changes and saved as draft and exit
5) Go back to web content, publish > NOT OK nor saved as draft


Can you tell me how you're existing in step 4 and how you're going back in step 5 so I can reproduce your steps?

Also, how are you setting up your workflow? Are you approving the content after each publish or have you turn workflow off on Web Content?
Hitoshi Ozawa
RE: Web Content Publishing - Misbehaviour
2011年5月5日 下午3:20
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

4) Edit web content, make changes and saved as draft and exit
5) Go back to web content, publish > NOT OK nor saved as draft


I just tested this and I can publish after getting back the saved draft.

Here are my steps.
1. Add Web Content to a page
2. Add content
3. Save as Draft
4. Select "Cancel" to exit Web Content edit
I've turned off Workflow, but the Web Content Displays ".... is not approved" This is a misleading message. (see attached figure)
 To turn off workflow - Control Panel -> Workflow Configuration -> Web Content (set to "Default: No workflow")
5. Double click on the ".... is not approved" message to bring back the content in edit mode.
6. Select "Publish" button. The content is published.
附件

附件

附件: webContent1.jpg (5.7k), webContent2.jpg (4.4k)
Ming Chien Ng
RE: Web Content Publishing - Misbehaviour
2011年5月5日 下午8:47
答复

Ming Chien Ng

等级: New Member

帖子: 10

加入日期: 2011年1月6日

最近的帖子

Hi Hitoshi,

Thanks for your reply. Your steps are correct but if you were drill in further, as in create a 2nd draft after publishing the 1st draft of the web content,the error will occurred.
I've got this error quite consistent.

1. Create web content
2. Published 1st draft.
3.Edit web content, saved as 2nd draft.
4.Exit from the page, and edit web content > click publish > NOT OK > click save as draft > NOT OK also

So basically user will stucked in 2nd draft, don't know what to do. As workaround, I copied 2nd draft, deleted the 2nd draft frm history and create another version and publish.

BUT I have just realized, if I waited for 1 min or so ...it allows me to publish ... emoticon

I might sound stupid, but that's exactly what I'm facing. emoticon

Attached are the details.

Thanks again!
附件: Web Content Publishing - Misbehaviour.docx (150.1k)
Hitoshi Ozawa
RE: Web Content Publishing - Misbehaviour
2011年5月5日 下午9:42
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

I just retried you steps and did not get the error you've mentioned.

I was looking through your attached document and realized something different.
When creating a new web content, "localized", "Language", and "Default Language" should be disabled. In your first web content screen shot, they are enabled. It seems to be a screenshot of the web content "edit" rather than new web content.

BUT I have just realized, if I waited for 1 min or so ...it allows me to publish.


That is strange. If this is your development server, maybe you can test it in "Development Mode" to turn the cache off.
http://www.liferay.com/community/wiki/-/wiki/Main/Liferay+Developer+Mode
附件

附件: webContent3.jpg (11.2k)
Manuela Neidt
RE: Web Content Publishing - Misbehaviour
2012年1月16日 下午11:50
答复

Manuela Neidt

等级: New Member

帖子: 2

加入日期: 2011年10月27日

最近的帖子

Hi,

I have the same problem like Ming.

1. Create web content and publish
2. Edit web content and publish
3. Content is published
4. Edit web content and save as draft
5. Content is saved as draft, press cancel
6. Published Content is shown
7. Edit web content and publish
8. Error is shown

From this moment there is no possibility to publish the web content again.
Waiting a while like Ming didn't work.

The only way is publishing in control panel.

I'm using Liferay Portal Enterprise Edition 6.0 EE SP1

Thanks!
附件: Web Content Publishing - Misbehaviour.docx (287.0k)
Hitoshi Ozawa
RE: Web Content Publishing - Misbehaviour
2012年1月17日 下午1:58
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

If you're using the EE version, it may be quicker to contact Liferay support about this.

Are you using this on a local single computer without using any proxy or caching?
Sorry, but I only have CE versions and can't reproduce.
Manuela Neidt
RE: Web Content Publishing - Misbehaviour
2012年1月26日 下午11:22
答复

Manuela Neidt

等级: New Member

帖子: 2

加入日期: 2011年10月27日

最近的帖子

hello Hitoshi, thanks for the answer.
I'll contact Liferay support. and will be back with their answer.
regards