论坛

主页 » Liferay Portal » English » 3. Development

组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
gary b
deploy process hangs
2013年3月8日 上午2:46
答复

gary b

等级: Junior Member

帖子: 77

加入日期: 2013年2月2日

最近的帖子

I am deploying the portlet on local and deploy process hangs here:

 110:25:48,716 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][AutoDeployDir:177] Processing InvestorSignUp-portlet-6.1.1.1.war
 210:25:48,717 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][PortletAutoDeployListener:77] Copying portlets for F:\INVESTED\liferay-portal\deploy\InvestorSignUp-portlet-6.1.1.1.war
 310:25:48,718 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:763] Deploying InvestorSignUp-portlet-6.1.1.1.war
 410:25:48,748 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:859] Updating InvestorSignUp from version 6.1.1.1 to version 6.1.1.1
 5  Expanding: F:\INVESTED\liferay-portal\deploy\InvestorSignUp-portlet-6.1.1.1.war into F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748
 6  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF
 7  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\classes
 8  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\classes
 9  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\jsp
1010:25:49,028 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:2083] Modifying Servlet 2.4 F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748\WEB-INF\web.xml
11  Copying 206 files to F:\INVESTED\liferay-portal\tomcat\webapps\InvestorSignUp-portlet
12  Copying 1 file to F:\INVESTED\liferay-portal\tomcat\webapps\InvestorSignUp-portlet
13  Deleting directory F:\INVESTED\liferay-portal\tomcat\temp\20130308102548748
1410:25:49,574 INFO  [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][PortletAutoDeployListener:87] Portlets for F:\INVESTED\liferay-portal\deploy\InvestorSignUp-portlet-6.1.1.1.war copied successfully. Deployment will start in a few seconds.
158 Mar, 2013 10:25:51 AM org.apache.catalina.startup.HostConfig checkResources
16INFO: Undeploying context [/InvestorSignUp-portlet]
1710:25:51,604 INFO  [ContainerBackgroundProcessor[StandardEngine[Catalina]]][PluginPackageUtil:1033] Reading plugin package for InvestorSignUp-portlet
188 Mar, 2013 10:25:51 AM org.apache.catalina.core.ApplicationContext log
19INFO: Closing Spring root WebApplicationContext
208 Mar, 2013 10:25:52 AM org.apache.catalina.startup.HostConfig deployDirectory
21INFO: Deploying web application directory F:\INVESTED\liferay-portal\tomcat\webapps\InvestorSignUp-portlet
2210:25:52,505 INFO  [pool-2-thread-5][HotDeployImpl:178] Deploying InvestorSignUp-portlet from queue
2310:25:52,505 INFO  [pool-2-thread-5][PluginPackageUtil:1033] Reading plugin package for InvestorSignUp-portlet
24Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/portlet.properties
25Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/service.properties
26Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/portlet.properties
27Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/service.properties
288 Mar, 2013 10:25:52 AM org.apache.catalina.core.ApplicationContext log
29INFO: Initializing Spring root WebApplicationContext
30Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/service.properties
31Loading file:/F:/INVESTED/liferay-portal/tomcat/temp/7-InvestorSignUp-portlet/WEB-INF/classes/portlet.properties

Portlet is working properly and even not giving any error but still not showing 1 portlet is available for use
And when I am deploying the war on production... deploy process hangs on same place and not able to drag the portlet on page.


I am using liferay-6.1.1-ce-ga2.
Please help...
Dipanjan Das
RE: deploy process hangs
2013年3月8日 下午2:00
答复

Dipanjan Das

等级: Junior Member

帖子: 30

加入日期: 2012年9月28日

最近的帖子

You could increase the max perm-size in startup.bat of tomcat to resolve this issue.
Jitendra Rajput
RE: deploy process hangs
2013年3月9日 上午7:19
答复

Jitendra Rajput

等级: Liferay Master

帖子: 858

加入日期: 2011年1月7日

最近的帖子

Basically the log level for deployer located in com.liferay.portal.deploy.hot package are default set to ERROR level. To get your successful deployment message just modify the log level the com.liferay.portal.deploy.hot.*HotDeployListener loggers.


Above changes will be lost if you restart your server so if you want permanent solution then override portal-log4j.xml in your ext - plugin and change below entries.
Set log level to info instead of error.

1<category name="com.liferay.portal.deploy.hot.PortletHotDeployListener">
2        <priority value="INFO" />
3  </category>
Hitoshi Ozawa
RE: deploy process hangs
2013年3月9日 下午11:36
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Is this a custom portlet or a portlet from liferay's Marketplace?
gary b
RE: deploy process hangs
2013年3月10日 下午10:39
答复

gary b

等级: Junior Member

帖子: 77

加入日期: 2013年2月2日

最近的帖子

Hitoshi Ozawa:
Is this a custom portlet or a portlet from liferay's Marketplace?


It 's a custom portlet.
Hitoshi Ozawa
RE: deploy process hangs
2013年3月11日 上午4:38
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

If your custom portlet is hanging, it only means you have a bug in your custom portlet. I don't think anyone can say what's wrong with your portlet because we don't know your portlet.
gary b
RE: deploy process hangs
2013年3月13日 上午4:36
答复

gary b

等级: Junior Member

帖子: 77

加入日期: 2013年2月2日

最近的帖子

Hitoshi Ozawa:
If your custom portlet is hanging, it only means you have a bug in your custom portlet. I don't think anyone can say what's wrong with your portlet because we don't know your portlet.



Actually this is not happening only with one portlet but with all custom portlets.
Jitendra Rajput
RE: deploy process hangs
2013年3月13日 上午5:08
答复

Jitendra Rajput

等级: Liferay Master

帖子: 858

加入日期: 2011年1月7日

最近的帖子

Did you tried by changing log levels from control panel ?
dave ch
RE: deploy process hangs
2013年3月13日 上午7:01
答复

dave ch

等级: Regular Member

帖子: 164

加入日期: 2012年2月6日

最近的帖子

Is this a custom portlet or a portlet from liferay's Marketplace?


I am customizing liferay's Marketplace portlets and getting the same result after deploy, i.e, not getting "portlet is available for use ".
But the portlet is getting deployed and working fine and not giving any error.
What would be the possible reason for this?

Dave
dave ch
RE: deploy process hangs
2013年3月13日 上午7:08
答复

dave ch

等级: Regular Member

帖子: 164

加入日期: 2012年2月6日

最近的帖子

Did you tried by changing log levels from control panel ?


Changing log levels solves my issue.

Thanks.
Jitendra Rajput
RE: deploy process hangs
2013年3月13日 上午7:22
答复

Jitendra Rajput

等级: Liferay Master

帖子: 858

加入日期: 2011年1月7日

最近的帖子

Make sure you modify the same in portal-log4j-ext.xml also other wise log setting will be lost next time when you restart your server.
gary b
RE: deploy process hangs
2013年3月13日 下午10:34
答复

gary b

等级: Junior Member

帖子: 77

加入日期: 2013年2月2日

最近的帖子

Jitendra Rajput:
Make sure you modify the same in portal-log4j-ext.xml also other wise log setting will be lost next time when you restart your server.



Thanks Jitendra,

Changing log levels solves the issue .Sorry for replying late :-)