组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Jignesh Vachhani
Embed portlet in layout using Liferay 6.1.1
2012年11月30日 上午12:23
答复

Jignesh Vachhani

等级: Liferay Master

帖子: 785

加入日期: 2008年3月10日

最近的帖子

Hi Everyone,

I am trying to put navigation portlet in my layout.
Now i am using below code to embed navigation portlet in layout :

$theme.runtime("71_INSTANCE_MAIN", "", $velocityPortletPreferences.toString())

So portlet is being embedded but out side of layout div tags .
Does anybody have any idea ? Is this Liferay OOB error ?
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1 EE GA2
2012年11月30日 上午3:02
答复

Jignesh Vachhani

等级: Liferay Master

帖子: 785

加入日期: 2008年3月10日

最近的帖子

I think I found the issue is ,



1) When i am using $processor.processPortlet

Ans : I used $processor.processPortlet("71_INSTANCE_MAIN") to embed portlet in layout .tpl file
but it can not read this.
I dig the code and found that it seems to be problem in Liferay Code TemplateProcessor.java class
In this class,processPortlet method seems to be using wrong portlet id @ 175 line number. (See below code)
 1
 2public String processPortlet(String portletId) throws Exception {
 3        try {
 4            _request.setAttribute(
 5                WebKeys.RENDER_PORTLET_RESOURCE, Boolean.TRUE);
 6
 7            return RuntimePortletUtil.processPortlet(
 8                _servletContext, _request, _response, null, null, [b]_portletId[/b],
 9                null, false);
10        }
11        finally {
12            _request.removeAttribute(WebKeys.RENDER_PORTLET_RESOURCE);
13        }
14    }


2) When i am using $theme.runtime
Its rendering the code outside of layout and trying to find out the solution
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
2012年12月5日 下午10:51
答复

Jignesh Vachhani

等级: Liferay Master

帖子: 785

加入日期: 2008年3月10日

最近的帖子

Thanks Liferay.

I got patch from liferay and now its working properly.
Karen Smallwood
RE: Embed portlet in layout using Liferay 6.1.1
2013年2月11日 下午8:38
答复

Karen Smallwood

等级: New Member

帖子: 3

加入日期: 2010年5月17日

最近的帖子

I have the same issue. Can you share where you located the patch?
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
2013年2月26日 下午11:17
答复

Jignesh Vachhani

等级: Liferay Master

帖子: 785

加入日期: 2008年3月10日

最近的帖子

you can find this patch from liferay if you are using EE version
Andrew Jardine
RE: Embed portlet in layout using Liferay 6.1.1
2013年10月31日 上午10:48
答复

Andrew Jardine

Community Moderator

等级: Liferay Legend

帖子: 1062

加入日期: 2010年12月22日

最近的帖子

I just ran into the same issue this morning but I have found a work around (CE version, no patch). For me, I used the following line in my layout template and it worked --

$theme.runtime(", '', '')
James Falkner
RE: Embed portlet in layout using Liferay 6.1.1
2014年4月14日 上午7:29
答复

James Falkner

Community Moderator

等级: Liferay Legend

帖子: 1406

加入日期: 2010年9月17日

最近的帖子

Jignesh Vachhani:
1 - Stop Tomcat
2 - Copy the attached liferay-hotfix-110-6120.zip into $LIFERAY_HOME/patching-tool/patches folder
3 - Run 'patching-tool install' at $LIFERAY_HOME/patching-tool folder
4 - Run 'patching-tool info' to ensure that the patch has installed
5 - Start Tomcat


Hey Jignesh, please don't post EE hotfixes to our forums - as they are for enterprise subscription customers only. Thanks!
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
2014年4月14日 上午7:51
答复

Jignesh Vachhani

等级: Liferay Master

帖子: 785

加入日期: 2008年3月10日

最近的帖子

Ohhh Thanks James for reminding me. Removed post