论坛

主页 » Liferay Portal » English » 3. Development

组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Mohammad Danish
Error at deployment..After building the services
2012年11月16日 上午5:44
答复

Mohammad Danish

等级: Regular Member

帖子: 175

加入日期: 2012年3月5日

最近的帖子

Hello everyone.
I am using LR6.1
I am having a service.xml comprising of 100 entities .
Now i am having two scenarios.
1) Setting all the entities like this ..
<entity name="CompanyNote">
<column name="companyNoteID" primary="true" type="long"></column>
<column name="companyNoteCode" type="long"></column>
<column name="isDeleted" type="boolean"></column>
<column name="companyID" type="long"></column>
<column name="date" type="Date"></column>
<column name="userID" type="long"></column>
<column name="note" type="String"></column>
<column name="noteType" type="int"></column>

<column name="extraField1" type="String"></column>
<column name="extraField2" type="String"></column>
<column name="extraField3" type="String"></column>
</entity>
Build services .The building of services goes fine . Also the deployment of the portlet goes fine and the tables are created in the database.
2) Setting all the entities like this ..
<entity name="CompanyNote" local-service="true" remote-service="true">
<column name="companyNoteID" primary="true" type="long"></column>
<column name="companyNoteCode" type="long"></column>
<column name="isDeleted" type="boolean"></column>
<column name="companyID" type="long"></column>
<column name="date" type="Date"></column>
<column name="userID" type="long"></column>
<column name="note" type="String"></column>
<column name="noteType" type="int"></column>

<column name="extraField1" type="String"></column>
<column name="extraField2" type="String"></column>
<column name="extraField3" type="String"></column>
</entity>
Build services .The building of services goes fine. But now when i deploy the portlet i got the following error.
12:47:34,784 INFO [PortletHotDeployListener:503] 1 portlet for IPGMonitor-portlet was unregistered
12:48:35,353 ERROR [PortletApplicationContext:87] org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Bean class [com.ipg.projectmonitor.services.service.impl.AddressTypeLocalServiceImpl] not found
Offending resource: ServletContext resource [/WEB-INF/classes/META-INF/portlet-spring.xml]
Bean 'com.ipg.projectmonitor.services.service.AddressTypeLocalService'; nested exception is java.lang.ClassNotFoundException: com.ipg.projectmonitor.services.service.impl.AddressTypeLocalServiceImpl
org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Bean class [com.ipg.projectmonitor.services.service.impl.AddressTypeLocalServiceImpl] not found
Offending resource: ServletContext resource [/WEB-INF/classes/META-INF/portlet-spring.xml]
Bean 'com.ipg.projectmonitor.services.service.AddressTypeLocalService'; nested exception is java.lang.ClassNotFoundException: com.ipg.projectmonitor.services.service.impl.AddressTypeLocalServiceImpl
at org.springframework.beans.factory.parsing.FailFastProblemReporter.error(FailFastProblemReporter.java:68)
at org.springframework.beans.factory.parsing.ReaderContext.error(ReaderContext.java:85)

附件: error.txt (92.0k)
David H Nebinger
RE: Error at deployment..After building the services
2012年11月16日 上午5:56
答复

David H Nebinger

Community Moderator

等级: Liferay Legend

帖子: 11101

加入日期: 2006年9月1日

最近的帖子

It's telling you what the problem is, a class not found on com.ipg.projectmonitor.services.service.impl.AddressTypeLocalServiceImpl.

If you do not now have an AddressType entity in service.xml, I'm betting that you did and removed the entity. When you do this you need to clean the project otherwise old artifacts linger and you ended up w/ them.