论坛

主页 » Liferay Portal » English » 3. Development

组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Ranen Das
Whats wrong with Liferay
2012年11月9日 上午7:13
答复

Ranen Das

等级: Regular Member

帖子: 137

加入日期: 2011年4月6日

最近的帖子

This is becoming a regular feature - mixing english with other languages???
附件: watsWrongWithLiferay.bmp (1,317.8k)
Florencia Gadea
RE: Whats wrong with Liferay
2012年11月9日 上午7:27
答复

Florencia Gadea

等级: Regular Member

帖子: 146

加入日期: 2012年3月27日

最近的帖子

Yes, it happens to me all the time...
David H Nebinger
RE: Whats wrong with Liferay
2012年11月9日 上午7:30
答复

David H Nebinger

Community Moderator

等级: Liferay Legend

帖子: 11046

加入日期: 2006年9月1日

最近的帖子

I don't know that there is anything wrong here...

Looks like your default locale is set so you see the surrounding content in the locale of your selection.

But forum posts, like mine for example, are done in my locale only. I'm not writing the forum post in all other languages that Liferay supports. So I think you're stuck seeing the original english post...

Other things in the portal itself can and are localized. You can localize your web content, your labels, etc. When the content supports localization, you get the localization.

But if the content does not support localization (i.e. my forum response), the content cannot be localized.

I'll typically use chrome's ability to translate pages when I get to a forum post that is in another language that I'm concerned about. Doesn't do an awesome job (it sucks at translating source code), but typically does enough that I can get the gist of what is being said...
Juan Gonzalez
RE: Whats wrong with Liferay
2012年11月9日 上午11:48
答复

Juan Gonzalez

LIFERAY STAFF

等级: Liferay Legend

帖子: 2794

加入日期: 2008年10月28日

最近的帖子

Happens the same to a mate in office.

I didn't see anything wrong. Probably is a browser language setting misconfiguration, and you can see now because of an upgrade in Liferay.com.
Jack Bakker
RE: Whats wrong with Liferay
2012年11月9日 下午1:49
答复

Jack Bakker

等级: Liferay Master

帖子: 840

加入日期: 2010年1月3日

最近的帖子

I get same thing once in a while but then clear my cache/cookies and all seems fine again

no idea why except that it seems to happen after I google then go to liferay page in other language then find myself in other language by default
Milan Kostoláni
RE: Whats wrong with Liferay
2012年11月12日 上午12:55
答复

Milan Kostoláni

等级: Junior Member

帖子: 92

加入日期: 2012年7月26日

最近的帖子

The thing is that when you someone posts a link to wiki/forum/blog with his personal language option and you click on it, it changes your default language in liferay to language that has that someone as default.

So basically that was you see is not problem with liferay, just your default language changed to Magyar, probably after you clicked on some link to content posted by someone with default language - Magyar. (but I think it can be classified as bug, because it should not change your default language)