论坛

主页 » Liferay Portal » magyarul

组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Adam ANDRASKO
service builder - org.hibernate.ObjectNotFoundException keletkezik
2012年6月25日 上午2:14
答复

Adam ANDRASKO

等级: New Member

帖子: 2

加入日期: 2010年4月22日

最近的帖子

Sziasztok,

Egy érdekes hibába futottam bele, amire egyelőre nem találtam értelmes megoldást, gondoltam megosztom veletek, hátha találkoztatok már hasonlóval.

Környezet: jBoss-4.2.3; Liferay Portal Enterprise Edition 5.2 EE SP4 (Augustine / Build 5208 / May 20, 2009);

Folyamat: egy web service-ről van szó, ami adatbázisba ment le adatokat illetve ad vissza onnan értékeket. A folyamat fontos része, hogy az adatok mentése során a WS kitöröl minden releváns adatot az adatbázisból és felveszi az újakat.

Kód: az adatbázis kód service builder-el lett generálva.

Hibajelenség: az első mentési kérés után az adatvisszanyerés sikeres, viszont a második mentés utáni adat visszakérés során már org.hibernate.ObjectNotFoundException keletkezik. Jobban megnézve a logokat azt láttam, hogy a második mentés utáni adat visszakérésnél még mindig az első mentés során lementett rekordot keresi a hibernate (amit már a második mentési folyamat törölt).

Nem tudom érthetően fogalmaztam-e. Találkozott már valaki hasonló jelenséggel?

üdv,
Ádám
Vilmos Papp
RE: service builder - org.hibernate.ObjectNotFoundException keletkezik
2012年7月10日 下午2:16
答复

Vilmos Papp

LIFERAY STAFF

等级: Liferay Master

帖子: 521

加入日期: 2010年10月21日

最近的帖子

Szia Ádám!

Elég furcsa amit tapasztalsz, esetleg tudsz csatolni egy minta kódot? Akár futtathatót is, amit ki lehet próbálni?

Próbáltad már nem WS-en keresztül lefuttatni a releváns kódrészt? Jó lenne izolálni, hogy magában a generált adatbázis rétegben van-e a gond, vagy a WebService-esítésnél.

Üdv.
Vili