组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
显示 26 结果中的 1 - 20。
的 2
Jaafar Altaie
Error editing web content
2012年4月28日 上午5:07
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

I'm running liferay-portal-6.1.0-ce-ga1 on Win (64 bit) 2008 Server R2

When trying to edit the Welcome page I get an error as soon as I try to save a draft of the edited content.

I looked into a previous bug (http://issues.liferay.com/browse/LPS-12723) but the contents of the files they are refrerring to (ie: ckeditor.jsp) are different in my install. So i don't really understand how to correctly apply the fixes in this bug report and would really appreciate any advice on how to do that.

In case this bug is not the problem, is anybody aware of any problems in this version when it comes to editing default web content?

THANK YOU!
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 上午6:14
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Please attach your console log so we'll know what error you have.
Jaafar Altaie
RE: Error editing web content
2012年4月28日 上午6:23
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

Here it is
附件: liferay.2012-04-27.log (1,087.5k)
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 上午6:44
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

The issue you've shown should be fixed. I'm currently running Liferay 6.1.0 GA1 on Windows 7 64 bit without any error.

Are you using Oracle JDK 1.6? JDK 1.7 is known to cause error and OpenJDK sometimes do to.

Also, is your web content in English with only alphabet characters?
Jaafar Altaie
RE: Error editing web content
2012年4月28日 上午6:49
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

My DB is mySQL and I'm using JDK 1.6 I think. I'm double checking that now in the settings.
Jaafar Altaie
RE: Error editing web content
2012年4月28日 上午6:57
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

From the 'System Properties' I see the following entries:


java.runtime.name

Java(TM) SE Runtime Environment



java.runtime.version

1.6.0_20-b02



java.specification.name

Java Platform API Specification
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 上午7:10
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Java version can be found just by opening a command console and enter "java -version"

There was a similar error when an user was entering non-alphabet character in the title.

Try just entering the following and publishing to see it works.
title: test
content: test content
Jaafar Altaie
RE: Error editing web content
2012年4月28日 上午8:28
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

I confirmed the java version in the command console is the same as in Liferay (1.6). I also tried your suggestion (title: content / test content). I was NOT able to save that as a draft - gave the usual error. Should i try to reinstall Liferay?

BY THE WAY - Now I accidentally CLOSED the content pages after signing in so the portal appears blank. Can you please tell me how to restore the views of the seections in the Welcome page?

Thanks a lot for your help!
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 上午8:33
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Just to be sure, are you using liferay-portal-tomcat-6.1.0-ce-ga1-20120106155615760.zip?

There's no "close" button. Do you mean "delete"?
Jaafar Altaie
RE: Error editing web content
2012年4月28日 上午8:36
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

Yes that's the exact version I"m using.

When you first login as admin there's WEB DISPLAY icons over the sections on the Welcome page. You can select OPTIONS or there's an X which closes the section and I pushed that X so it closed left hand column
Jaafar Altaie
RE: Error editing web content
2012年4月28日 上午9:04
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

I attached a screenshot of what I mean. There's a WEB DISPLAY icon in which you can either select OPTIONS or click the X which closes that particuar section. Since I pressed X the icon no longer shows the CLOSE option just the standard OPTONS and now the page appears blank so I'd like to know how to restore the oriignal web contents. Thanks!
附件: lifreray1.docx (480.4k)
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 下午3:21
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Sorry to say thist, but that "X" is a delete button, not a close button. Now that you've mentioned it, it may be confusing to some people because it's used as close of many OS's.
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 下午3:27
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Getting back to the original question, please try reinstalling. I recommend using 7zip (http://www.7-zip.org/) to extract file from zip. Windows zip sometimes do not extract all files when file name is long.

There's somebody else using the JBoss bundle instead of Tomcat bundle so it should work.

http://www.liferay.com/community/forums/-/message_boards/message/7843068
Jaafar Altaie
RE: Error editing web content
2012年4月28日 下午5:08
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

Hitoshi,

Great advice. Thanks again. Are there any specific steps I should take to 'uninstall'? Do the mySQL Liferay tables/ schema have to be deleted or can I just go ahead and point the new installation to the same mySQL database URL that I'm currently using?
Hitoshi Ozawa
RE: Error editing web content
2012年4月28日 下午11:09
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

If you haven't too much work, it may be better to drop and recreate the database table.
Jaafar Altaie
RE: Error editing web content
2012年4月29日 上午6:25
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

I reinstalled into a brand new DB schema, but still having the same problem. If I try to edit and replace default Welcome text with just the words Title (for title) and Content (in the content area), the request completes sucessfully. I then go to WORKFLAW TASKS to ASSIGN to myself (admin) and APPROVE the edit. When I try to view the page aafter is approved, it is totally BLANK!

Just to make sure I'm going through the right steps to edit the webcontent. I perform the following:

1) Sign in as admin
2) Go to Control Panel
3) Select WEB CONTENT
4) Edit the content
5) Select SUBMIT FOR PUBLICATION
6) Go to Workflow tasks
7) Assign the documeny
8) Approve the document
Jaafar Altaie
RE: Error editing web content
2012年4月29日 下午4:13
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

Well, looking around Google and this forum it seems like editing web content is a limitation of Liferay, I really want to push Liferay as our company portal but not when it has such basic limitations.

The only fix I've seen is http://issues.liferay.com/browse/LPS-12723 but this talks about an earlier version I think since the files described are totally different from the files in my bundle. So any way to apply this fix to my version?
Hitoshi Ozawa
RE: Error editing web content
2012年4月30日 下午2:48
答复

Hitoshi Ozawa

等级: Liferay Legend

帖子: 7949

加入日期: 2010年3月23日

最近的帖子

Are you trying to sample web content? Instead of trying to edit that, delete it and create a new one "Add -> Web Content display".

That said, unless you're just testing this out, recommend you delete the sample 7cogs portlets because they really do cause problems in development and production environment. They should just be used for demos to see what features liferay has.
Jaafar Altaie
RE: Error editing web content
2012年4月30日 下午2:57
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

I'm trying to edit the sample content. I'll add a new page and see if I can edit it. I'll also delete 7cogs and let you know. THANK YOU!
Jaafar Altaie
RE: Error editing web content
2012年4月30日 下午3:49
答复

Jaafar Altaie

等级: Junior Member

帖子: 69

加入日期: 2012年4月26日

最近的帖子

OK deleting the Welcome page makes the app totally unavailable and there's a null pointer exception when calling localhost:8080.

Do I reinstall the app again? How do I get the view back?
显示 26 结果中的 1 - 20。
的 2