组合视图 统一视图 树状图
讨论主题 [ 上一个 | 下一个 ]
toggle
Mario Fagúndez
Tunnel-web war installation with W7 and Liferay 6.0.6
2012年1月5日 上午2:12
答复

Mario Fagúndez

等级: New Member

帖子: 2

加入日期: 2011年11月18日

最近的帖子

Hi all.

I'm having trouble when I try to map a network drive on Windows 7 (neither works on Vista) using it's WebDav URL. (Problems with WebDav and Windows, so typical...). I have tried in the following environments:
1. Liferay 6.0.6 bundled with Tomcat (downloaded from the official site).
2. Liferay 6.0.6 bundled with JBoss (downloaded from the official site).
3. Installing Liferay (6.0.6) on a pre-existent Tomcat.
4. Installing Liferay (6.0.6) on a pre-existent JBoss server.

In 1 and 2 the mapping worked in Windows, but not in 3 and 4 (with a pre-existente server), at the third attempt the following message appears, denying the access:



Despite of this, there is no message in the Liferay log (level ALL). I think that it could be a problem of the Liferay installation in the server, even when I have followed the instructions of "liferay-administrator-guide-6.0.pdf". For the tunnel-web war installation I have just leaved the unzipped folder in /webapps or /server/default/deploy. This works on Linux and MacOs, so is it necessary any aditional configuration for Windows? Anybody knows something about this?

Thanks in advance,
Mario.

P.S. I know that in Liferay 6.0.6 there are some bugs resolved for 6.1.0RC, but I haven´t found any that could affect the mapping, so I think that's not the problem.
P.S.2. I have done the changes in the Windows registry (http://support.microsoft.com/kb/928692) and they are working, because as I said, the first and second cases works without problems.
Juan Gonzalez
RE: Tunnel-web war installation with W7 and Liferay 6.0.6
2012年1月5日 上午2:57
答复

Juan Gonzalez

LIFERAY STAFF

等级: Liferay Legend

帖子: 2794

加入日期: 2008年10月28日

最近的帖子

Mario Fagúndez:
Hi all.

I'm having trouble when I try to map a network drive on Windows 7 (neither works on Vista) using it's WebDav URL. (Problems with WebDav and Windows, so typical...). I have tried in the following environments:
1. Liferay 6.0.6 bundled with Tomcat (downloaded from the official site).
2. Liferay 6.0.6 bundled with JBoss (downloaded from the official site).
3. Installing Liferay (6.0.6) on a pre-existent Tomcat.
4. Installing Liferay (6.0.6) on a pre-existent JBoss server.

In 1 and 2 the mapping worked in Windows, but not in 3 and 4 (with a pre-existente server), at the third attempt the following message appears, denying the access:



Despite of this, there is no message in the Liferay log (level ALL). I think that it could be a problem of the Liferay installation in the server, even when I have followed the instructions of "liferay-administrator-guide-6.0.pdf". For the tunnel-web war installation I have just leaved the unzipped folder in /webapps or /server/default/deploy. This works on Linux and MacOs, so is it necessary any aditional configuration for Windows? Anybody knows something about this?

Thanks in advance,
Mario.

P.S. I know that in Liferay 6.0.6 there are some bugs resolved for 6.1.0RC, but I haven´t found any that could affect the mapping, so I think that's not the problem.
P.S.2. I have done the changes in the Windows registry (http://support.microsoft.com/kb/928692) and they are working, because as I said, the first and second cases works without problems.


Change web.xml in tunnel-web from digest_auth to basic_auth in Secure WebDav
Mario Fagúndez
RE: Tunnel-web war installation with W7 and Liferay 6.0.6
2012年1月5日 上午5:57
答复

Mario Fagúndez

等级: New Member

帖子: 2

加入日期: 2011年11月18日

最近的帖子

Hi Juan. Thanks for your answer.

I've read about this change last days, and I have tested it, but it doesn't work for me, and I can't map the WebDav URL. Notice that in the tunnel-web war provided by bundled version, this param has digest_auth value and it works fine. In addition, I tried using the same tunnel-web folder that is in the bundled version, and nothing happens: I can't map the network drive on the pre-existing JBoss/Tomcat server.

Thanks again,
Mario.