« Back

blade CLI 2.3.0 Released!

Company Blogs November 3, 2017 By Gregory Amerson Staff

We just released latest version of blade cli that includes all of the new npm frontend project templates. This also bumps the rest of the project templates to use latest versions of Liferay gradle and Liferay workspace plugins.

To update simply do $ blade update or for those that haven't installed blade yet, follow the guide here:

https://dev.liferay.com/develop/tutorials/-/knowledge_base/7-0/installing-blade-cli

Then you can update to the latest using the  $ blade update command.  If you receive the following error when you try to execute blade update:

Error
0. [URLClient.send] http://repo.jpm4j.org/jsonrpc/2.0/jpm
Error
0. blade exited with code: 1

That means that your blade executable is too old and you will need to perform the update this way:

$ (sudo) jpm install -f https://releases.liferay.com/tools/blade-cli/latest/blade.jar

After that point, you can just use blade update command going forward.

Also, we have released all new maven archetypes as well, which you can see a full list here.

No comments yet. Be the first.