Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Alan Robertson
Opensocial with apache web server?
19 de Janeiro de 2011 13:58
Resposta

Alan Robertson

Ranking: New Member

Mensagens: 19

Data de entrada: 4 de Novembro de 2010

Mensagens recentes

I have Liferay 6.0.5 (Tomcat bundle) running behind an apache2 web server which is configured to only use https (all http traffic is redirected to https). I've been trying to get opensocial gadgets to work, but they don't work quite right and any image files don't get downloaded correctly.

I've narrowed the problem down to the apache web server. If I bypass apache and go to Liferay on port 8080, the opensocial gadget will work just fine. Does anyone have a solution to this problem?
Michael Young
RE: Opensocial with apache web server?
27 de Janeiro de 2011 20:04
Resposta

Michael Young

LIFERAY STAFF

Ranking: Liferay Master

Mensagens: 847

Data de entrada: 4 de Agosto de 2004

Mensagens recentes

When you are running behind Apache, can you check the urls on the images that are not being returned properly?
Alan Robertson
RE: Opensocial with apache web server?
1 de Fevereiro de 2011 07:39
Resposta

Alan Robertson

Ranking: New Member

Mensagens: 19

Data de entrada: 4 de Novembro de 2010

Mensagens recentes

It's not just the images that are incorrect. Let me show you a small section of the html source of the iframe for a gadget when it's "good" (going directly to Liferay) and when it's "bad" (going through Apache).

When bypassing Apache you get normal html:
1<html><head><style type="text/css">body,td,div,span,p{font-family:arial,sans-serif;}a {color:#0000cc;}a:visited {color:#551a8b;}a:active {color:#ff0000;}body{margin: 0px;padding: 0px;background-color:white;}</style><script>window['__isgadget']=true;</script>


When going through Apache, the html doesn't seem to be rendered correctly:
1<!-- saved from url=(0557)https://liferay.exempla.org/opensocial-portlet/gadgets/ifr?aid=http%3A%2F%2Fwww.labpixies.com%2Fcampaigns%2Ftodo%2Ftodo.xml&container=default&mid=-2010858259&nocache=&country=ALL&lang=ALL&view=default&url=http%3A%2F%2Fwww.labpixies.com%2Fcampaigns%2Ftodo%2Ftodo.xml&parent=http%3A%2F%2Fliferay.exempla.org&st=10507%3A10507%3Ahttp%253A%252F%252Fwww.labpixies.com%252Fcampaigns%252Ftodo%252Ftodo.xml%3Ahttps%253A%252F%252Fliferay.exempla.org%3Ahttp%253A%252F%252Fwww.labpixies.com%252Fcampaigns%252Ftodo%252Ftodo.xml%3A-2010858259%3Adefault#rpctoken=786949598 -->
2<html><body><div class="webkit-line-gutter-backdrop"></div><table><tbody><tr><td class="webkit-line-number"></td><td class="webkit-line-content"><span class="webkit-html-tag">&lt;html&gt;</span><span class="webkit-html-tag">&lt;head&gt;</span><span class="webkit-html-tag">&lt;style <span class="webkit-html-attribute-name">type</span>="<span class="webkit-html-attribute-value">text/css</span>"&gt;</span>body,td,div,span,p{font-family:arial,sans-serif;}a {color:#0000cc;}a:visited {color:#551a8b;}a:active {color:#ff0000;}body{margin: 0px;padding: 0px;background-color:white;}&lt;/style&gt;<span class="webkit-html-tag"></span><span class="webkit-html-tag">&lt;script&gt;</span>window['__isgadget']=true;&lt;/script&gt;

I'll attach the full source for the "good" and the "bad" versions. Hopefully you can figure out what's going on.
Anexos: todo-bad.html (83,9k), todo-good.html (25,7k)
Gustav Novotný
RE: Opensocial with apache web server?
5 de Março de 2012 07:42
Resposta

Gustav Novotný

Ranking: New Member

Mensagens: 10

Data de entrada: 24 de Janeiro de 2012

Mensagens recentes

Hi, is anyone here who solved this kind of problem already? Thanks for reply...