Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Pablo M Mino
Maven portlet: My portlet is running from temp folder, why?
26 de Março de 2010 14:44
Resposta

Pablo M Mino

Ranking: Regular Member

Mensagens: 135

Data de entrada: 2 de Outubro de 2009

Mensagens recentes

Hi,

I made a portlet with jsf, spring, hibernate and maven, when the portlet runs the ApplicationContext sets the web app root to the temp folder, instead to the one in webapps

I've created the same portlet with Plugins SDK and that doesn't happen

So my guess is Plugins SDK does something specific that tells LR how to deploy correctly the portlet, and I'm not doing that on my maven antrun

Can someone help me plz?

Also it doesn't recognize the category correctly, I assume it's the same reason but that's not so urgent

P.S.: moved this from development to see if I could get better results here emoticon
atul patel
RE: Maven portlet: My portlet is running from temp folder, why?
26 de Março de 2010 14:56
Resposta

atul patel

Ranking: Regular Member

Mensagens: 192

Data de entrada: 17 de Novembro de 2006

Mensagens recentes

Take a look at the deployed web.xml for both versions. Is there anything different about the configured listeners?
Pablo M Mino
RE: Maven portlet: My portlet is running from temp folder, why?
26 de Março de 2010 15:29
Resposta

Pablo M Mino

Ranking: Regular Member

Mensagens: 135

Data de entrada: 2 de Outubro de 2009

Mensagens recentes

Both files are exactly the same, didn't knew Liferay add so many things to them btw...
Pablo M Mino
RE: Maven portlet: My portlet is running from temp folder, why?
27 de Março de 2010 22:15
Resposta

Pablo M Mino

Ranking: Regular Member

Mensagens: 135

Data de entrada: 2 de Outubro de 2009

Mensagens recentes

Pablo M Mino:

Also it doesn't recognize the category correctly, I assume it's the same reason but that's not so urgent


Found that my maven is not transforming the liferay-plugin-package.properties to .xml which might solve the problem quoted, I'm not adding any lib from that file anyway

How can I tell my maven-ant-run to create that?

P.S: this means my app is still running from temp, plz help
Pablo M Mino
RE: Maven portlet: My portlet is running from temp folder, why?
5 de Abril de 2010 18:31
Resposta

Pablo M Mino

Ranking: Regular Member

Mensagens: 135

Data de entrada: 2 de Outubro de 2009

Mensagens recentes

I'm a newbie at deploying.... I really need a hand

There must be someone who already created a portlet as a full project with maven