Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Rodrigo Kauer Zuchetto
Installation problem
28 de Maio de 2009 06:19
Resposta

Rodrigo Kauer Zuchetto

Ranking: New Member

Mensagens: 4

Data de entrada: 28 de Maio de 2009

Mensagens recentes

I am not able to install liferay. I tried with the bundle but can not start the Tomcat and isn't displayed any error message. I tried to install Tomcat separately and make the deploy of the war and did not succeed. Can anybody help me?
Lari Tuominen
RE: Installation problem
28 de Maio de 2009 06:32
Resposta

Lari Tuominen

Ranking: Expert

Mensagens: 283

Data de entrada: 7 de Novembro de 2007

Mensagens recentes

Are you sure you don't find any error messages in catalina.out? Also can you see that tomcat starts correctly and that portal is deployed?

In addition what kind of environment do you have (Operating system, Database and JAVA)?

- Lari
Rodrigo Kauer Zuchetto
RE: Installation problem
28 de Maio de 2009 07:13
Resposta

Rodrigo Kauer Zuchetto

Ranking: New Member

Mensagens: 4

Data de entrada: 28 de Maio de 2009

Mensagens recentes

Hi Lari,

Thank you for your attention.

Yeah. I'm sure, I don't find any error messages. Tomcat not starts. The image attached show de messages when I try to to starter tomcat.

My environment is: Windows XP, JDK1.6.0_06 and I don't change the database.
Anexo

Anexos: liferay.PNG (30,1k)
Lari Tuominen
RE: Installation problem
28 de Maio de 2009 15:22
Resposta

Lari Tuominen

Ranking: Expert

Mensagens: 283

Data de entrada: 7 de Novembro de 2007

Mensagens recentes

OK,

Few things

1. Don't install JAVA into the path that contains spaces like C:\Arquivos de programas\ ....... it will only cause troubles.

2. Tomcat log file catalina.out is located in <tomcat-dir>/logs so in your case C:\Temp\liferay-portal-5.2.3\tomcat-6.0.18\logs\catalina.out .... Check errors from that file. Note that you don't see ERRORS in console but in that file!

- Lari
Amos Fong
RE: Installation problem
28 de Maio de 2009 16:02
Resposta

Amos Fong

LIFERAY STAFF

Ranking: Liferay Legend

Mensagens: 1898

Data de entrada: 7 de Outubro de 2008

Mensagens recentes

From your console, it looks like it's not using your java_home. Try checking your JRE_HOME. I think tomcat looks to JRE_HOME first, then to JAVA_HOME if it doesn't exist.
Rodrigo Kauer Zuchetto
RE: Installation problem
29 de Maio de 2009 05:43
Resposta

Rodrigo Kauer Zuchetto

Ranking: New Member

Mensagens: 4

Data de entrada: 28 de Maio de 2009

Mensagens recentes

As you said, I installed Java in "c: \ java". I set the environment variables but still the same thing happening.
I checked the folder "logs" of Tomcat as you said, but the folder is empty.
I also set the JRE_HOME but does't work.
Amos Fong
RE: Installation problem
29 de Maio de 2009 14:00
Resposta

Amos Fong

LIFERAY STAFF

Ranking: Liferay Legend

Mensagens: 1898

Data de entrada: 7 de Outubro de 2008

Mensagens recentes

Olaf Kock
RE: Installation problem
30 de Maio de 2009 13:15
Resposta

Olaf Kock

LIFERAY STAFF

Ranking: Liferay Legend

Mensagens: 3516

Data de entrada: 23 de Setembro de 2008

Mensagens recentes

Where did you set JAVA_HOME?

It's correct, Tomcat uses JRE_HOME first, unless the "debug" parameter is passed to the startup script. Liferay actually comes with it's own (windows only) jre (which I dislike - hint hint), so it should run without any extra java installation.

Your screenshot shows, that it's not your java in C:\java is used, but from C:\arquiv~\java\jre_1.5.07 (which is quite old and outdated, by the way)

You should set your environment variables in tomcat's bin/setenv.bat. See what's already in there and change. You might want to uninstall the old java version (1.5.07) unless you've got some software installed that absolutely positively needs this particular version.

Also, as an extra measure you might want to empty the tomcat directories temp and work (leave the directories in place but make them empty.
Azizi B. Yazit @ Ahmad Zawawi
RE: Installation problem
19 de Junho de 2009 22:05
Resposta

Azizi B. Yazit @ Ahmad Zawawi

Ranking: New Member

Mensagens: 6

Data de entrada: 9 de Abril de 2009

Mensagens recentes

Did you set the CATALINA_HOME and it path?

check this post :

http://www.dzone.com/links/install_the_latest_version_of_liferay522.html