Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Tobias Käfer
problem with message board rss feeds after upgrading from 5.1.1 to 5.2.2
27 de Maio de 2009 04:19
Resposta

Tobias Käfer

Ranking: Regular Member

Mensagens: 128

Data de entrada: 28 de Março de 2008

Mensagens recentes

I just did an update to the Liferay 5.2.2 Version and all message board rss feed from a private page message board of a community do require to login.

Is that a bug or a feature?

With all previous version of Liferay the feeds worked well, but after upgrading to 5.2.2 I cannot access feed of a message board in a private community page.
That makes the use of private message boards a little problematic.

If this is a feature, there should be a property in portal.properties to disable this behavior.
Olaf Kock
RE: problem with message board rss feeds after upgrading from 5.1.1 to 5.2.
27 de Maio de 2009 11:10
Resposta

Olaf Kock

LIFERAY STAFF

Ranking: Liferay Legend

Mensagens: 3425

Data de entrada: 23 de Setembro de 2008

Mensagens recentes

From what you say I'd expect this behaviour from the start. If it's private, I'd be surprised, if there was an url - easy to guess - where the private data was available. If it was public - well...

I've not tried private message boards, but it sounds rather like a bug has been fixed than anything else. I might miss the point though...
Tobias Käfer
RE: problem with message board rss feeds after upgrading from 5.1.1 to 5.2.
27 de Maio de 2009 21:01
Resposta

Tobias Käfer

Ranking: Regular Member

Mensagens: 128

Data de entrada: 28 de Março de 2008

Mensagens recentes

Olaf Kock:
From what you say I'd expect this behaviour from the start. If it's private, I'd be surprised, if there was an url - easy to guess - where the private data was available. If it was public - well...


It was not that way in earlier releases. From Liferay 4.3.x (or so) it was that way!

Olaf Kock:

I've not tried private message boards, but it sounds rather like a bug has been fixed than anything else. I might miss the point though...

If it is a wanted behavior, than it MUST NOT use any kind of an form-based login, since this does not work with any kind of feed-reader, that I know.
If a feed reader does know about authentication, then it knows HTTP Authentication, since it is the only thing that is standardized for HTTP requests.


So eather the former behavior is a bug, then there should be HTTP (Basic) Auth.
Olaf Kock
RE: problem with message board rss feeds after upgrading from 5.1.1 to 5.2.
28 de Maio de 2009 00:34
Resposta

Olaf Kock

LIFERAY STAFF

Ranking: Liferay Legend

Mensagens: 3425

Data de entrada: 23 de Setembro de 2008

Mensagens recentes

Tobias S. Käfer:

Olaf Kock:

I've not tried private message boards, but it sounds rather like a bug has been fixed than anything else. I might miss the point though...

If it is a wanted behavior, than it MUST NOT use any kind of an form-based login, since this does not work with any kind of feed-reader, that I know.
If a feed reader does know about authentication, then it knows HTTP Authentication, since it is the only thing that is standardized for HTTP requests.


So either the former behavior is a bug, then there should be HTTP (Basic) Auth.


Ok, this is the point I've missed. It would render private feeds truly private, but for the price of not rendering them at all, which is certainly wrong & bad.
Rainer Schmitz
RE: problem with message board rss feeds after upgrading from 5.1.1 to 5.2.
12 de Junho de 2009 01:58
Resposta

Rainer Schmitz

Ranking: New Member

Mensagens: 19

Data de entrada: 9 de Novembro de 2005

Mensagens recentes

I'm experiencing the same problem. And it's a blocker, because my users RSS feeds are not updated anymore. And I don't have a way to inform them about the problem, because they won't notice my message :-(

If this is the intended behavior, what is the auth.public.paths property in portal.properties for?

1# Enter a list of comma delimited paths that do not require authentication.
2#
3auth.public.paths=\
4...
5/blogs/rss,\
6...
7/message_boards/rss,\
8...


This seems to express exactly our intended behavior: don't apply any authentication to the rss feed.
Any workaround or at least statement from Liferay?

Thanks,
Rainer
Tobias Käfer
RE: problem with message board rss feeds after upgrading from 5.1.1 to 5.2.
16 de Junho de 2009 00:34
Resposta

Tobias Käfer

Ranking: Regular Member

Mensagens: 128

Data de entrada: 28 de Março de 2008

Mensagens recentes

Rainer Schmitz:
If this is the intended behavior, what is the auth.public.paths property in portal.properties for?


That's the most confusing part of it all!!!

When there is a property, that says, that I don't want to have any kind of authentication for an URL path, why is there an authentication anyhow?
Scott Gibson
RE: problem with message board rss feeds after upgrading from 5.1.1 to 5.2.
9 de Setembro de 2009 08:48
Resposta

Scott Gibson

Ranking: New Member

Mensagens: 19

Data de entrada: 12 de Junho de 2009

Mensagens recentes

Everyone concerned about this issue should be aware of and vote for:

LPS-3622

Although for some reason it won't let me vote. I click on it and it just refreshes without adding a vote.

- Scott