Fóruns

Início » Liferay Portal » Português

Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Ruchi Dubey
Localization liferay6
15 de Março de 2012 07:15
Resposta

Ruchi Dubey

Ranking: New Member

Mensagens: 19

Data de entrada: 28 de Fevereiro de 2012

Mensagens recentes

Hi,
I have done localization in my portlet like this:
In portlet.xml :
<supported-locale>en</supported-locale>
<supported-locale>fr</supported-locale>
<resource-bundle>content/Language</resource-bundle>

I have a Language.properties file in in content folder inside my docroot at the correct location. i have tried a lot but localization is not at all happening.I am gettings labels like ???Label1???.

Please help ...
David H Nebinger
RE: Localization liferay6
15 de Março de 2012 07:18
Resposta

David H Nebinger

Community Moderator

Ranking: Liferay Legend

Mensagens: 11060

Data de entrada: 1 de Setembro de 2006

Mensagens recentes

So do you have the content/Language_fr.properties file w/ the entries for each label?
Hitoshi Ozawa
RE: Localization liferay6
15 de Março de 2012 07:34
Resposta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensagens: 7949

Data de entrada: 23 de Março de 2010

Mensagens recentes

Did you create both Language_en.properties and Language_fr.properties files?
Is "Label1" one of your key?

Did you look at the sample in Liferay svn? (user:guest, no password)
http://svn.liferay.com/repos/public/plugins/trunk/portlets/test-localized-portlet/docroot/
Ruchi Dubey
RE: Localization liferay6
15 de Março de 2012 22:34
Resposta

Ruchi Dubey

Ranking: New Member

Mensagens: 19

Data de entrada: 28 de Fevereiro de 2012

Mensagens recentes

Thanks David and Hitoshi for your replies
Yes I have Language_en and Language_fr properties files in my content folder.
Label1 , I had given as an example.Let me give you some exact data:
I have labels like <fmt:message key="ao.portlet.category" /> in my jsp where ao.portlet.category is a key in Language.en and Language.fr properties files and have given resource bundle in portlet.xml as I have said in earlier post. The strange thing is I have done the same in other portlets and things are working fine.Only in this portlet it is not working.
Also to add, I have done only these three things, is there anything else I am missing?