Fóruns

Início » Liferay Portal » English » 3. Development

Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
paurik bhavsar
Search portlet does not work when put web-content on HOME page
29 de Janeiro de 2012 21:34
Resposta

paurik bhavsar

Ranking: New Member

Mensagens: 21

Data de entrada: 22 de Abril de 2011

Mensagens recentes

Hi Friends,

I created one web-content at my home page.
Now I am log in as normal-user(power user).
Now when I try to search in search portlet, It gives me error like this (You do not have the roles required to access this portlet).
I give the permission to power-user to view the web-content. but still this error is coming.
Archi Madhu
RE: Search portlet does not work when put web-content on HOME page
30 de Janeiro de 2012 01:17
Resposta

Archi Madhu

Ranking: Regular Member

Mensagens: 240

Data de entrada: 24 de Março de 2008

Mensagens recentes

Hello,

Make sure web content is not expired and user has permission to view home page.

-Archi
paurik bhavsar
RE: Search portlet does not work when put web-content on HOME page
30 de Janeiro de 2012 01:49
Resposta

paurik bhavsar

Ranking: New Member

Mensagens: 21

Data de entrada: 22 de Abril de 2011

Mensagens recentes

Hi Archi,
Thanks for giving reply but I selected never auto expire option for web-content and also checked permission for user,power user of home page.
I gave all permission to user and power user of home page. but still this problem coming.
Oliver Bayer
RE: Search portlet does not work when put web-content on HOME page
30 de Janeiro de 2012 02:07
Resposta

Oliver Bayer

Ranking: Liferay Master

Mensagens: 883

Data de entrada: 18 de Fevereiro de 2009

Mensagens recentes

Hi Paurik,

from your description I would guess that the search portlet doesn't have the appropriate permissions. In the control panel under plugin configuration you can set which roles can access each portlet so e.g. add the power user role to the search portlet.

HTH Oli
paurik bhavsar
RE: Search portlet does not work when put web-content on HOME page
30 de Janeiro de 2012 22:40
Resposta

paurik bhavsar

Ranking: New Member

Mensagens: 21

Data de entrada: 22 de Abril de 2011

Mensagens recentes

Hi Oliver

I show search portlet plugin configuration in control panel.
I see following permission there.
The users with the following roles can add this portlet the pages they manage:
Guest,Power User and User.
and also they can view rights.
This problems occurs only when I try search from home page where I put my web-content.
From other menu it search is working fine for user and power user.
There is something problem of web-content.