Liferayは6年連続でGartner Magic Quadrantのリーダーに。 詳細はこちら
« Liferay IDE に戻る

Liferay IDE Installation Guide

Alternative Languages: 日本語

This document is a detailed guide to installation of Liferay IDE.

Requirements #

  • Java 5.0 JRE
  • Eclipse Indigo JavaEE (3.7.x) or greater

Installation steps #

  • 1. Install Eclipse Indigo JavaEE package or greater
  • 2. Run eclipse.exe
  • 3. When eclipse opens, go to Help > Install New Software...
  • 4. Click "Add..." button to open Add Site dialog
  • 5. Type in Liferay IDE for name, and location use one of the following URLs

Eclipse Update sites #

Latest Stable Release URL (1.6.x) - http://releases.liferay.com/tools/ide/latest/stable/

Latest Milestone Release URL (2.x) - http://releases.liferay.com/tools/ide/latest/milestone/ (Unstable version)

  • 6. Select OK
  • 7. Select the Liferay IDE site from the combo selection box.
  • 8. When the table refreshes you should see Liferay Tooling category and one entry for Liferay IDE feature, select the checkbox to install the feature.
  • 9. Click Next and then click Finish to begin the install
  • 10. After plugins download and install you will have to accept that the content is unsigned and then restart eclipse.
  • 11. After you restart, go to Help > About Eclipse and you should see a Icon badge for Liferay IDE that shows you have it properly installed.

Alternative installation #

Check installation #

If everything installed correctly you should be able to begin using the IDE. You can see a getting started tutorial here:

Liferay IDE Getting Started Tutorial

5 添付ファイル
253820 参照数
平均 (14 投票)
平均評価は4.92857142857143星中の5です。
コメント
コメント 作成者 日時
These guides are so helpful! Please keep them... Joel Protivnak 2010/07/14 7:13
I'm having difficulty installing this. I'm... Jessica Dutton 2010/08/18 0:44
Hi Jessica, Sorry you are having troubles. ... Gregory Amerson 2010/08/19 6:51
IF alternative installation fails ... Abhishek Saxena 2010/08/27 7:19
great ..!!! Marlon Viñan 2010/09/20 13:44
its very great... but i have problem with this... Umesh Annegirikar 2010/10/03 22:20
Could you follow up with me over on the forums?... Gregory Amerson 2010/10/12 14:50
I am new to Liferay and am trying to add the... Joshua Spangler 2010/11/29 7:11
Hi Josh, can you post your problems over on the... Gregory Amerson 2011/02/11 12:09
I've been using Galileo, should I switch to... Gavin Headen 2011/02/21 8:11
Yes, the latest IDE version (1.2) is only... Gregory Amerson 2011/02/23 13:05
ServiceBuilder Wizard is not as advanced as... Ruben Gerad Mathew 2011/02/24 22:50
We have plans for adding a visual service... Gregory Amerson 2011/02/28 7:32
I tried it... verbatim. Cannot get past step... Dean Parkinson 2011/03/12 13:26
Hi Dean, The problem is that your eclipse... Gregory Amerson 2011/03/21 10:55
Everytime I try to install the IDE from Eclipse... Dipankar Sengupta 2011/05/09 7:39
That update site is only supported for Eclipse... Gregory Amerson 2011/06/09 15:21
Thank you so much. A very useful page indeed Vijay Mudivedu 2011/10/13 4:00
Just like to add: It says: '# Eclipse Inidigo... Ay Kay 2011/11/22 5:14
Is there a possibility 2 install some liferay... Michal Ocho 2012/07/16 7:14
Hi Michal, There is a much older version of... Gregory Amerson 2012/08/07 12:53
Hey the links for Indigo is not working they... Mradul Ashok 2012/11/05 5:08
Thank you for the article! alexey -bykov 2012/11/12 23:22
If you use Juno, this is the correct link :... Matthieu R. 2012/11/23 0:10
Got following error while installation through... Gradle Son 2013/02/17 8:33
Hello Gradle, Try just installing not using... Gregory Amerson 2013/02/20 21:22
Hello, this manual is not clear at all. Which... Mauricio Cubaque 2014/02/07 9:37
Hey Mauricio, Can you post your issue over on... Gregory Amerson 2014/02/11 0:49
i have installed this successfully.please let... ganesh kumar 2013/05/15 22:16
Hello Ganesh, If you can post your specific... Gregory Amerson 2013/05/20 20:20

These guides are so helpful! Please keep them coming. emoticon
投稿日時:10/07/14 7:13
I'm having difficulty installing this. I'm following the steps exactly, but after eclipse restarts and I go to Help > About Eclipse there is no icon for Liferay. If I click the Installation Details button, Liferay IDE is listed under Installed Software.

Has anyone encountered any similar problems?
投稿日時:10/08/18 0:44
Hi Jessica,

Sorry you are having troubles. Could you post your problem again in the Liferay IDE forums. Hopefully we can get your issue fixed over there.

http://www.liferay.com/community/forums/-/message_boards/category/4627757
Jessica Duttonへのコメント。投稿日時:10/08/19 6:51
IF alternative installation fails

http://www.liferay.com/community/forums/-/message_boards/message/5681419?_19_pre­view=false
Jessica Duttonへのコメント。投稿日時:10/08/27 7:19
its very great...
but i have problem with this installation.whenever i am trying this i get the error as Liferay 1.1 does not have valid license aggrement.
So please resolve this issue
Thanks...
投稿日時:10/10/03 22:20
I am new to Liferay and am trying to add the IDE to Eclipse. I am getting the following error with both the regular installation and the alternative installation:

Cannot complete the install because of a conflicting dependency.
Software being installed: Liferay IDE 1.1.0.v201009141126 (com.liferay.ide.eclipse.tools.feature.group 1.1.0.v201009141126)
Software currently installed: Eclipse Web Developer Tools 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU (org.eclipse.wst.web_ui.feature.feature.group 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU)
Only one of the following can be installed at once:
Java EMF Model Utilities 2.0.200.v200905140200 (org.eclipse.jem.util 2.0.200.v200905140200)
Java EMF Model Utilities 2.0.201.v201001252130 (org.eclipse.jem.util 2.0.201.v201001252130)
Cannot satisfy dependency:
From: Liferay IDE 1.1.0.v201009141126 (com.liferay.ide.eclipse.tools.feature.group 1.1.0.v201009141126)
To: com.liferay.ide.eclipse.ui [1.1.0.v201009141126]
Cannot satisfy dependency:
From: Liferay UI 1.1.0.v201009141126 (com.liferay.ide.eclipse.ui 1.1.0.v201009141126)
To: bundle org.eclipse.jem.util 2.0.201
Cannot satisfy dependency:
From: WST Common Core 3.1.1.v200908102300-7B77FZ3F7RZHIVI9QdN4PM (org.eclipse.wst.common_core.feature.feature.group 3.1.1.v200908102300-7B77FZ3F7RZHIVI9QdN4PM)
To: org.eclipse.jem.util [2.0.200.v200905140200]
Cannot satisfy dependency:
From: WST Web Core 3.1.1.v200908120400-7H77FDAAT7oGlfz0dFV3j0BgbCD7 (org.eclipse.wst.web_core.feature.feature.group 3.1.1.v200908120400-7H77FDAAT7oGlfz0dFV3j0BgbCD7)
To: org.eclipse.wst.common_core.feature.feature.group [3.1.1.v200908102300-7B77FZ3F7RZHIVI9QdN4PM]
Cannot satisfy dependency:
From: Eclipse Web Developer Tools 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU (org.eclipse.wst.web_ui.feature.feature.group 3.1.1.v200908120400-7R77FSpEVw2xXR0CtKvX6bG6a2qU)
To: org.eclipse.wst.web_core.feature.feature.group [3.1.1.v200908120400-7H77FDAAT7oGlfz0dFV3j0BgbCD7]

Does anyone know how to solve the conflicting versions of "Java EMF Model Utilities"?

Thanks, Josh
投稿日時:10/11/29 7:11
Hi Josh, can you post your problems over on the IDE forums? http://www.liferay.com/community/forums/-/message_boards/category/4627757 and I can try to answer your install problem over there.
Joshua Spanglerへのコメント。投稿日時:11/02/11 12:09
I've been using Galileo, should I switch to Helios?
Gregory Amersonへのコメント。投稿日時:11/02/21 8:11
Yes, the latest IDE version (1.2) is only compatible with Helios.
Gavin Headenへのコメント。投稿日時:11/02/23 13:05
ServiceBuilder Wizard is not as advanced as NetBeans plugin. Will there be any updates on the same ? It does not allow adding of elements using a GUI wizard.
Last time I checked Netbeans plugin did not support relationships via GUI inteface can that be incorporated into the new ServiceBuilder in the Eclipse IDE with some updates for the same in Netbeans too ?
投稿日時:11/02/24 22:50
We have plans for adding a visual service builder editor later this year.
Ruben Gerad Mathewへのコメント。投稿日時:11/02/28 7:32
I tried it... verbatim. Cannot get past step 9. The problem is documented over here: http://marketplace.eclipse.org/content/error/report/36226

Is there a fix?
投稿日時:11/03/12 13:26
Hi Dean,

The problem is that your eclipse install doesn't have the full Java EE for Web developers features, i.e. it doesn't have the JSF features from eclipse. You should be able to download WTP(webtools project) features from this updatesite: http://download.eclipse.org/releases/helios/
Dean Parkinsonへのコメント。投稿日時:11/03/21 10:55
Everytime I try to install the IDE from Eclipse Galileo by going to the URL ( http://releases.liferay.com/tools/ide/eclipse/helios/stable/ ) given in this guide, I am being asked id and password and I don't know any id and password for further installation and due to that I get the authentication failed message and the liferay IDE never gets installed within Eclipse. The zip file is also missing some prerequisites. Can some one please let me know what is wrong with the process - It seems very straightforward. I am not able to understand what am I missing here
投稿日時:11/05/09 7:39
That update site is only supported for Eclipse Helios. You mentioned you were trying Eclipse Galileo which is not supported from that update-site. There is a galileo update-site http://releases.liferay.com/tools/ide/eclipse/galileo/stable/ but it is a much older version of Liferay IDE.
Dipankar Senguptaへのコメント。投稿日時:11/06/09 15:21
Thank you so much.

A very useful page indeed
投稿日時:11/10/13 4:00
Just like to add:
It says: '# Eclipse Inidigo (3.7.x) or Eclipse Helios (3.6.x) IDE for Java EE Developers'
I just managed (within a breeze) to install Liferay IDE into Eclipse Indigo (3.7) Java EE Dev
投稿日時:11/11/22 5:14
Is there a possibility 2 install some liferay ide on eclipse indigo 3.5 ?
投稿日時:12/07/16 7:14
Hi Michal,

There is a much older version of Liferay IDE available for Eclipse Galileo (3.5) available. But it is only version 1.1 of Liferay IDE

http://releases.liferay.com/tools/ide/eclipse/galileo/stable/
Michal Ochoへのコメント。投稿日時:12/08/07 12:53
Hey the links for Indigo is not working they say links are no more can you people provide me the link for present repository so that i can install LIferay SDK on my eclipse indigo 3.7.2
Gregory Amersonへのコメント。投稿日時:12/11/05 5:08
投稿日時:12/11/12 23:22
If you use Juno, this is the correct link : http://releases.liferay.com/tools/ide/eclipse/juno/stable/
ivanov -voidへのコメント。投稿日時:12/11/23 0:10
Got following error while installation through Eclipse Market place in sts-3.0.0.RELEASE:

An error occurred while collecting items to be installed
session context wasemoticonprofile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to connect to repository http://releases.liferay.com/tools/ide/eclipse/juno/stable/plugins/org.eclipse.sa­pphire.ui_0.5.4.201210261722.jar
Connection timed out: connect
投稿日時:13/02/17 8:33
Hello Gradle,

Try just installing not using marketplace but by using this URL in the install manager:

http://releases.liferay.com/tools/ide/eclipse/juno/stable/
Gradle Sonへのコメント。投稿日時:13/02/20 21:22
i have installed this successfully.please let me know the next SDK configuration and runtime?

thanks in advance
投稿日時:13/05/15 22:16
Hello Ganesh,

If you can post your specific question over on the IDE forums we can help you better there. Thanks!

http://www.liferay.com/community/forums/-/message_boards/category/4627757­
ganesh kumarへのコメント。投稿日時:13/05/20 20:20
Hello, this manual is not clear at all. Which version of Eclipse must we use to develop something to Liferay 6.1.2 GA3? This link is broken, the SDK with Eclipse Juno in the newsert version says "Error creating Liferay plugin project", no matter which version of Eclipse you use, the new project is not made or at least half made.

Could you please tell us the updated links to download a Eclipse Version, with their respective plugins to make any development? Thanks for your help and soon answer.
Gregory Amersonへのコメント。投稿日時:14/02/07 9:37
Hey Mauricio,

Can you post your issue over on the Liferay IDE forums and we can follow up over there. www.liferay.com/community/forums/-/message_boards/category/4627757
Mauricio Cubaqueへのコメント。投稿日時:14/02/11 0:49