フォーラム

ホーム » Liferay Portal » English » 3. Development

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Subhasis Roy
Error in Forum portlet Permission
2013/04/22 6:57
答え

Subhasis Roy

ランク: Expert

投稿: 284

参加年月日: 2012/01/19

最近の投稿

Hi,

I have added the default Forum portlet of liferay in one of my site pages and then I clicked on the permission button in the Forum portlet.
But I am getting following error:

Error:

05:51:51,263 INFO [PortalImpl:3812] Current URL /null generates exception: null
05:51:51,263 INFO [PortalImpl:3824]


Can anyone please help on this. My site and portlet has the default language as German.
Juan Gonzalez
RE: Error in Forum portlet Permission
2013/04/21 23:59
答え

Juan Gonzalez

LIFERAY STAFF

ランク: Liferay Legend

投稿: 2947

参加年月日: 2008/10/28

最近の投稿

What are the values of these properties in your portal-ext.properties

1redirect.url.*
?

Are you using a load balancer/proxy behind, like Apache?
Subhasis Roy
RE: Error in Forum portlet Permission
2013/04/22 0:50
答え

Subhasis Roy

ランク: Expert

投稿: 284

参加年月日: 2012/01/19

最近の投稿

Juan Gonzalez:
What are the values of these properties in your portal-ext.properties

1redirect.url.*
?

Are you using a load balancer/proxy behind, like Apache?



Hi Juan,

I don't have any entry in the portal-ext.properties also I am not using any load balancer.
Should I need to have any entry.
As Forum is a default Liferay portlet so I guess I don't need to have any setting in the portal-ext.properties file. Please correct me if I am wrong.

Regards,
subhasis
Subhasis Roy
RE: Error in Forum portlet Permission
2013/04/22 7:00
答え

Subhasis Roy

ランク: Expert

投稿: 284

参加年月日: 2012/01/19

最近の投稿

Got the solution.

Added the following key in the portal-ext.properties file

redirect.url.security.mode=domain

The problem is that we have the following entries in our portal-ext.properties file. So at the time of constructing the redirect url for any button hit on the portlet struts is not able to construct the URL. As the default language is not EN. So we added the above line.

#Default country and language
user.country=DE
user.language=de



Reference: http://www.liferay.com/community/forums/-/message_boards/message/5305263