フォーラム

ホーム » Liferay Portal » English » 3. Development

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Imran Khalil
Help Regarding Search Portlet
2012/12/02 23:46
答え

Imran Khalil

ランク: Junior Member

投稿: 36

参加年月日: 2012/10/21

最近の投稿

Hey All, I am wondering why search portlet is having this much issues.

I have added search portlet in my theme as $ themedisply.search(); search is working fine.buit when i search with some user other than administrator, the footer is added into the search Portlet content area. and when i make some congiuration changes in portlet, it just applied when i search from home page. form other pages no configurations are added.
画像の固定

添付ファイル: search.PNG (69.8k)
Oliver Bayer
RE: Help Regarding Search Portlet
2012/12/03 1:44
答え

Oliver Bayer

ランク: Liferay Master

投稿: 883

参加年月日: 2009/02/18

最近の投稿

Hi Imran,

I think this is a css bug in your theme. You can check this by switchting to the classic theme and repeat the search. My guess is that your footer element is missing a "style=clear:both;" css rule. You can test it easily with the firefox plugin firebug.

HTH Oli
Imran Khalil
RE: Help Regarding Search Portlet
2012/12/03 2:10
答え

Imran Khalil

ランク: Junior Member

投稿: 36

参加年月日: 2012/10/21

最近の投稿

No,, Its not a css bug. When i logged in with admin role its fine.. but for normal users its like this.
Oliver Bayer
RE: Help Regarding Search Portlet
2012/12/03 7:26
答え

Oliver Bayer

ランク: Liferay Master

投稿: 883

参加年月日: 2009/02/18

最近の投稿

Hi Imran,

nevertheless I think it's a css bug which can be e.g. related to liferay roles. If e.g. the admin user gets more search results or other results than the normal user this "search portlet result html/css markup" can influence the positioning of the footer. My guess would be that there is only a tiny difference in the resulting markup between the admin and normal users which is causing this effect. So you should take a close look at missing or additional pieces of code.

To narrow it down apply the classic theme of liferay. There you will find a footer: "power by liferay" if I remember right. So you can test the search portlet the same way you did with your theme and check if the footer is still displayed inside the search portlet for normal users. If not it's definetely a css bug off your theme.

Greets Oli
Koen Olaerts
RE: Help Regarding Search Portlet
2013/11/18 6:45
答え

Koen Olaerts

ランク: New Member

投稿: 9

参加年月日: 2010/12/21

最近の投稿

Hello,

I am currently experiencing the same and stumbled across this forum entry. Has there ever been any resolution for this strange behaviour? Even the footer from the classic theme is located inside the results table.
Aldo De Vleeschauwer
RE: Help Regarding Search Portlet
2013/11/21 9:05
答え

Aldo De Vleeschauwer

ランク: Junior Member

投稿: 25

参加年月日: 2011/03/09

最近の投稿

Looks like something related to the way the results HTML is generated and improper exception handling.

So say a <div ..> is opened but not properly closed due to an exception. Then the HTML is messed up.

Search for exceptions in you Liferay log file.