構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Jignesh Vachhani
Embed portlet in layout using Liferay 6.1.1
2012/11/30 0:23
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 792

参加年月日: 2008/03/10

最近の投稿

Hi Everyone,

I am trying to put navigation portlet in my layout.
Now i am using below code to embed navigation portlet in layout :

$theme.runtime("71_INSTANCE_MAIN", "", $velocityPortletPreferences.toString())

So portlet is being embedded but out side of layout div tags .
Does anybody have any idea ? Is this Liferay OOB error ?
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1 EE GA2
2012/11/30 3:02
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 792

参加年月日: 2008/03/10

最近の投稿

I think I found the issue is ,



1) When i am using $processor.processPortlet

Ans : I used $processor.processPortlet("71_INSTANCE_MAIN") to embed portlet in layout .tpl file
but it can not read this.
I dig the code and found that it seems to be problem in Liferay Code TemplateProcessor.java class
In this class,processPortlet method seems to be using wrong portlet id @ 175 line number. (See below code)
 1
 2public String processPortlet(String portletId) throws Exception {
 3        try {
 4            _request.setAttribute(
 5                WebKeys.RENDER_PORTLET_RESOURCE, Boolean.TRUE);
 6
 7            return RuntimePortletUtil.processPortlet(
 8                _servletContext, _request, _response, null, null, [b]_portletId[/b],
 9                null, false);
10        }
11        finally {
12            _request.removeAttribute(WebKeys.RENDER_PORTLET_RESOURCE);
13        }
14    }


2) When i am using $theme.runtime
Its rendering the code outside of layout and trying to find out the solution
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
2012/12/05 22:51
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 792

参加年月日: 2008/03/10

最近の投稿

Thanks Liferay.

I got patch from liferay and now its working properly.
Karen Smallwood
RE: Embed portlet in layout using Liferay 6.1.1
2013/02/11 20:38
答え

Karen Smallwood

ランク: New Member

投稿: 3

参加年月日: 2010/05/17

最近の投稿

I have the same issue. Can you share where you located the patch?
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
2013/02/26 23:17
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 792

参加年月日: 2008/03/10

最近の投稿

you can find this patch from liferay if you are using EE version
Andrew Jardine
RE: Embed portlet in layout using Liferay 6.1.1
2013/10/31 10:48
答え

Andrew Jardine

Community Moderator

ランク: Liferay Legend

投稿: 1080

参加年月日: 2010/12/22

最近の投稿

I just ran into the same issue this morning but I have found a work around (CE version, no patch). For me, I used the following line in my layout template and it worked --

$theme.runtime(", '', '')
James Falkner
RE: Embed portlet in layout using Liferay 6.1.1
2014/04/14 7:29
答え

James Falkner

Community Moderator

ランク: Liferay Legend

投稿: 1406

参加年月日: 2010/09/17

最近の投稿

Jignesh Vachhani:
1 - Stop Tomcat
2 - Copy the attached liferay-hotfix-110-6120.zip into $LIFERAY_HOME/patching-tool/patches folder
3 - Run 'patching-tool install' at $LIFERAY_HOME/patching-tool folder
4 - Run 'patching-tool info' to ensure that the patch has installed
5 - Start Tomcat


Hey Jignesh, please don't post EE hotfixes to our forums - as they are for enterprise subscription customers only. Thanks!
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
2014/04/14 7:51
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 792

参加年月日: 2008/03/10

最近の投稿

Ohhh Thanks James for reminding me. Removed post