構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Miguel Ángel Júlvez
Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/06/27 0:45
答え

Miguel Ángel Júlvez

ランク: Junior Member

投稿: 58

参加年月日: 2011/03/29

最近の投稿

Hi all!

When I deploy liferay war on JBoss 7.1.1.Final everything seems to work fine but I get these logs warnings every time:

09:28:34,815 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'MESSAGE'
09:28:34,815 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'STORAGE_TYPE'
09:28:34,816 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'DESCRIPTION'
09:28:34,816 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'DESTINATION_NAME'
09:28:34,817 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'JOB_STATE'

Any idea?

Thanks!
Hitoshi Ozawa
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/06/30 22:22
答え

Hitoshi Ozawa

ランク: Liferay Legend

投稿: 7949

参加年月日: 2010/03/23

最近の投稿

Probably because org.quartz.scheduler.jobFactory.class is not set in quartz.properties and default to using org.quartz.simpl.PropertySettingJobFactory.
evan ni
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/07/03 22:33
答え

evan ni

ランク: New Member

投稿: 2

参加年月日: 2010/12/27

最近の投稿

I am using tomcat also encounter this problem

I can't find quartz.properties in any place.

How to deal with this problem?

thanks
Manuel Pinto
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/08/20 10:37
答え

Manuel Pinto

ランク: New Member

投稿: 4

参加年月日: 2012/08/20

最近の投稿

I am using liferay 6.1 CE GA2 bundled with JBoss and also found this problem.

Any Idea?

Thanks
Marco Dussin
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/09/28 3:38
答え

Marco Dussin

ランク: Junior Member

投稿: 45

参加年月日: 2010/07/06

最近の投稿

I've that problem too (LR 6.1.0 ce-ga1, Jboss 7)

Any help wiil be appreciated

Thanks a lot

Marco
Ondřej Životský
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/10/01 0:18
答え

Ondřej Životský

ランク: Junior Member

投稿: 29

参加年月日: 2011/03/11

最近の投稿

Liferay store some important informations (MESSAGE, DESCRIPTION, JOB_STATE, ...) to JobDataMap in QuartzSchedulerEngine class. But org.quartz.simpl.PropertySettingJobFactory expects only fields in this map.
If you don't want to see this warnings, set log level for class org.quartz.simpl.PropertySettingJobFactory to ERROR level.
James Falkner
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/10/01 8:28
答え

James Falkner

Community Moderator

ランク: Liferay Legend

投稿: 1406

参加年月日: 2010/09/17

最近の投稿

Ondřej Životský:
Liferay store some important informations (MESSAGE, DESCRIPTION, JOB_STATE, ...) to JobDataMap in QuartzSchedulerEngine class. But org.quartz.simpl.PropertySettingJobFactory expects only fields in this map.
If you don't want to see this warnings, set log level for class org.quartz.simpl.PropertySettingJobFactory to ERROR level.


I believe this is a result of Liferay not configuring the logging level properly - you can see in Control Panel that the log level for org.quartz set to ERROR yet INFO and WARNs are getting through. This does not happen on the Tomcat bundles. I suspect there is an issue with the fix for LPS-27399. IF you set the log level to ERROR through JBoss' recommended log configuration mechanism (I don't have the details but you can search for them) and this eliminates the WARNs I will re-open the bug for you to add details!
Marco Dussin
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/10/02 1:28
答え

Marco Dussin

ランク: Junior Member

投稿: 45

参加年月日: 2010/07/06

最近の投稿

JBoss users must consider also this issue if the configuration page for log levels is missing.

Marco
Marco Dussin
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/10/02 3:11
答え

Marco Dussin

ランク: Junior Member

投稿: 45

参加年月日: 2010/07/06

最近の投稿

I've still the error using CE GA1, also after setting portal-log4j-ext.xml as
1<?xml version="1.0"?>
2<!DOCTYPE log4j:configuration SYSTEM "log4j.dtd">
3<log4j:configuration xmlns:log4j="http://jakarta.apache.org/log4j/">
4<category name="org.quartz.simpl.PropertySettingJobFactory">
5<priority value="ERROR" />
6</category>
7</log4j:configuration>



Marco
Igor Spasić
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
2012/10/19 5:02
答え

Igor Spasić

LIFERAY STAFF

ランク: New Member

投稿: 10

参加年月日: 2010/04/26

最近の投稿

try this: open standalone.xml and set the logging level. For example:
1
2    <profile>
3        <subsystem xmlns="urn:jboss:domain:logging:1.1">
4....
5            <logger category="org.quartz">
6                <level name="ERROR"/>
7            </logger>
8...


source:
http://www.liferay.com/community/wiki/-/wiki/Main/JBoss+AS7+tips#section-JBoss+AS7+tips-Setting+log+level