フォーラム

ホーム » Liferay Portal » magyarul

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Adam ANDRASKO
service builder - org.hibernate.ObjectNotFoundException keletkezik
2012/06/25 2:14
答え

Adam ANDRASKO

ランク: New Member

投稿: 2

参加年月日: 2010/04/22

最近の投稿

Sziasztok,

Egy érdekes hibába futottam bele, amire egyelőre nem találtam értelmes megoldást, gondoltam megosztom veletek, hátha találkoztatok már hasonlóval.

Környezet: jBoss-4.2.3; Liferay Portal Enterprise Edition 5.2 EE SP4 (Augustine / Build 5208 / May 20, 2009);

Folyamat: egy web service-ről van szó, ami adatbázisba ment le adatokat illetve ad vissza onnan értékeket. A folyamat fontos része, hogy az adatok mentése során a WS kitöröl minden releváns adatot az adatbázisból és felveszi az újakat.

Kód: az adatbázis kód service builder-el lett generálva.

Hibajelenség: az első mentési kérés után az adatvisszanyerés sikeres, viszont a második mentés utáni adat visszakérés során már org.hibernate.ObjectNotFoundException keletkezik. Jobban megnézve a logokat azt láttam, hogy a második mentés utáni adat visszakérésnél még mindig az első mentés során lementett rekordot keresi a hibernate (amit már a második mentési folyamat törölt).

Nem tudom érthetően fogalmaztam-e. Találkozott már valaki hasonló jelenséggel?

üdv,
Ádám
Vilmos Papp
RE: service builder - org.hibernate.ObjectNotFoundException keletkezik
2012/07/10 14:16
答え

Vilmos Papp

LIFERAY STAFF

ランク: Liferay Master

投稿: 521

参加年月日: 2010/10/21

最近の投稿

Szia Ádám!

Elég furcsa amit tapasztalsz, esetleg tudsz csatolni egy minta kódot? Akár futtathatót is, amit ki lehet próbálni?

Próbáltad már nem WS-en keresztül lefuttatni a releváns kódrészt? Jó lenne izolálni, hogy magában a generált adatbázis rétegben van-e a gond, vagy a WebService-esítésnél.

Üdv.
Vili