フォーラム

ホーム » Liferay IDE » English

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Peter Hellstrand
Alloy UI
2012/02/02 6:24
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

I have been reading that Alloy UI is included in Liferay 6.X.

What do I need to do?

This will not complie.
1<%@ taglib uri="http://liferay.com/tld/aui" prefix="aui" %>


I tried adding this to the web.xml

1    <taglib>
2        <taglib-uri>http://liferay.com/tld/aui</taglib-uri>
3        <taglib-location>/WEB-INF/tld/liferay-aui.tld</taglib-location>
4    </taglib>


And I also have the alloy-taglib.jar in my path. "Liferay Portal Plugin API".

This ca be found in my liferay-plugin-package.properties.
1portal-dependency-jars=\
2    alloy-taglib.jar,\
3    jstl-impl.jar



How can I use alloy UI?
David H Nebinger
RE: Alloy UI
2012/02/02 6:27
答え

David H Nebinger

Community Moderator

ランク: Liferay Legend

投稿: 12529

参加年月日: 2006/09/01

最近の投稿

What do you mean, it will not compile?

Is the IDE just marking it as an error, or does the ant build script fail when you try to create the portlet? Or is the failure seen when deploying or rendering the portlet?
Peter Hellstrand
RE: Alloy UI
2012/02/02 6:36
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

The IDE is marking it as an error.

Description Resource Path Location Type
Can not find the tag library descriptor for "http://liferay.com/tld/aui" init.jsp /mvc-portlet-portlet/docroot line 8 JSP Problem



ant deploy shows no error message.


Edit: Something is wrong. When I am using

1<aui:form>
2    <aui:input name="productName" size="45" />
3</aui:form>


in /admin/view.jsp

I get "Product Administration is temporarily unavailable."
David H Nebinger
RE: Alloy UI
2012/02/02 6:40
答え

David H Nebinger

Community Moderator

ランク: Liferay Legend

投稿: 12529

参加年月日: 2006/09/01

最近の投稿

1. Well the IDE is famous for not understanding where all of the Liferay bones are buried. I have a hook that is always marked as an error in the IDE because it has an include for a file like "./init.jspf" that I didn't need to hook so didn't copy it in. Deploy time everything works fine, just the IDE doesn't get it.

I wouldn't fret those kinds of issues.

2. When you get the 'not available' message, there's usually a stack trace in the log indicating what your issue is...
Peter Hellstrand
RE: Alloy UI
2012/02/02 6:44
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

Where can I find this log? Not "catalina.out"?
Gregory Amerson
RE: Alloy UI
2012/02/02 17:26
答え

Gregory Amerson

LIFERAY STAFF

ランク: Liferay Legend

投稿: 1079

参加年月日: 2010/02/16

最近の投稿

Peter Hellstrand:
I have been reading that Alloy UI is included in Liferay 6.X.

What do I need to do?

This will not complie.
1<%@ taglib uri="http://liferay.com/tld/aui" prefix="aui" %>


I tried adding this to the web.xml

1    <taglib>
2        <taglib-uri>http://liferay.com/tld/aui</taglib-uri>
3        <taglib-location>/WEB-INF/tld/liferay-aui.tld</taglib-location>
4    </taglib>


And I also have the alloy-taglib.jar in my path. "Liferay Portal Plugin API".

This ca be found in my liferay-plugin-package.properties.
1portal-dependency-jars=\
2    alloy-taglib.jar,\
3    jstl-impl.jar



How can I use alloy UI?


Hi Peter are you trying this on 6.0 or 6.1?
Peter Hellstrand
RE: Alloy UI
2012/02/05 4:04
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

Hi

I am using version 6.1

Thanks!
Gregory Amerson
RE: Alloy UI
2012/02/05 17:13
答え

Gregory Amerson

LIFERAY STAFF

ランク: Liferay Legend

投稿: 1079

参加年月日: 2010/02/16

最近の投稿

Hey Peter,

There was a mix-up with URL/URIs for the aui taglib for 6.1 GA1. This is going ot be addressed by GA2 but for now you can just add this to your web.xml in your IDE project:

1
2<taglib>
3        <taglib-uri>http://liferay.com/tld/aui</taglib-uri>
4        <taglib-location>/WEB-INF/tld/aui.tld</taglib-location>
5</taglib>


Then copy the aui.tld from the portal's tld folder (<tomcat>/webapps/ROOT/WEB-INF/tld/aui.tld) into your project's docroot/WEB-INF/tld

Then to get Eclipse to not mark it as error you will have to close and reopen the project (or restart) eclipse and then re-validate your jsp files.
Pablo Antonio Zamora Ortiz
RE: Alloy UI
2012/02/11 0:10
答え

Pablo Antonio Zamora Ortiz

ランク: Junior Member

投稿: 28

参加年月日: 2011/03/18

最近の投稿

Thank you very much for your contribution and I had the same problem and corrected it with your contribution Thanks
kashika singh
RE: Alloy UI
2013/01/21 5:45
答え

kashika singh

ランク: New Member

投稿: 1

参加年月日: 2013/01/21

最近の投稿

I have liferay-portlet.tld and aui.tld files in WEB-INF/tld folder and I also restarted eclipse but there is still an error on the following lines :


<%@ taglib uri="http://java.sun.com/portlet_2_0" prefix="portlet" %>
<%@ taglib uri="http://liferay.com/tld/aui" prefix="aui" %>


I am using liferay-portal-6.1.1-ce-ga2 and eclipse indigo
Kindly help!!
Tanaji Londhe
RE: Alloy UI
2013/02/05 3:06
答え

Tanaji Londhe

ランク: Regular Member

投稿: 196

参加年月日: 2012/04/25

最近の投稿

make this entry in web.xml file inside the <jsp-config> tag
<taglib>
<taglib-uri>http://liferay.com/tld/aui</taglib-uri>
<taglib-location>/WEB-INF/tld/aui.tld</taglib-location>
</taglib>