Alternative Languages: 日本語

Introduction #

Liferay IDE is an extension for the Eclipse platform that supports development of plug-in projects for the Liferay Portal platform. Its available as a set of Eclipse plug-ins installable from an update-site. The latest version supports developing 5 Liferay plug-in types: portlets, hooks, layout templates, themes, and EXT-style plug-ins. Liferay IDE requires the Eclipse Java EE developer package using either Indigo or Helios versions.

Installation / Releases #

Eclipse Marketplace #

Latest Stable Release #

Latest Milestone Release #

Roadmap for future releases #

Tutorials #

Help / Support #

Contribute to Liferay IDE #

2 Allegati
273841 Visualizzazioni
Media (11 Voti)
La media del punteggio è 4.45454545454545 stelle su 5.
Commenti Autore Data
error when use spring sts! pls fix!can't... arron wu 8 luglio 2010 19.01
Hi. Can you post your specific issue to the... Gregory Amerson 11 gennaio 2011 18.24
Hello. Why I can a "You do not have the... Lucas Raw 12 agosto 2010 11.32
Hi Lucas, For me both logged in and logged out... Gregory Amerson 12 agosto 2010 13.49
Hi.. "Working out to integrate OpenLDAP in... Sigma Infosolutions 18 agosto 2010 4.00
Hello all, I am not able to access Liferay IDE... Dharmender Singh 18 agosto 2010 5.31
Hi, Can something be done about the resolution... William Gosse 19 agosto 2010 8.58
Hi Bill, There is no workaround at the moment... Gregory Amerson 27 agosto 2010 12.13
I tried to follow the videocast... John Joseph Ryan 3 ottobre 2010 13.56
Hi John, Could you post your question over on... Gregory Amerson 6 ottobre 2010 3.15
Hi, Where can I find a changelog for new... Mathieu Hicauber 5 giugno 2012 6.36
Hi Mathieu, You can go to JIRA project for the... Gregory Amerson 11 giugno 2012 1.32
Thanks a lot. Mathieu Hicauber 18 marzo 2013 14.48

error when use spring sts! pls fix!can't setting the sdk path!
Inviato il 08/07/10 19.01.
Hi. Can you post your specific issue to the Liferay IDE forums. I'll do my best to help out.
Inviato il 11/01/11 18.24 in risposta a arron wu.
Hello. Why I can a "You do not have the required permissions." when trying the <•Liferay IDE Developing Liferay Portlets> link?
Or, is there a way to get this permission?
Thank you for the great work!
Inviato il 12/08/10 11.32.
Hi Lucas,

For me both logged in and logged out I'm able to see that wiki article. Could you just try again?
Inviato il 12/08/10 13.49 in risposta a Lucas Raw.

"Working out to integrate OpenLDAP in Liferay to incorporate single sign-on feature" looking for input for the same.

Inviato il 18/08/10 4.00.
Hello all,

I am not able to access Liferay IDE Developing Liferay Portlets link, it show me the error "You do not have the required permissions".

can somebody help me of why i am not able to access this link

thanks in advance
Inviato il 18/08/10 5.31.

Can something be done about the resolution tablibs and class references when creating a a jsp hook. I'd like to be able to use code completion when adding tags, esoecially liferay and aui tags. All the declaration seem to exit in ohter init files in various parts of the html folder.

Is any kind of work around for this issue?

Inviato il 19/08/10 8.58.
Hi Bill,

There is no workaround at the moment for actually getting those references to validate. There is a workaround for removing those error markers so they don't dirty up your project under the validation exclusion settings on the project properties page.

I hope to extend the Eclipse JSP editor in the future to properly resolve those references.
Inviato il 27/08/10 12.13 in risposta a Bill Gosse.
I tried to follow the videocast and continue to get a classNotFound error after trying to add a portlet to the portlet project. The original file edit.jsp works fine but adding the second portlet caused the issue.

WARNING: A docBase /opt/liferay/liferay-portal-6.0.5/tomcat-6.0.26/webapps/JohnDemo-portlet inside the host appBase has been specified, and will be ignored
20:42:25,338 INFO [PortletHotDeployListener:220] Registering portlets for JohnDemo-portlet
20:42:25,518 ERROR [PortletBagFactory:115] java.lang.ClassNotFoundException: com.test.JohnPortlet
java.lang.ClassNotFoundException: com.test.JohnPortlet
at org.apache.catalina.loader.WebappClassLoader.loadClass(­16)
at org.apache.catalina.loader.WebappClassLoader.loadClass(­61)
at com.liferay.portlet.PortletBagFactory.create(
at com.liferay.portal.kernel.servlet.PortletContextListener.doPortalInit(PortletCon­
at com.liferay.portal.kernel.util.BasePortalLifecycle.portalInit(BasePortalLifecycl­
at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.­java:52)
at com.liferay.portal.kernel.util.BasePortalLifecycle.registerPortalLifecycle(BaseP­
at com.liferay.portal.kernel.servlet.PortletContextListener.contextInitialized(Port­
at org.apache.catalina.core.StandardContext.listenerStart(­)
at org.apache.catalina.core.StandardContext.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
­at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.startup.HostConfig.deployDescriptor(
at org.apache.catalina.startup.HostConfig.deployDescriptors(
at­ org.apache.catalina.startup.HostConfig.deployApps(
at org.apache.catalina.startup.HostConfig.check(
at org.apache.catalina.startup.HostConfig.lifecycleEvent(
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.ja­va:119)
at org.apache.catalina.core.ContainerBase.backgroundProcess(­)
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChild­ren(
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChild­ren(
at org.apache.catalina.core.ContainerBase$­
20:42:25,713 INFO [PortletHotDeployListener:369] 1 portlet for JohnDemo-portlet is available for use
Inviato il 03/10/10 13.56 in risposta a Gregory Amerson.
Hi John,

Could you post your question over on the liferay ide forums? I can followup with you there.
Inviato il 06/10/10 3.15 in risposta a John Joseph Ryan.

Where can I find a changelog for new versions ? I saw there's a brand new 1.5.3.v201205280937, but how can I know what's insid e?


Inviato il 05/06/12 6.36.
Hi Mathieu,

You can go to JIRA project for the IDE, click on versions and select the 1.5.3 release and there it will contain a link to the Fixed issues.

Here is a link if you want to just go straight there:­roject+%3D+IDE+AND+fixVersion+%3D+%221.5.3%22+AND+status+%3D+Closed+ORDER+BY+pri­ority+DESC&mode=hide
Inviato il 11/06/12 1.32 in risposta a Mathieu Hicauber.
Inviato il 18/03/13 14.48 in risposta a Gregory Amerson.