« Torna a Liferay IDE

Developing Portlets in Liferay IDE

Portlet Development Demo Video. #

Click the link below to see a video of portlet development demo.

Portlet development demo video

0 Allegati
95723 Visualizzazioni
Media (4 Voti)
La media del punteggio è 3.25 stelle su 5.
Commenti
Commenti Autore Data
I just began a project, and I have to use... Roman Quelen 25 giugno 2010 5.23
The documentation here would not be... Gregory Amerson 26 giugno 2010 10.51
Ok, I'll look this way (although I already made... Roman Quelen 28 giugno 2010 0.51
can any one tell me, is there the screen cast... Heri Parid Pardian 29 giugno 2010 1.06
Not yet but hopefully soon. Gregory Amerson 2 luglio 2010 7.58
I basically did what was described in the... Stefan Moellmann 27 luglio 2010 6.56
The same as Stefan here! It did not happen to... Aritz Galdos 29 luglio 2010 6.17
Same here. I haven't been able to add a simple... Victor Popiol 29 luglio 2010 8.26
I had the same problem with infinite loop of... Peter Sterba 30 luglio 2010 0.12
I have the same problem, I created the... Nicolas Burg 2 agosto 2010 9.09
A work around was posted in the Issue by... Geoff Ruscoe 2 agosto 2010 12.30
This video is great and helps a lot to create... Nicolas Burg 5 agosto 2010 3.01
You will likely have to include the struts jars... Gregory Amerson 5 agosto 2010 8.19
Hey guys, if you want to get the fixed portlet... Gregory Amerson 5 agosto 2010 8.22
I´m a newbie to liferay and pretty frustrated... Antti Kokko 19 agosto 2010 2.39
Try installing the nightly build of the IDE the... Gregory Amerson 19 agosto 2010 6.32
Video seems to be missing. Anyway we could have... Jason Morton 25 agosto 2010 14.03
Hi Jason, I fixed the link. Gregory Amerson 27 agosto 2010 12.15
Hi, Did anyone face problem using service... Sandeep Nair 6 settembre 2010 4.31
I encountered a problem while trying to add... Bindu Lakhanpal 14 settembre 2010 22.38
Hi Bindu That problem will arise if you use... Ramesh K 14 settembre 2010 23.37
I added a new portlet as demonstrated by this... Bindu Lakhanpal 16 settembre 2010 23.54
I am getting the following error when trying to... Michael Smolyak 13 ottobre 2010 6.10
The video is broken/gone? I am logged in but... Keith Freeman 13 ottobre 2010 8.32
Thanks for the note Keith, the permissions... Gregory Amerson 19 ottobre 2010 1.32
The video is gone again. I get the error below.... Eren Senelmis 19 novembre 2011 12.57
New Jira ticket for 404 :... Mike Harris 23 dicembre 2011 6.26
Sorry for the inconvenience. I have fixed the... Gregory Amerson 2 gennaio 2012 20.58
I successfully created a Portlet per this... Neo Foo 8 febbraio 2012 17.41
Hi all, is there any document that is relevant... Vivekanantham Janakiram 30 luglio 2012 3.06

I just began a project, and I have to use Liferay, so I figured the best way to develop new portlets would be the new IDE, but I don't have much time (8 weeks).
It's the first time I have to work with portlets, so it's a little difficult to start without documentation.
Will this documentation be released soon or should I pick another framework to start to work with?
Inviato il 25/06/10 5.23.
The documentation here would not be comprehensive on portlet development in Liferay but rather just how to use the Liferay Portlet wizard in Liferay IDE. But there is lots of information you need online for Liferay 5.2 documentation that would include portlet development.

http://www.liferay.com/documentation/liferay-portal/5.2
Inviato il 26/06/10 10.51 in risposta a Roman Quelen.
Ok, I'll look this way (although I already made a first glance at the documentation).
Inviato il 28/06/10 0.51 in risposta a Gregory Amerson.
can any one tell me, is there the screen cast video tutorial for EXT - Plugin (Liferay portal 6)
Inviato il 29/06/10 1.06.
Not yet but hopefully soon.
Inviato il 02/07/10 7.58 in risposta a Heri Parid Pardian.
I basically did what was described in the video, but when I was trying to add the new portlet to a page in Liferay (as in 2:15 min in the video) the portlet wasn't loaded. It was listed in the selection dialog so it was obviously deployed, but when I added it there was just an animation indicating that it was still loading.

Meanwhile in the console of the Liferay/Tomcat-Server there was an exception being thrown in an infinite loop. The exception starts of with:
"Caused by: javax.portlet.PortletException: javax.servlet.ServletException: javax.portlet.PortletException: javax.servlet.ServletException: javax.portlet.PortletException: javax.servlet.ServletException: Servlet execution threw an exception
at com.liferay.portlet.PortletRequestDispatcherImpl.include(PortletRequestDispatche­rImpl.java:109)"
and is followed by a stack trace of probably hundreds of lines.

What did I do wrong? Why does it work in the video but not on my machine?

These are the software components I am working with:
Eclipse JEE Helios
Liferay Portal Tomcat 6.0.4
Liferay Plugins SDK 6.0.4
Liferay Eclipse Plugin 1.0.1

If you need any more information to understand my problem, feel free to ask!
Any help would be much appreciated!
Inviato il 27/07/10 6.56.
The same as Stefan here!
It did not happen to me with previous versions.
I use exactly the same config as Stefan
Inviato il 29/07/10 6.17 in risposta a Stefan Moellmann.
Same here. I haven't been able to add a simple sample portlet to the portal. The server gets into an infinite loop with exceptions. I'm using the tomcat bundle 6.04 and the plugin sdk 6.04 on Eclipse Helios. Any help will be highly appreciated.

Victor
Inviato il 29/07/10 8.26.
I had the same problem with infinite loop of exceptions. Out of pure desperation I tried to return to the clear starting state, and it worked.
In my case I have delted all the projects from Liferay IDE (including source files), and also all remaining/forgotten portlets from ..liferay-plugins-sdk-6.0.2\portlets\
Inviato il 30/07/10 0.12 in risposta a Victor Popiol.
I have the same problem, I created the following issue : http://issues.liferay.com/browse/IDE-174
I hope a fix will be sent soon emoticon
Inviato il 02/08/10 9.09 in risposta a Peter Sterba.
A work around was posted in the Issue by Gregory Amerson

Here is the quote:
Hey guys, this problem has been fixed in SVN but I haven't gotten the nightly builds fixed as I haven't had a chance to discuss the issue with Brian Chan.

But it is easy to avoid it with the current release of the IDE by simply changing the name of the JSP folder for the mode jsps to be something other than an exact match for the portlet name. See issue IDE-160

-----

Super big thanks to everyone for such a quick reply. I have tested the work around and passed it along to coworkers.

Cheers!
Inviato il 02/08/10 12.30 in risposta a Nicolas Burg.
This video is great and helps a lot to create simple portlets.

But, is it possible to have a demo of how to develop portlet with struts actions?

I've tried to modify the portlet.xml to make a StrutsPortlet but the class was missing in my libs... Is there a tutorial somewhere on how to implement solutions with struts actions in a new portlet using liferay ide and liferay-plugins-sdk?
Inviato il 05/08/10 3.01.
You will likely have to include the struts jars in your portal dependency jars in the liferay-plugin-package.properties. I hope to support more struts development in the future that will make it more straight forward.
Inviato il 05/08/10 8.19 in risposta a Nicolas Burg.
Hey guys, if you want to get the fixed portlet wizard that avoids the infinite loop exceptions you can install the nightly build (development stream) here:

http://releases.liferay.com/tools/ide/eclipse/helios/nightly/
Inviato il 05/08/10 8.22.
I´m a newbie to liferay and pretty frustrated since I´ve been figthing with this infinite loop for couple of days and nothing seems to work out. I tried to rename the folder and installed the nightly build but still no success.
Inviato il 19/08/10 2.39 in risposta a Gregory Amerson.
Try installing the nightly build of the IDE the infinite loop bug has been fixed.

http://releases.liferay.com/tools/ide/eclipse/helios/nightly/
Inviato il 19/08/10 6.32 in risposta a Antti Kokko.
Video seems to be missing. Anyway we could have that video back?
Inviato il 25/08/10 14.03 in risposta a Gregory Amerson.
Hi Jason, I fixed the link.
Inviato il 27/08/10 12.15 in risposta a Jason Morton.
Hi,

Did anyone face problem using service builder in the IDE. First time it works fine. When i tried to add another entity and try to build-service and then deploy it gave me error in the server. So i switched back to using service builder from command prompt.
Inviato il 06/09/10 4.31 in risposta a Gregory Amerson.
I encountered a problem while trying to add portlet.
I signed in using test@liferay.com and test as password.
When i am trying to add by clicking the green add button,there is a continouus Loading.. message appearing in the small box..
Inviato il 14/09/10 22.38.
Hi Bindu
That problem will arise if you use browser version below IE7 & mozilla below 3.5
so use greater versions to work
for more info click this link.
http://www.liferay.com/community/forums/-/message_boards/message/5673473


Tha­nks & Regards
Ramesh K
Inviato il 14/09/10 23.37 in risposta a Bindu Lakhanpal.
I added a new portlet as demonstrated by this video.But there were no "Preferences" and "Help" options at 2:44.Only "Look and Feel" and "configuration" options are there.
Inviato il 16/09/10 23.54.
I am getting the following error when trying to watch the video.

You do not have permission to access the requested resource.

http://www.liferay.com/c/document_library/get_file?p_l_id=5630538&groupId=461583­7&folderId=4933105&name=DLFE-40608.swf

Michael
Inviato il 13/10/10 6.10.
The video is broken/gone? I am logged in but get this error when I click the link:

Forbidden

You do not have permission to access the requested resource.

http://www.liferay.com/c/document_library/get_file?p_l_id=5630538&groupId=461583­7&folderId=4933105&name=DLFE-40608.swf
Inviato il 13/10/10 8.32.
Thanks for the note Keith, the permissions should be fixed now.
Inviato il 19/10/10 1.32 in risposta a Keith Freeman.
The video is gone again. I get the error below.

The requested resource was not found.

http://www.liferay.com/c/document_library/get_file?p_l_id=5630538&groupId=­4615837&folderId=4933105&name=DLFE-40608.swf
Inviato il 19/11/11 12.57 in risposta a Gregory Amerson.
New Jira ticket for 404 :
http://issues.liferay.com/browse/IDE-526
Inviato il 23/12/11 6.26 in risposta a Eren Senelmis.
Sorry for the inconvenience. I have fixed the video link.
Inviato il 02/01/12 20.58.
I successfully created a Portlet per this video. The problem I'm having is modifications to my JSP don't appear when I refresh the web page hosting my portlet.

The only way I can get my JSP changes to show up in the browser is to right click on my project in Eclipse then select Liferay -> SDK -> Deploy. Then when I refresh the page hosting my portlet I can see the changes.

How can I make the modifications to my project files automatically deploy?
Inviato il 08/02/12 17.41.
Hi all, is there any document that is relevant to the developing the custom portlet using Eclipse IDE.
Inviato il 30/07/12 3.06.