Tribune

Home » Liferay Portal » English » 3. Development

Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Luca Lupo
Date on Liferay - Bug or Not?
21 novembre 2012 1.36
Risposta

Luca Lupo

Punteggio: Regular Member

Messaggi: 106

Data di Iscrizione: 1 ottobre 2012

Messaggi recenti

Hi Guys, I realized that there might be another important bug out there.

Basically, if you create an article the displayDate is correct (current day). But when you modify an existing one, in particular when you modify one or all of the date (Display, Expirtaion, Review) those dates are save on the DB with one day plus. Then, going in control panel->web content (on left menu) you can see an overview of the articles present on the portal and here the display date is decremented by one.

How can I fix that without doing 3-4 hooks?

Thanks

Luca
Hitoshi Ozawa
RE: Date on Liferay - Bug or Not?
21 novembre 2012 13.49
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7949

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

Have you checked if it's not the time zone issue?
Luca Lupo
RE: Date on Liferay - Bug or Not?
22 novembre 2012 4.03
Risposta

Luca Lupo

Punteggio: Regular Member

Messaggi: 106

Data di Iscrizione: 1 ottobre 2012

Messaggi recenti

I didn't know about this issue...could you tell me more about it?

Thanks

Luca
Ezequiel Turovetzky
RE: Date on Liferay - Bug or Not?
14 febbraio 2013 15.48
Risposta

Ezequiel Turovetzky

Punteggio: New Member

Messaggi: 12

Data di Iscrizione: 4 luglio 2012

Messaggi recenti

Hi, guys! Same problem here! In my case, this happened suddenly, everything was working fine until today.
Did you find anything?
Ezequiel Turovetzky
RE: Date on Liferay - Bug or Not?
14 febbraio 2013 16.33
Risposta

Ezequiel Turovetzky

Punteggio: New Member

Messaggi: 12

Data di Iscrizione: 4 luglio 2012

Messaggi recenti

Ok, this is what we did. Last week we changed the default timezone from America/Los_Angeles to America/Sao_Paulo, but we didn't restart the servers... until today, and that's when the problem showed up.

Now, we've changed the default time zone back to America/Los_Angeles and we restarted the server, and the problem went off. I can change back to America/Sao_Paulo but I know that when restarting the servers the problem is going to show up again.

I think there's a bug there, isn't?

Regards,
Ezequiel
David H Nebinger
RE: Date on Liferay - Bug or Not?
15 febbraio 2013 6.21
Risposta

David H Nebinger

Community Moderator

Punteggio: Liferay Legend

Messaggi: 11087

Data di Iscrizione: 1 settembre 2006

Messaggi recenti

Ezequiel Turovetzky:
I think there's a bug there, isn't?


No, it's not a bug.

Dates are stored in the database as GMT. When you change the timezone (either as a user or the server default timezone), you're only affecting how the dates are displayed.

All you were seeing was the date in the America/San_Paulo timezone format, but the underlying dates remain the same.