Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Wassim Kattan
Liferay setup on Centos
3 luglio 2012 10.00
Risposta

Wassim Kattan

Punteggio: New Member

Messaggi: 1

Data di Iscrizione: 3 luglio 2012

Messaggi recenti

Hi Everyone,

This is the first time I set up Liferay on a Centos machine, and I keep running into a weird problem.

This is the guide I followed: http://www.liferay.com/community/wiki/-/wiki/Main/Quick+Installation+Instructions

I have the latest Java installed , and have the liferay with tomcat bundle downloaded, copied to /usr , unzipped it there and did something very similar to this: Linux/OSX: cd /{directory}/liferay-{version}/tomcat-{version}/bin ./startup.sh }}}

here is what I get:


[root@webserver bin]# ./startup.sh
Using CATALINA_BASE: /usr/liferay-portal-6.0.6/tomcat-6.0.29
Using CATALINA_HOME: /usr/liferay-portal-6.0.6/tomcat-6.0.29
Using CATALINA_TMPDIR: /usr/liferay-portal-6.0.6/tomcat-6.0.29/temp
Using JRE_HOME: /usr
Using CLASSPATH: /usr/liferay-portal-6.0.6/tomcat-6.0.29/bin/bootstrap.jar
[root@webserver bin]#


and nothing happens afterwards... I tried to go to serveripaddress:8080 , nothing... IPtables are down, and Webmin is accessible (which means nothing wrong with network or iptables).

Any ideas on what I could be doing wrong?

Thanks
Linus Sphinx
RE: Liferay setup on Centos
3 luglio 2012 11.09
Risposta

Linus Sphinx

Punteggio: Junior Member

Messaggi: 89

Data di Iscrizione: 12 agosto 2010

Messaggi recenti

Looks like it's starting up, execute as root;
# netstat -ant
and see if you can figure out what address the port is bound to, may only be listening on localhost.
Check the file /usr/liferay-portal-6.0.6/tomcat-6.0.29/logs/catalina.out, will usually complain loudly in there what the exact problem is.
Hitoshi Ozawa
RE: Liferay setup on Centos
3 luglio 2012 15.41
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7949

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

have the latest Java installed


This may not be the problem, but Liferay doesn't support JDK 1.7 nor OpenJDK. You'll have to use Oracle JDK 1.6

As to your question, try ps -ef to find is the process is up or not and look in tomcat log file to see if there's any error.
Chris Daly
RE: Liferay setup on Centos
16 maggio 2013 7.21
Risposta

Chris Daly

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 16 maggio 2013

Messaggi recenti

Was this issue ever resolved because I get the same error. Oracle no longer supports JDK 1.6 (according to their web-site). I have JDK 1.7 installed as well and get the exact same error.