Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Bruno Conrado Santos
How to intall liferay on JBOSS 7.1 like domain mode?
18 giugno 2012 12.09
Risposta

Bruno Conrado Santos

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 21 marzo 2012

Messaggi recenti

Hi everyone.

I configured liferay with Jboss AS 7.1 on standalone mode on existent AS with success.

Now i'm trying to configure on domain mode for use cluster but i had problems.

This is the stack trace;

 1
 2
 318:27:50,410 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015876: Starting deployment of "ROOT.war"
 418:28:27,181 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-4) Class Path entry commons-cli.jar in "/content/ROOT.war/WEB-INF/lib/xuggle-xuggler.jar"  does not point to a valid jar for a Class-Path reference.
 518:28:27,200 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-4) Class Path entry logback-classic.jar in "/content/ROOT.war/WEB-INF/lib/xuggle-xuggler.jar"  does not point to a valid jar for a Class-Path reference.
 618:28:27,202 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-4) Class Path entry logback-core.jar in "/content/ROOT.war/WEB-INF/lib/xuggle-xuggler.jar"  does not point to a valid jar for a Class-Path reference.
 718:28:27,205 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-4) Class Path entry unoloader.jar in "/content/ROOT.war/WEB-INF/lib/jurt.jar"  does not point to a valid jar for a Class-Path reference.
 818:29:11,447 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."ROOT.war".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."ROOT.war".STRUCTURE: Failed to process phase STRUCTURE of deployment "ROOT.war"
 9    at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
10    at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
11    at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
12    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_26]
13    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_26]
14    at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_26]
15Caused by: java.lang.IllegalArgumentException: Given parent is not an ancestor of this virtual file
16    at org.jboss.vfs.VirtualFile.getPathNameRelativeTo(VirtualFile.java:116) [jboss-vfs-3.1.0.Final.jar:3.1.0.Final]
17    at org.jboss.vfs.VirtualFile.getPathNameRelativeTo(VirtualFile.java:122) [jboss-vfs-3.1.0.Final.jar:3.1.0.Final]
18    at org.jboss.vfs.VirtualFile.getPathNameRelativeTo(VirtualFile.java:110) [jboss-vfs-3.1.0.Final.jar:3.1.0.Final]
19    at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.createAdditionalModule(ManifestClassPathProcessor.java:193) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
20    at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.handlingExistingClassPathEntry(ManifestClassPathProcessor.java:185) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
21    at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.deploy(ManifestClassPathProcessor.java:162) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
22    at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
23    ... 5 more
24
2518:29:11,490 INFO  [org.jboss.as.server] (host-controller-connection-threads - 1) JBAS015870: Deploy of deployment "ROOT.war" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"ROOT.war\".STRUCTURE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"ROOT.war\".STRUCTURE: Failed to process phase STRUCTURE of deployment \"ROOT.war\""}}
2618:29:11,504 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015877: Stopped deployment ROOT.war in 14ms
2718:29:11,508 INFO  [org.jboss.as.controller] (host-controller-connection-threads - 1) JBAS014774: Service status report
28JBAS014777:   Services which failed to start:      service jboss.deployment.unit."ROOT.war".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."ROOT.war".STRUCTURE: Failed to process phase STRUCTURE of deployment "ROOT.war"


I did step by step from this site: http://blogs.xtivia.com/home/-/blogs/configuring-liferay-6-1-ce-ga1-on-jboss-7-0-2-as-a-managed-domain?_33_redirect=null

The steps is very similar of configuretion found in liferay wiki for JBOSS AS 7.0.x

Could you help me?

Thanks
Hitoshi Ozawa
RE: How to intall liferay on JBOSS 7.1 like domain mode?
23 giugno 2012 5.39
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7949

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

Are you trying to share liferay's deploy directory and data directory and share cache memory by running in domain mode?
Bruno Conrado Santos
RE: How to intall liferay on JBOSS 7.1 like domain mode?
3 luglio 2012 5.16
Risposta

Bruno Conrado Santos

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 21 marzo 2012

Messaggi recenti

Hitoshi Ozawa:
Are you trying to share liferay's deploy directory and data directory and share cache memory by running in domain mode?



No, I'm not.
Peter Oostenbach
RE: How to intall liferay on JBOSS 7.1 like domain mode?
13 luglio 2012 5.00
Risposta

Peter Oostenbach

Punteggio: New Member

Messaggi: 1

Data di Iscrizione: 13 luglio 2012

Messaggi recenti

I'm having the same error on a JBOSS 7.1.1 domain with two JBOSS instances. Each JBOSS has his own liferay directory. The only thing we use is the cluster.link in the liferay properties. I wonder if anybody has made progress with a solution. Thanks.
Bruno Conrado Santos
RE: How to intall liferay on JBOSS 7.1 like domain mode?
16 luglio 2012 8.51
Risposta

Bruno Conrado Santos

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 21 marzo 2012

Messaggi recenti

Peter Oostenbach:
I'm having the same error on a JBOSS 7.1.1 domain with two JBOSS instances. Each JBOSS has his own liferay directory. The only thing we use is the cluster.link in the liferay properties. I wonder if anybody has made progress with a solution. Thanks.


I don't understand... but i was tried to deploy liferay using one server first(master only), after i will configure other server to use cluster. Why this doesn't work? Can you show me your domain.xml? How much instances do you use in your master?
Héctor Giner
RE: How to intall liferay on JBOSS 7.1 like domain mode?
26 novembre 2012 0.33
Risposta

Héctor Giner

Punteggio: New Member

Messaggi: 5

Data di Iscrizione: 24 ottobre 2012

Messaggi recenti

Hi all.

I have the same problem. Is there any solution for this issue?
I'm trying to deploy Liferay 6.1.1-CE-GA2 on JBoss AS 7.1.1 without success.

Thanks.
Bruno Conrado Santos
RE: How to intall liferay on JBOSS 7.1 like domain mode?
26 novembre 2012 2.59
Risposta

Bruno Conrado Santos

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 21 marzo 2012

Messaggi recenti

Héctor Giner:
Hi all.

I have the same problem. Is there any solution for this issue?
I'm trying to deploy Liferay 6.1.1-CE-GA2 on JBoss AS 7.1.1 without success.

Thanks.


Hi Héctor Giner!

Unfortunately i don't have any solution for this. I tried find some thing and find some help but i didn't find a solution.
So, now i don't now what i will do.

If you have some idea please help me.
Hitoshi Ozawa
RE: How to intall liferay on JBOSS 7.1 like domain mode?
26 novembre 2012 3.24
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7949

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

For all I know, this doesn't work correctly. We've tried it and encountered errors during operation. Best to use JBoss in standalone mode.
Jack Chung
RE: How to intall liferay on JBOSS 7.1 like domain mode?
27 novembre 2012 16.18
Risposta

Jack Chung

Punteggio: New Member

Messaggi: 19

Data di Iscrizione: 30 novembre 2011

Messaggi recenti

There is a JBOSS bug in 7.1.1 regarding domain mode: https://community.jboss.org/thread/197430

I had to use 7.1.2, which I had to compile from the JBOSS github source, for a successful test with domain mode and Liferay 6.1
Héctor Giner
RE: How to intall liferay on JBOSS 7.1 like domain mode?
1 febbraio 2013 1.41
Risposta

Héctor Giner

Punteggio: New Member

Messaggi: 5

Data di Iscrizione: 24 ottobre 2012

Messaggi recenti

Hi.

I finally found a solution compiling 1.7.3 release from the JBOSS github source. Also, I needed to add some jar refs into /modules/com/liferay/portal/main like jruby.jar and jruby-gems.jar. Now, the deployment in domain mode is fine but I found another problem emoticon

I have to use JSON web service API for functionality integration. The list of REST services available can be found in /liferay_url/api/jsonws. If I run the standalone mode the services are available, but if I start the domain mode, the list is empty. The startup log shows an error message:

[Server:liferay] 10:30:14,466 INFO (MSC service thread 1-4) 10:30:14,464 ERROR [MSC service thread 1-4][ClassPathUtil:173] Class com.liferay.portal.servlet.MainServlet is not loaded from a standard location (/WEB-INF/classes)

This error doesn't affect to Liferay behaviour in domain mode, but could be linked with the JSON webservices autodiscover error.

Any help, please?
Juan Carlos Toledo Baute
RE: How to intall liferay on JBOSS 7.1 like domain mode?
23 aprile 2013 1.48
Risposta

Juan Carlos Toledo Baute

Punteggio: Junior Member

Messaggi: 50

Data di Iscrizione: 30 marzo 2011

Messaggi recenti

Héctor Giner:
Hi.


[Server:liferay] 10:30:14,466 INFO (MSC service thread 1-4) 10:30:14,464 ERROR [MSC service thread 1-4][ClassPathUtil:173] Class com.liferay.portal.servlet.MainServlet is not loaded from a standard location (/WEB-INF/classes)

This error doesn't affect to Liferay behaviour in domain mode, but could be linked with the JSON webservices autodiscover error.

Any help, please?


Hi

I have the same problems as Jboss-7.2.0 and Liferay 6.1.1-ce cga2.

I tried this solution and it did not work, http://stackoverflow.com/questions/14643819/liferay-json-web-services-visibility-in-jboss-domain-mode

Does it work for you?

Thanks
Héctor Giner
RE: How to intall liferay on JBOSS 7.1 like domain mode?
23 aprile 2013 1.58
Risposta

Héctor Giner

Punteggio: New Member

Messaggi: 5

Data di Iscrizione: 24 ottobre 2012

Messaggi recenti

Juan Carlos Toledo Baute:
Héctor Giner:
Hi.


[Server:liferay] 10:30:14,466 INFO (MSC service thread 1-4) 10:30:14,464 ERROR [MSC service thread 1-4][ClassPathUtil:173] Class com.liferay.portal.servlet.MainServlet is not loaded from a standard location (/WEB-INF/classes)

This error doesn't affect to Liferay behaviour in domain mode, but could be linked with the JSON webservices autodiscover error.

Any help, please?


Hi

I have the same problems as Jboss-7.2.0 and Liferay 6.1.1-ce cga2.

I tried this solution and it did not work, http://stackoverflow.com/questions/14643819/liferay-json-web-services-visibility-in-jboss-domain-mode

Does it work for you?

Thanks


It doesn't. I found my own solution debugging the web services publication process during the server startup.
All you have to do is to copy the jars contained in ROOT.war/WEB-INF/lib to an external folder and declare it in portal-ext.properties like following:

1liferay.lib.portal.dir=/full_path/liferay_libs