Tribune

Home » Liferay IDE » English

Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Peter Hellstrand
Alloy UI
2 febbraio 2012 6.24
Risposta

Peter Hellstrand

Punteggio: Regular Member

Messaggi: 167

Data di Iscrizione: 30 novembre 2011

Messaggi recenti

I have been reading that Alloy UI is included in Liferay 6.X.

What do I need to do?

This will not complie.
1<%@ taglib uri="http://liferay.com/tld/aui" prefix="aui" %>


I tried adding this to the web.xml

1    <taglib>
2        <taglib-uri>http://liferay.com/tld/aui</taglib-uri>
3        <taglib-location>/WEB-INF/tld/liferay-aui.tld</taglib-location>
4    </taglib>


And I also have the alloy-taglib.jar in my path. "Liferay Portal Plugin API".

This ca be found in my liferay-plugin-package.properties.
1portal-dependency-jars=\
2    alloy-taglib.jar,\
3    jstl-impl.jar



How can I use alloy UI?
David H Nebinger
RE: Alloy UI
2 febbraio 2012 6.27
Risposta

David H Nebinger

Community Moderator

Punteggio: Liferay Legend

Messaggi: 11295

Data di Iscrizione: 1 settembre 2006

Messaggi recenti

What do you mean, it will not compile?

Is the IDE just marking it as an error, or does the ant build script fail when you try to create the portlet? Or is the failure seen when deploying or rendering the portlet?
Peter Hellstrand
RE: Alloy UI
2 febbraio 2012 6.36
Risposta

Peter Hellstrand

Punteggio: Regular Member

Messaggi: 167

Data di Iscrizione: 30 novembre 2011

Messaggi recenti

The IDE is marking it as an error.

Description Resource Path Location Type
Can not find the tag library descriptor for "http://liferay.com/tld/aui" init.jsp /mvc-portlet-portlet/docroot line 8 JSP Problem



ant deploy shows no error message.


Edit: Something is wrong. When I am using

1<aui:form>
2    <aui:input name="productName" size="45" />
3</aui:form>


in /admin/view.jsp

I get "Product Administration is temporarily unavailable."
David H Nebinger
RE: Alloy UI
2 febbraio 2012 6.40
Risposta

David H Nebinger

Community Moderator

Punteggio: Liferay Legend

Messaggi: 11295

Data di Iscrizione: 1 settembre 2006

Messaggi recenti

1. Well the IDE is famous for not understanding where all of the Liferay bones are buried. I have a hook that is always marked as an error in the IDE because it has an include for a file like "./init.jspf" that I didn't need to hook so didn't copy it in. Deploy time everything works fine, just the IDE doesn't get it.

I wouldn't fret those kinds of issues.

2. When you get the 'not available' message, there's usually a stack trace in the log indicating what your issue is...
Peter Hellstrand
RE: Alloy UI
2 febbraio 2012 6.44
Risposta

Peter Hellstrand

Punteggio: Regular Member

Messaggi: 167

Data di Iscrizione: 30 novembre 2011

Messaggi recenti

Where can I find this log? Not "catalina.out"?
Gregory Amerson
RE: Alloy UI
2 febbraio 2012 17.26
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Legend

Messaggi: 1028

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Peter Hellstrand:
I have been reading that Alloy UI is included in Liferay 6.X.

What do I need to do?

This will not complie.
1<%@ taglib uri="http://liferay.com/tld/aui" prefix="aui" %>


I tried adding this to the web.xml

1    <taglib>
2        <taglib-uri>http://liferay.com/tld/aui</taglib-uri>
3        <taglib-location>/WEB-INF/tld/liferay-aui.tld</taglib-location>
4    </taglib>


And I also have the alloy-taglib.jar in my path. "Liferay Portal Plugin API".

This ca be found in my liferay-plugin-package.properties.
1portal-dependency-jars=\
2    alloy-taglib.jar,\
3    jstl-impl.jar



How can I use alloy UI?


Hi Peter are you trying this on 6.0 or 6.1?
Peter Hellstrand
RE: Alloy UI
5 febbraio 2012 4.04
Risposta

Peter Hellstrand

Punteggio: Regular Member

Messaggi: 167

Data di Iscrizione: 30 novembre 2011

Messaggi recenti

Hi

I am using version 6.1

Thanks!
Gregory Amerson
RE: Alloy UI
5 febbraio 2012 17.13
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Legend

Messaggi: 1028

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Hey Peter,

There was a mix-up with URL/URIs for the aui taglib for 6.1 GA1. This is going ot be addressed by GA2 but for now you can just add this to your web.xml in your IDE project:

1
2<taglib>
3        <taglib-uri>http://liferay.com/tld/aui</taglib-uri>
4        <taglib-location>/WEB-INF/tld/aui.tld</taglib-location>
5</taglib>


Then copy the aui.tld from the portal's tld folder (<tomcat>/webapps/ROOT/WEB-INF/tld/aui.tld) into your project's docroot/WEB-INF/tld

Then to get Eclipse to not mark it as error you will have to close and reopen the project (or restart) eclipse and then re-validate your jsp files.
Pablo Antonio Zamora Ortiz
RE: Alloy UI
11 febbraio 2012 0.10
Risposta

Pablo Antonio Zamora Ortiz

Punteggio: Junior Member

Messaggi: 28

Data di Iscrizione: 18 marzo 2011

Messaggi recenti

Thank you very much for your contribution and I had the same problem and corrected it with your contribution Thanks
kashika singh
RE: Alloy UI
21 gennaio 2013 5.45
Risposta

kashika singh

Punteggio: New Member

Messaggi: 1

Data di Iscrizione: 21 gennaio 2013

Messaggi recenti

I have liferay-portlet.tld and aui.tld files in WEB-INF/tld folder and I also restarted eclipse but there is still an error on the following lines :


<%@ taglib uri="http://java.sun.com/portlet_2_0" prefix="portlet" %>
<%@ taglib uri="http://liferay.com/tld/aui" prefix="aui" %>


I am using liferay-portal-6.1.1-ce-ga2 and eclipse indigo
Kindly help!!
Tanaji Londhe
RE: Alloy UI
5 febbraio 2013 3.06
Risposta

Tanaji Londhe

Punteggio: Regular Member

Messaggi: 196

Data di Iscrizione: 25 aprile 2012

Messaggi recenti

make this entry in web.xml file inside the <jsp-config> tag
<taglib>
<taglib-uri>http://liferay.com/tld/aui</taglib-uri>
<taglib-location>/WEB-INF/tld/aui.tld</taglib-location>
</taglib>