Vue combinée Vue Plate Arborescence
toggle
Eli Miz
help with liferay-plugin-package.properties dependency-jars and versions
15 août 2013 13:38
Réponse

Eli Miz

Rang: New Member

Publications: 3

Date d'inscription: 11 août 2013

Publications Récentes

Hi Team,

Couple questions. That I really could use help on now.

1. I have downloaded several marketplace apps; and am uncertain as what to enter in portal-dependency-jars in the liferay-plugin-package.properties. And how to enter it appropriately.

Does it come out of my POMS dependencies :
https://github.com/openfeed/AjaxQuotePortlet/blob/master/ajaxquote_war/pom.xml
https://github.com/openfeed/AjaxQuotePortlet/blob/master/ajaxquote_jar/pom.xml

2. I also have tested my app with successfully with 6.1 CE GA2 (with the workaround for LPS-29103) and can confirm the portlets deploy to 6.2 Beta 1. . What would be the appropriate liferay-versions value?

3. And what about the war file name; some people use xxxx-portlet-1.0.0.0.war and some do xxxx-portlet-6.1.1.1.war? Is it irrelevant?

4. I want to submit with PACL disabled; do I need to add all this security-manager info on the liferay-plugin-package.properties.

5. In addition I have tested with both Tomcat and JBOSS bundles; JBOSS bundle requires explicit MySQL dialect configuration in the persistence unit to work (JBOSS 7.0 AS bug among many)

The code and build:
https://github.com/openfeed/AjaxQuotePortlet

Warmest
James Falkner
RE: help with liferay-plugin-package.properties dependency-jars and version
15 août 2013 13:44
Réponse

James Falkner

Community Moderator

Rang: Liferay Legend

Publications: 1406

Date d'inscription: 17 septembre 2010

Publications Récentes

Eli Miz:
Hi Team,

Couple questions. That I really could use help on now.

1. I have downloaded several marketplace apps; and am uncertain as what to enter in portal-dependency-jars in the liferay-plugin-package.properties. And how to enter it appropriately.

Are you intending on bundling copies of apps you downloaded into your own app? You can do this, but be aware that many apps have a license associated with them that requires special steps to do this, to abide by the license.

2. I also have tested my app with successfully with 6.1 CE GA2 (with the workaround for LPS-29103) and can confirm the portlets deploy to 6.2 Beta 1. . What would be the appropriate liferay-versions value?

If your app works with 6.1 CE GA2, you can put "liferay-versions=6.1.1+" in your liferay-plugin-package.properties file. If you also intend to support 6.1 EE, you should put "liferay-versions=6.1.1+,6.1.20+".

You cannot yet mention 6.2 in your liferay-plugin-package.properties file, as that does not exist (we are only at beta) - it's great to hear your app works with it, though! Once the 6.2 GA is released, you will need to update your app to include 6.2.0+ (and potentially 6.2.10+, or whatever version we end up calling 6.2 EE).



3. And what about the war file name; some people use xxxx-portlet-1.0.0.0.war and some do xxxx-portlet-6.1.1.1.war? Is it irrelevant?


See the official Marketplace developer docs for details about naming.



4. I want to submit with PACL disabled; do I need to add all this security-manager info on the liferay-plugin-package.properties.

Nope! If you don't intend to use PACL, all you need is "security-manager-enabled=false" in your properties file.


5. In addition I have tested with both Tomcat and JBOSS bundles; JBOSS bundle requires explicit MySQL dialect configuration in the persistence unit to work (JBOSS 7.0 AS bug among many)


Well good on ya for reporting this! Hopefully someone else hitting this will find your valuable information. Do you happen to have an explicit pointer to the jboss bug?