Forum

Accueil » Liferay IDE » English

Vue combinée Vue Plate Arborescence
Sujets [ Précédent | Suivant ]
toggle
Joga Krish
Unable to install Liferay IDE on my Eclipse Juno
8 janvier 2013 05:39
Réponse

Joga Krish

Rang: Junior Member

Publications: 38

Date d'inscription: 8 janvier 2013

Publications Récentes

Hallo everyone,

I am new to Liferay. I want to install it on my Eclipse Juno.
When i try to install Liferay IDE I get the following error.

Cannot complete the install because one or more required items could not be found.
Software being installed: Liferay IDE 1.4.0.v201110020918 (com.liferay.ide.eclipse.tools.feature.group 1.4.0.v201110020918)
Missing requirement: Liferay IDE Core 1.4.0.v201110020918 (com.liferay.ide.eclipse.core 1.4.0.v201110020918) requires 'bundle org.eclipse.wst.server.core [1.1.102,1.2.0)' but it could not be found
Cannot satisfy dependency:
From: Liferay Portlet Core 1.5.0.v201110020918 (com.liferay.ide.eclipse.portlet.core 1.5.0.v201110020918)
To: bundle com.liferay.ide.eclipse.core 0.0.0
Cannot satisfy dependency:
From: Liferay IDE 1.4.0.v201110020918 (com.liferay.ide.eclipse.tools.feature.group 1.4.0.v201110020918)
To: com.liferay.ide.eclipse.portlet.core [1.5.0.v201110020918]

There is a thread on the same question in this website but It did not help me. I have already tried it.
Can anyone please help me

Regards,
Krish.
Attachement

Attachement

Attachement

Pièces jointes: 1.PNG (70,3k), 2.PNG (59,7k), 3.PNG (77,8k)
Gregory Amerson
RE: Unable to install Liferay IDE on my Eclipse Juno
8 janvier 2013 05:44
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Legend

Publications: 1024

Date d'inscription: 16 février 2010

Publications Récentes

For installing into Eclipse Juno it is best to use the latest version of Liferay IDE version 1.6.1. You can download it from here:

http://www.liferay.com/downloads/liferay-projects/liferay-ide
Joga Krish
RE: Unable to install Liferay IDE on my Eclipse Juno
8 janvier 2013 05:56
Réponse

Joga Krish

Rang: Junior Member

Publications: 38

Date d'inscription: 8 janvier 2013

Publications Récentes

Thank you emoticon
I will do it now
Joga Krish
RE: Unable to install Liferay IDE on my Eclipse Juno
8 janvier 2013 06:06
Réponse

Joga Krish

Rang: Junior Member

Publications: 38

Date d'inscription: 8 janvier 2013

Publications Récentes

The link that you have provided is "Liferay IDE v1.6.1 along with Eclipse Juno IDE" or Is it just only with Eclipse Plugins ?
Attachement

Attachement

Pièces jointes: 4.PNG (102,7k), 5.PNG (50,5k)
Joga Krish
RE: Unable to install Liferay IDE on my Eclipse Juno
8 janvier 2013 06:34
Réponse

Joga Krish

Rang: Junior Member

Publications: 38

Date d'inscription: 8 janvier 2013

Publications Récentes

Problem solved

http://releases.liferay.com/tools/ide/eclipse/juno/stable/

I have used this link to install Liferay for Juno emoticon. It has worked for me
Thank you

Regards,
Krish.
Gregory Amerson
RE: Unable to install Liferay IDE on my Eclipse Juno
9 janvier 2013 00:54
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Legend

Publications: 1024

Date d'inscription: 16 février 2010

Publications Récentes

Joga Krish:
Problem solved

http://releases.liferay.com/tools/ide/eclipse/juno/stable/

I have used this link to install Liferay for Juno emoticon. It has worked for me
Thank you

Regards,
Krish.


Glad everything is working ok now.
Tim Collins
RE: Unable to install Liferay IDE on my Eclipse Juno
2 mars 2013 06:05
Réponse

Tim Collins

Rang: New Member

Publications: 1

Date d'inscription: 2 mars 2013

Publications Récentes

Apparently this broke again.

About 5 minutes ago I installed Juno SR2

I tried to add this site given in this thread:

http://releases.liferay.com/tools/ide/eclipse/juno/stable/


and upon install I see

Cannot complete the install because one or more required items could not be found.
Software being installed: Liferay IDE 1.6.1.v201211020947 (com.liferay.ide.eclipse.tools.feature.group 1.6.1.v201211020947)
Missing requirement: Liferay IDE Snippets 1.6.1.v201211020947 (com.liferay.ide.eclipse.ui.snippets 1.6.1.v201211020947) requires 'bundle org.eclipse.jst.jsf.common [1.1.9,1.3.0)' but it could not be found
Cannot satisfy dependency:
From: Liferay IDE 1.6.1.v201211020947 (com.liferay.ide.eclipse.tools.feature.group 1.6.1.v201211020947)
To: com.liferay.ide.eclipse.ui.snippets [1.6.1.v201211020947]


For good measure I also downloaded the 1.6.1 .ZIP archive "liferay-ide-eclipse-updatesite-1.6.1" and got the same result.

Are these plugins actually required? Is it true that this IDE plugin is broken and nobody seems to have noticed and therefore maybe I should avoid getting dependent on them? Is it only this version because somebody didn't test it on a clean Juno install? Should I abandon Juno and see if an older combination of Eclipse and Liferay IDE can be found that works?
Gregory Amerson
RE: Unable to install Liferay IDE on my Eclipse Juno
4 mars 2013 04:05
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Legend

Publications: 1024

Date d'inscription: 16 février 2010

Publications Récentes

Hello Tim,

You are correct, this is a problem with Juno SR2. We will get a fix for this uploaded ASAP. Sorry for the inconvenience caused.
Gregory Amerson
RE: Unable to install Liferay IDE on my Eclipse Juno
4 mars 2013 04:23
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Legend

Publications: 1024

Date d'inscription: 16 février 2010

Publications Récentes

Here is the ticket to track the fix: http://issues.liferay.com/browse/IDE-852
Alain Dresse
RE: Unable to install Liferay IDE on my Eclipse Juno
13 mars 2013 00:16
Réponse

Alain Dresse

Rang: Junior Member

Publications: 95

Date d'inscription: 18 juillet 2011

Publications Récentes

Hello Gregory,

The Jira entry identifies this as fixed, and I see in GitHub a tag refering to a 1.6.2 release. That version however seems not to be available in liferay's eclipse repository. Is the 1.6.2 compatible with Juno SR2 ? Is it available ?

Thank you for your clarifications,
Alain
Gregory Amerson
RE: Unable to install Liferay IDE on my Eclipse Juno
13 mars 2013 00:28
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Legend

Publications: 1024

Date d'inscription: 16 février 2010

Publications Récentes

Alain Dresse:
Hello Gregory,

The Jira entry identifies this as fixed, and I see in GitHub a tag refering to a 1.6.2 release. That version however seems not to be available in liferay's eclipse repository. Is the 1.6.2 compatible with Juno SR2 ? Is it available ?

Thank you for your clarifications,
Alain


The final build of 1.6.2 has been completed and we are rolling it out to updatesite and sourceforge.net today. I'll make a blog post about it once they are generally available. However, for those of you that are watching this forum topic, you can grab an early copy here:

http://ftp.liferay.com/Liferay_IDE_1.6.2.v201303111029-updatesite.zip

In order to use this "archived" updatesite, just download it and go to Help > install new software... and click "add" and then use the "archive" button to point to the zip file.

Let me know if you have any problems.
Daniel Tyger
RE: Unable to install Liferay IDE on my Eclipse Juno
3 avril 2013 06:40
Réponse

Daniel Tyger

Rang: Junior Member

Publications: 79

Date d'inscription: 5 février 2013

Publications Récentes

Greg-

If you could tell us:

Can we use Eclipse JUNO + your latest IDE to develop against 6.06 as well as 6.1 / 2?

Thank you for all your work!
Gregory Amerson
RE: Unable to install Liferay IDE on my Eclipse Juno
3 avril 2013 06:52
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Legend

Publications: 1024

Date d'inscription: 16 février 2010

Publications Récentes

Daniel Tyger:
Greg-

If you could tell us:

Can we use Eclipse JUNO + your latest IDE to develop against 6.06 as well as 6.1 / 2?

Thank you for all your work!



Hey Daneil,

You can use 1.6.2 to develop against both 6.0.x and 6.1.x. Right now to develop with 6.2.x Liferay Portal milestones you need the upcoming 2.0.0-Milestone IDE release. We are plannign a release shortly, within a couple of weeks. I may post an early access build to the forums for anyone that would like to try them out.
Daniel Tyger
RE: Unable to install Liferay IDE on my Eclipse Juno
3 avril 2013 10:24
Réponse

Daniel Tyger

Rang: Junior Member

Publications: 79

Date d'inscription: 5 février 2013

Publications Récentes

Amazing response time, Greg. Thank you, kindly. I have used the advice on this page and the tutorial and I am off and running.
Daniel
Daniel Tyger
RE: Unable to install Liferay IDE on my Eclipse Juno
3 avril 2013 11:48
Réponse

Daniel Tyger

Rang: Junior Member

Publications: 79

Date d'inscription: 5 février 2013

Publications Récentes

Greg:

Any chance we can also edit / manage 5.2.3 projects in this setup?

Daniel
Jack Bakker
RE: Unable to install Liferay IDE on my Eclipse Juno
3 avril 2013 17:32
Réponse

Jack Bakker

Rang: Liferay Master

Publications: 840

Date d'inscription: 3 janvier 2010

Publications Récentes

An awesome evolution going on with reach out to community with grace. Interesting and heart warming which is inspiring.

Am looking at 6.0 to 6.1 and wondering about 6.2 in general. Good to know IDE (and Studio I assume) is backward compatible to v6+ versions. I don't think the IDE was avail for v5...