Vue combinée Vue Plate Arborescence
Sujets [ Précédent | Suivant ]
toggle
Stew Sutton
Proxy settings for accessing marketplace downloads
11 décembre 2012 13:27
Réponse

Stew Sutton

Rang: New Member

Publications: 5

Date d'inscription: 6 novembre 2012

Publications Récentes

I'm having some difficulty in getting a successful DOWNLOAD to work within the MARKETPLACE for PURCHASED PRODUCTS that appear. I have suspected that this is due to proxy settings and have updated the system-ext.properties file located in the directory liferay/WEB-INF/classes to include the following parameters (with adjustments made for actual values)...

portal.instance.http.port=1234
http.proxy.Set=true
http.proxyHost=Name_of_Our_Proxy
http.proxyPort=1234
http.proxyUser=User_Name_For_Proxy
http.proxyPass=Password_For_User_To_Proxy

However even after these changes being accepted via a liferay restart, I am unable to successfully DOWNLOAD any PURCHASED PRODUCT from within the MARKETPLACE / PURCHASED inventory screen. Clicking on the DOWNLOAD button results in a PLEASE WAIT... notification over the button and the process never completes.

Does anybody have any suggestions on other PROXY settings or system configuration settings that might prevent the DOWNLOAD from working on a CE instance of Liferay running behind a corporate firewall?

Thanks for any suggestions!

-Stew
Aaron Paxson
RE: Proxy settings for accessing marketplace downloads
16 décembre 2012 16:10
Réponse

Aaron Paxson

Rang: Regular Member

Publications: 103

Date d'inscription: 27 juillet 2010

Publications Récentes

Not sure if this helps, but I'm getting that issue, too. But, I don't use a proxy. Seemed to have happened recently, since I was able to use Marketplace without problems before.
Stew Sutton
RE: Proxy settings for accessing marketplace downloads
17 décembre 2012 07:45
Réponse

Stew Sutton

Rang: New Member

Publications: 5

Date d'inscription: 6 novembre 2012

Publications Récentes

Aaron Paxson:
Not sure if this helps, but I'm getting that issue, too. But, I don't use a proxy. Seemed to have happened recently, since I was able to use Marketplace without problems before.



My first and only install was behind a firewall so I have no point of comparison. I have established a workaround using the hot-deploy folder and downloading the .lpkg files into that location, setting ownership correctly and "watching the magic happen"... I'd certainly prefer to be able to install directly from within the web interface, but sometimes you just have to take a trip to the terminal do get stuff done... :-)
Stratos Zolotas
RE: Proxy settings for accessing marketplace downloads
22 septembre 2013 03:08
Réponse

Stratos Zolotas

Rang: New Member

Publications: 3

Date d'inscription: 22 septembre 2013

Publications Récentes

I have the same issue. Downloading through marketplace stays on "Please wait" forever. Installing manual works. Any hints, where to check?
James Falkner
RE: Proxy settings for accessing marketplace downloads
22 septembre 2013 11:49
Réponse

James Falkner

Community Moderator

Rang: Liferay Legend

Publications: 1406

Date d'inscription: 17 septembre 2010

Publications Récentes

Stratos Zolotas:
I have the same issue. Downloading through marketplace stays on "Please wait" forever. Installing manual works. Any hints, where to check?


If you are using the latest CE and EE releases (6.1.2 CE GA3 and 6.1.30 EE GA3), chances are the problem is that the default maximum size of files uploaded to the DL is set too low. In the latest releases, Marketplace now uses the DL to store apps that you download, and if the app is too big (~3MB or larger), it will fail to download and you'll get the forever spinner. (see LPS-40457). If you go to Control Panel -> Server Administration -> File Uploads and increase the size of the DL files to something larger (say, 30MB instead of 3Memoticon it should work. This is a high priority issue that I hope is fixed in the next release.
Stratos Zolotas
RE: Proxy settings for accessing marketplace downloads
22 septembre 2013 11:56
Réponse

Stratos Zolotas

Rang: New Member

Publications: 3

Date d'inscription: 22 septembre 2013

Publications Récentes

James Falkner:
Stratos Zolotas:
I have the same issue. Downloading through marketplace stays on "Please wait" forever. Installing manual works. Any hints, where to check?


If you are using the latest CE and EE releases (6.1.2 CE GA3 and 6.1.30 EE GA3), chances are the problem is that the default maximum size of files uploaded to the DL is set too low. In the latest releases, Marketplace now uses the DL to store apps that you download, and if the app is too big (~3MB or larger), it will fail to download and you'll get the forever spinner. (see LPS-40457). If you go to Control Panel -> Server Administration -> File Uploads and increase the size of the DL files to something larger (say, 30MB instead of 3Memoticon it should work. This is a high priority issue that I hope is fixed in the next release.


I checked the filesize there and it is "104857600". Is this in Bytes? There is no temporary storage directory set although.
James Falkner
RE: Proxy settings for accessing marketplace downloads
22 septembre 2013 12:19
Réponse

James Falkner

Community Moderator

Rang: Liferay Legend

Publications: 1406

Date d'inscription: 17 septembre 2010

Publications Récentes

That is the overall upload max - there is a setting below that for Documents and Media uploads that should be set to around 3MB. That is the one that you should increase...
Stratos Zolotas
RE: Proxy settings for accessing marketplace downloads
22 septembre 2013 12:23
Réponse

Stratos Zolotas

Rang: New Member

Publications: 3

Date d'inscription: 22 septembre 2013

Publications Récentes

Thanks it worked!! I was confused from the title (Documents and Media) and didn't gave attention to that setting.

Thanks again.