Vue combinée Vue Plate Arborescence
Sujets [ Précédent | Suivant ]
toggle
lou cat
Liferay 6.0 LAR import error and other bugs...
28 juin 2012 01:56
Réponse

lou cat

Rang: Regular Member

Publications: 196

Date d'inscription: 26 janvier 2012

Publications Récentes

Hi all!

I really need to be able to export the pages of an organization in order to replicate them in other new organizations, but the LAR import/export is not working properly emoticon
I export correctly, I create a new organization but when I try to import that LAR for public or private pages, I got "You have entered invalid data, please try again" and "An unexpected error occurred while importing your file. ".

I also had problems with site templates:

http://www.liferay.com/community/forums/-/message_boards/message/12245067

so it's going to be very tricky and long for me to organize all the website and intranet for my company if I don't solve these problems emoticon

Could these be some bugs that I could fix with patches?
Honestly I haven't seen any "updates available" message since I installed LF6 various months ago, so I'm not sure on how these works but... do I have to install some patches and important updates for my version (6.0.6 CE)?
lou cat
RE: Liferay 6.0 LAR import error and other bugs...
28 juin 2012 02:22
Réponse

lou cat

Rang: Regular Member

Publications: 196

Date d'inscription: 26 janvier 2012

Publications Récentes

Just to confirm I have this problem on another installation too: it's in another server location but always with tomcat + liferay 6.0.6 CE.
Hitoshi Ozawa
RE: Liferay 6.0 LAR import error and other bugs...
28 juin 2012 03:22
Réponse

Hitoshi Ozawa

Rang: Liferay Legend

Publications: 7949

Date d'inscription: 23 mars 2010

Publications Récentes

have to install some patches and important updates for my version (6.0.6 CE)?


Sorry, Liferay.com does not provide patches and updates for the CE versions. You'll have to fix the problems yourself. emoticon
Sunil Rai
RE: Liferay 6.0 LAR import error and other bugs...
28 juin 2012 04:13
Réponse

Sunil Rai

Rang: Junior Member

Publications: 57

Date d'inscription: 31 janvier 2012

Publications Récentes

I am facing the similar issue on Liferay 6.0.6 CE. Anyone can suggest how to debug and proceed for this issue?
Milen Dyankov
RE: Liferay 6.0 LAR import error and other bugs...
28 juin 2012 04:23
Réponse

Milen Dyankov

Rang: Regular Member

Publications: 173

Date d'inscription: 23 septembre 2009

Publications Récentes

lou cat:
I create a new organization but when I try to import that LAR for public or private pages, I got "You have entered invalid data, please try again" and "An unexpected error occurred while importing your file. "


Is there some error message in the logs? If you can reproduce this locally then perhaps you can start Liferay in debug mode and trace down the method / data record causing the error.
Hitoshi Ozawa
RE: Liferay 6.0 LAR import error and other bugs...
28 juin 2012 04:33
Réponse

Hitoshi Ozawa

Rang: Liferay Legend

Publications: 7949

Date d'inscription: 23 mars 2010

Publications Récentes

They're using 6.0.6 CE so it may be the following issue:
http://issues.liferay.com/browse/LPS-16425

Try to find where this got fixed and find a patch. emoticon

I've resorted to creating my own import/export routines because liferay's LAR seems to keep having problems. Better to get it fixed once properly then trying to get it fixed forever. :-)
lou cat
RE: Liferay 6.0 LAR import error and other bugs...
29 juin 2012 04:21
Réponse

lou cat

Rang: Regular Member

Publications: 196

Date d'inscription: 26 janvier 2012

Publications Récentes

Thank you for replying guys. even with sad news for us Community Edition users... emoticon

I got a pretty scary error log (you find it in the attachment if you are curious) and I don't know exactly where to start, but the first error is:

1[LayoutImporter:898] No theme loaders are deployed


and then I can see exceptions related to journal articles (as if it was trying to create in the db something that was suppose to be unique?), so I've tried to import the organization without "Data" in the portlets and it does work!

But of course I need data, and strangely I got the above error anyway in catalina.out!
Pièces jointes: importLAR-error.txt (115,6k)
lou cat
RE: Liferay 6.0 LAR import error and other bugs...
29 juin 2012 04:51
Réponse

lou cat

Rang: Regular Member

Publications: 196

Date d'inscription: 26 janvier 2012

Publications Récentes

Ok now I'm honestly quite confused...

1) The first time I imported with the default settings checked and was not successful.

2) Then I've tried unchecking all the checkboxes under "portlets" (Setup, Archived Setups, User Preferences, Data) and it worked fine, but without data inside the portlets...

3) Eventually I've just unticked the "Data" checkbox and... everything seems fine! with data inside the portlets!

So... is it just me who didn't understand a thing of how this thing works??
What am I not importing when I deselect Portlets->Data ??
Ján Ondrušek
RE: Liferay 6.0 LAR import error and other bugs...
10 janvier 2013 14:45
Réponse

Ján Ondrušek

Rang: New Member

Publications: 12

Date d'inscription: 26 avril 2009

Publications Récentes

Actually it works well as you said. This will import everything but data (web conent, gallery, ...) Then, in second import, simply untick everything but the data. And it's all there!
Nitin Bhandari
RE: Liferay 6.0 LAR import error and other bugs...
27 mars 2015 10:00
Réponse

Nitin Bhandari

Rang: New Member

Publications: 22

Date d'inscription: 26 juillet 2012

Publications Récentes

Thanks it helped