Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Kevin Lyons
Portlet Format Error?
7 de noviembre de 2006 15:01
Respuesta

Kevin Lyons

Ranking: New Member

Mensajes: 2

Fecha de incorporación: 7 de noviembre de 2006

Mensajes recientes

Using: Liferay 4.1.2 Tomcat
Development via Eclipse 3.1 Linux with JDK 1.5.0 installed

I'm attempting to create a simple new "hello world" style portlet that simply displays a single piece of text..

Following the instructions on the various tutorials available here, everything works fine until I attempt to "Hot Deploy" the portlet. Attempting to deploy the portlet always results in the following error:

Caused by: java.lang.ClassCastException: com.ne.unicam.CurrentBill
at com.liferay.portal.deploy.HotDeployPortletListener.invokeDeploy(HotDeployPortletListener.java:142)

The class itself contains all the GenericPortlet interface methods and compiles cleaning with no warnings both natively on the command line on the same machine as is running our Liferay server and remotely. Google and/or forum searches for this particular error have turned up little useful.

Any thoughts as to what might cause such an error?
Jorge Ferrer
RE: Portlet Format Error?
8 de noviembre de 2006 0:55
Respuesta

Jorge Ferrer

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 2768

Fecha de incorporación: 31 de agosto de 2006

Mensajes recientes

Are you deploying the portlet.jar library inside the WAR? Maybe that's causing a conflict
Kevin Lyons
RE: Portlet Format Error?
8 de noviembre de 2006 6:13
Respuesta

Kevin Lyons

Ranking: New Member

Mensajes: 2

Fecha de incorporación: 7 de noviembre de 2006

Mensajes recientes

Wouldn't you know it, that was exactly the issue - I hadn't moved the local copy out of the directory structure before I'd created the WAR.

Thanks for the prompt and helpful response!