Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Przemek Krysztofiak
Message board problem after setting web.server.host
26 de julio de 2012 3:37
Respuesta

Przemek Krysztofiak

Ranking: New Member

Mensajes: 4

Fecha de incorporación: 26 de julio de 2012

Mensajes recientes

Hello,
I got problem with message board after opening my portal to the world. When I work on localhost:8080 everything with message board works fine. But after i change
portal-ext.properties and add following lines:

web.server.host=my.company
web.server.protocol=https
web.server.http.port=80

I can not post new thread, add category. I can replay to message but it also does not work good. When I replay there is an annoucement: "Your request completed successfully.", but I'm not redirected to the messaged I just added. Instead I can add another message. That is not the way it should works. It also work well on localhost.

I working with liferay Liferay Portal 6.1 Community Edition 6.1 GA 1 bundled with tomcat.

I would apreaciate any help.
Jignesh Vachhani
RE: Message board problem after setting web.server.host
26 de julio de 2012 4:15
Respuesta

Jignesh Vachhani

Ranking: Liferay Master

Mensajes: 794

Fecha de incorporación: 10 de marzo de 2008

Mensajes recientes

Does it giving any error in server console ?
Przemek Krysztofiak
RE: Message board problem after setting web.server.host
26 de julio de 2012 4:34
Respuesta

Przemek Krysztofiak

Ranking: New Member

Mensajes: 4

Fecha de incorporación: 26 de julio de 2012

Mensajes recientes

There is nothing in catalina.out
Jignesh Vachhani
RE: Message board problem after setting web.server.host
26 de julio de 2012 4:45
Respuesta

Jignesh Vachhani

Ranking: Liferay Master

Mensajes: 794

Fecha de incorporación: 10 de marzo de 2008

Mensajes recientes

Did you make any message board related code changes part from this properties ?
Przemek Krysztofiak
RE: Message board problem after setting web.server.host
26 de julio de 2012 4:51
Respuesta

Przemek Krysztofiak

Ranking: New Member

Mensajes: 4

Fecha de incorporación: 26 de julio de 2012

Mensajes recientes

I did not. I just use standard Message board portlet.
Jignesh Vachhani
RE: Message board problem after setting web.server.host
26 de julio de 2012 5:08
Respuesta

Jignesh Vachhani

Ranking: Liferay Master

Mensajes: 794

Fecha de incorporación: 10 de marzo de 2008

Mensajes recientes

Ok so i think some problem with the properties you set here only.

web.server.host=my.company
web.server.protocol=https
web.server.http.port=80

Can you please give idea for which purpose you set this properties because i am seeing some conflicting here that you used protocol https and use http port.
Przemek Krysztofiak
RE: Message board problem after setting web.server.host
26 de julio de 2012 6:15
Respuesta

Przemek Krysztofiak

Ranking: New Member

Mensajes: 4

Fecha de incorporación: 26 de julio de 2012

Mensajes recientes

I use web.server.http.port=80 for one reason.

When I did not use it. I could get the page https://my.company.com but when i tried to log in I was redirected to
https://my.company.com:8080/web/guest/home?p_p_id=58&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&saveLastPath=0&_58_struts_action=%2Flogin%2Flogin
and site is unavailable.
I found solution on liferay forum and it was web.server.http.port=80.
Everything works fine excpet forum.
Manuel Hoyos
RE: Message board problem after setting web.server.host
22 de enero de 2013 0:41
Respuesta

Manuel Hoyos

Ranking: Junior Member

Mensajes: 60

Fecha de incorporación: 10 de junio de 2012

Mensajes recientes

Hi,

i have the same problem, when we open the portal to the world with a https connection, the forum portlet works bad.

Any idea??

Thanks
Arcane Huang
RE: Message board problem after setting web.server.host
24 de septiembre de 2013 16:29
Respuesta

Arcane Huang

Ranking: Junior Member

Mensajes: 32

Fecha de incorporación: 13 de abril de 2010

Mensajes recientes

Hi,
Go to Control Panel -> Portal Settings -> Main Configuration -> Virtual host
the value should be the same with the value of web.server.host
Then it works!