Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
dave ch
Reports generation issues
11 de junio de 2012 2:30
Respuesta

dave ch

Ranking: Regular Member

Mensajes: 164

Fecha de incorporación: 6 de febrero de 2012

Mensajes recientes

Hi all,

I am using LR 6.1. We are getting some problems on Reports generation.
Actually we have under taken 2 approaches but we haven't succeeded till yet.

First approach was: We have downloaded a war (aperte-reports-ui-1.2a) , installed and deployed that war. We got five portlet. By using i-report tool we have customised. But when we are trying to generate any report (suppose in xml or pdf) we are getting NULL instead of any value.

Second approach: We have downloaded a war(jasper server portlet) and did the same. Here we are getting only 1 portlet. But when we are trying to generate any report we are getting the same issue.

Anybody cud tell me which approach is better and any solution for this problem.

Any help will be highly appreciated.

Thanks in advance
Dave
Priyanka Dhingra
RE: Reports generation issues
11 de junio de 2012 4:45
Respuesta

Priyanka Dhingra

Ranking: Liferay Master

Mensajes: 501

Fecha de incorporación: 19 de diciembre de 2011

Mensajes recientes

Hi dave,

I have used ireport so i can tell about that only.....
if you are getting null values then there are some jars that are missing....
Rashmi Pandey
RE: Reports generation issues
11 de junio de 2012 5:09
Respuesta

Rashmi Pandey

Ranking: Junior Member

Mensajes: 89

Fecha de incorporación: 13 de septiembre de 2011

Mensajes recientes

Priyanka Dhingra:
Hi dave,

I have used ireport so i can tell about that only.....
if you are getting null values then there are some jars that are missing....


Thanks Priyanka..

Can u please tell me the jars needed????

Thanks,
RAshmi Agnihotri
dave ch
RE: Reports generation issues
11 de junio de 2012 6:31
Respuesta

dave ch

Ranking: Regular Member

Mensajes: 164

Fecha de incorporación: 6 de febrero de 2012

Mensajes recientes

Thanks Priyanka,

While i am trying to generate using aperte-reports-ui-1.2a approach, i am getting stuck since i am getting null as my result.
As u said : "if you are getting null values then there are some jars that are missing....". Could u please intimate me which jars am i missing.

Warm Regards,

Dave
Priyanka Dhingra
RE: Reports generation issues
11 de junio de 2012 9:39
Respuesta

Priyanka Dhingra

Ranking: Liferay Master

Mensajes: 501

Fecha de incorporación: 19 de diciembre de 2011

Mensajes recientes

Hi
please refer to this:-
http://jasperforge.org/uploads/publish/ireportwebsite/IR%20Website/ir_deploying_reports.html
the jar that is generally forgotten is "poi.jar". so, take care of adding that
dave ch
RE: Reports generation issues
12 de junio de 2012 22:34
Respuesta

dave ch

Ranking: Regular Member

Mensajes: 164

Fecha de incorporación: 6 de febrero de 2012

Mensajes recientes

Hi Priyanka,

Thanks for your quick response.

Priyanka Dhingra:

please refer to this:-
http://jasperforge.org/uploads/publish/ireportwebsite/IR%20Website/ir_deploying_reports.html
the jar that is generally forgotten is "poi.jar". so, take care of adding that


I have added all of the above jars still i am getting the same Null value as my result. Kindly tell me if i am missing any thing else. How had you achieved yours resulting reports?
Any help will be highly appreciated.

Warm regards
Dave
Priyanka Dhingra
RE: Reports generation issues
13 de junio de 2012 1:26
Respuesta

Priyanka Dhingra

Ranking: Liferay Master

Mensajes: 501

Fecha de incorporación: 19 de diciembre de 2011

Mensajes recientes

Hi,

I prepared xls report. so used
1JRBeanCollectionDataSource reportList = new JRBeanCollectionDataSource(objectList);
2JasperReport report = JasperCompileManager.compileReport(session.getPortletContext().getRealPath("/report/myreport.jrxml"));
3                JasperPrint print = JasperFillManager.fillReport(report,new HashMap(), reportList);
4OutputStream os = resourceResponse.getPortletOutputStream();
5                JRXlsExporter exporterXLS = new JRXlsExporter();               

code and then
worked on ireport..configuring which all columns i need..
Ken Stubbings
RE: Reports generation issues
5 de septiembre de 2012 7:48
Respuesta

Ken Stubbings

Ranking: New Member

Mensajes: 1

Fecha de incorporación: 3 de septiembre de 2012

Mensajes recientes

I know this is somewhat old now but I was trying to do the same thing as you yesterday and it looks to me like your problem is with the datasource setup rather than missing jars.

You need to check that you are referenceing a datasource in your jrxml file for the report that has been defined in your context.xml file in your tomcats conf directory.

eg:
jrxml contains -
1    <parameter name="datasource" class="java.lang.String">
2        <parameterDescription><![CDATA[java:comp/env/jdbc/mydatabase]]></parameterDescription>
3    </parameter>


conf/contex.xml contains -
 1    <Resource name="jdbc/mydatabase"
 2        auth="Container"
 3        driverClassName="com.mysql.jdbc.Driver"
 4        maxActive="8"
 5        maxIdle="4"
 6        password="thepassword"
 7        type="javax.sql.DataSource"
 8        url="jdbc:mysql://127.0.0.1:3306/databasename"
 9        username="user"
10        />