Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Laxman Rana
BeanLocator has not been set...
27 de marzo de 2012 23:22
Respuesta

Laxman Rana

Ranking: Junior Member

Mensajes: 42

Fecha de incorporación: 29 de febrero de 2012

Mensajes recientes

i have developed a portlet in which i placed kaleo worflow (External plugin) codes and all packages.....(liferay 6.0.6)

i am doing ant-build service and after that i am deploying in...

but at that time i am getting this error...

com.liferay.portal.kernel.bean.BeanLocatorException: BeanLocator has not been set

so anybody can help me out.....
Rahul Pande
RE: BeanLocator has not been set...
28 de marzo de 2012 5:40
Respuesta

Rahul Pande

Ranking: Expert

Mensajes: 308

Fecha de incorporación: 6 de julio de 2010

Mensajes recientes

Hi Laxman,

Please have a look at this link

Thanks
Rahul
Laxman Rana
RE: BeanLocator has not been set...
28 de marzo de 2012 20:45
Respuesta

Laxman Rana

Ranking: Junior Member

Mensajes: 42

Fecha de incorporación: 29 de febrero de 2012

Mensajes recientes

Thanks Rahul...

i tried the soluntion that is mentioned on that link..
but i am getting the same error....
David H Nebinger
RE: BeanLocator has not been set...
29 de marzo de 2012 6:23
Respuesta

David H Nebinger

Community Moderator

Ranking: Liferay Legend

Mensajes: 11795

Fecha de incorporación: 1 de septiembre de 2006

Mensajes recientes

There are lots of other suggestions in the forum. Unfortunately the best way to find them is to google for bean locator has not been set...
Juan Gonzalez
RE: BeanLocator has not been set...
29 de marzo de 2012 8:10
Respuesta

Juan Gonzalez

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 2947

Fecha de incorporación: 28 de octubre de 2008

Mensajes recientes

Laxman Rana:
i have developed a portlet in which i placed kaleo worflow (External plugin) codes and all packages.....(liferay 6.0.6)

i am doing ant-build service and after that i am deploying in...

but at that time i am getting this error...

com.liferay.portal.kernel.bean.BeanLocatorException: BeanLocator has not been set

so anybody can help me out.....


I remember this issue was solved in 6.1, but don't know how to solve for 6.0.6...
Laxman Rana
RE: BeanLocator has not been set...
21 de mayo de 2012 23:26
Respuesta

Laxman Rana

Ranking: Junior Member

Mensajes: 42

Fecha de incorporación: 29 de febrero de 2012

Mensajes recientes

i tried to reslove this....
it works when i delete work,temp,and project folder from webapps folder from tomcat bundle .
After this i am restarting the server and deploying my project its working fine...
But if i am deploying it second time it shows the same error...Bean Locator has not been set...

Thanks in advance for your kind help...
manasa chandri
RE: BeanLocator has not been set...
22 de mayo de 2012 0:21
Respuesta

manasa chandri

Ranking: Regular Member

Mensajes: 152

Fecha de incorporación: 27 de septiembre de 2010

Mensajes recientes

Hi Laxman Rana,

Go through this below site
http://www.liferay.com/community/forums/-/message_boards/message/10130524


Thanks & Regards,
Manasa.chandri.
Laxman Rana
RE: BeanLocator has not been set...
22 de mayo de 2012 0:45
Respuesta

Laxman Rana

Ranking: Junior Member

Mensajes: 42

Fecha de incorporación: 29 de febrero de 2012

Mensajes recientes

thanks for your reply...
i didn't found any soluton from your mentioned link....my using 6.0.6 liferay...
Tim Taylor
RE: BeanLocator has not been set...
21 de septiembre de 2012 4:15
Respuesta

Tim Taylor

Ranking: New Member

Mensajes: 18

Fecha de incorporación: 19 de septiembre de 2012

Mensajes recientes

I'm using Liferay 6.1.1 CE GA2 and have the same Problem.

I change the web.xml, change the portlet-spring.xml but nothing helps.

Any other solution idea's?

Tim
Ohad Raz
RE: BeanLocator has not been set...
9 de enero de 2013 10:55
Respuesta

Ohad Raz

Ranking: New Member

Mensajes: 23

Fecha de incorporación: 27 de junio de 2012

Mensajes recientes

Tim,

I am facing same issue.
Did you find the cause?

Cheers,
Ohad