Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
David Atkins
How to disable border by default?
29 de enero de 2007 10:19
Respuesta

David Atkins

Ranking: New Member

Mensajes: 23

Fecha de incorporación: 29 de enero de 2007

Mensajes recientes

When I add a portlet to a page, the border displays by default. I have to click configure and then uncheck the box for Show Borders to make it go away. Is there a setting, at the application or portlet level, to make the borders disabled?
Alaaeldin El-Nattar
RE: How to disable border by default?
17 de marzo de 2007 7:32
Respuesta

Alaaeldin El-Nattar

Ranking: New Member

Mensajes: 15

Fecha de incorporación: 9 de marzo de 2007

Mensajes recientes

Hi,

You can change that behavior by setting the portlet preferences in portlet.xml.

1<portlet-preferences>
2  <preference>
3    <name>portlet-setup-show-borders</name>
4    <value>false</value>
5  </preference>
6</portlet-preferences>


You have to do it for each portlet you want to disable borders by default for.

Hope this helps,

-Aladdin
André Gervásio
RE: How to disable border by default?
9 de agosto de 2008 7:14
Respuesta

André Gervásio

Ranking: New Member

Mensajes: 2

Fecha de incorporación: 30 de julio de 2008

Mensajes recientes

Fine! Works!


Alaaeldin El-Nattar:
Hi,

You can change that behavior by setting the portlet preferences in portlet.xml.

1<portlet-preferences>
2  <preference>
3    <name>portlet-setup-show-borders</name>
4    <value>false</value>
5  </preference>
6</portlet-preferences>


You have to do it for each portlet you want to disable borders by default for.

Hope this helps,

-Aladdin
Milan Jaroš
RE: How to disable border by default?
9 de diciembre de 2008 4:58
Respuesta

Milan Jaroš

Ranking: Expert

Mensajes: 269

Fecha de incorporación: 18 de agosto de 2008

Mensajes recientes

Hello,
there is solution on Theme level... So, you can modify key portlet-setup-show-borders-default in liferay-look-and-feel.xml.

It must be placed in settings (see part of file):

1
2<look-and-feel>
3    <theme>
4        <settings>
5            <setting key="portlet-setup-show-borders-default" value="true"></setting>
6        </settings>
7    </theme>
8</look-and-feel>
Kyrre Myrbostad
RE: How to disable border by default?
12 de febrero de 2009 7:04
Respuesta

Kyrre Myrbostad

Ranking: Junior Member

Mensajes: 37

Fecha de incorporación: 21 de enero de 2009

Mensajes recientes

Hi, I have a similar situation but the solution isn't quite up to it:

If you disable the borders on the portlet, there seems to be a standard "top section" that is presented, with text instead of icons. How do i get rid of this one? This doesn't seem to come from the velocity template. I can ofc adjust the portlet.vm to my taste, but if this replacement text can be manipulated that seems to be a more consistent way of doing it.

What I'm trying to achieve here is a set of fixed portlets where a user can only add content or work inside the portlets - not change the way they look / behave.
Milan Jaroš
RE: How to disable border by default?
25 de febrero de 2009 2:02
Respuesta

Milan Jaroš

Ranking: Expert

Mensajes: 269

Fecha de incorporación: 18 de agosto de 2008

Mensajes recientes

Hello,
you have to understand that you can see this labels because you are "admin" (you have rights). Note, guest or normal User will not see this. If so you have to set roles correctly to get from portal what you want. ;)
Please read some wiki's (something like "Get started" or else).

Here is something about roles in Liferay (if you find more somewhere else post it here).
Florence H
RE: How to disable border by default?
7 de diciembre de 2009 1:13
Respuesta

Florence H

Ranking: Junior Member

Mensajes: 51

Fecha de incorporación: 3 de noviembre de 2009

Mensajes recientes

You can add
1<use-default-template>false</use-default-template>

in liferay-portlet.xml
But even an admin cannot remove the portlet...
delang j
RE: How to disable border by default?
1 de julio de 2010 20:11
Respuesta

delang j

Ranking: Expert

Mensajes: 250

Fecha de incorporación: 13 de julio de 2008

Mensajes recientes

hi Alaaeldin,

i did test my local LR 511 and LR 523 but it ain't working. am i miss something or did some mistake?
here my code
 1    <portlet>
 2        <portlet-name>56</portlet-name>
 3        <display-name>Journal Content</display-name>
 4        <portlet-class>com.liferay.portlet.StrutsPortlet</portlet-class>
 5        <init-param>
 6            <name>view-action</name>
 7            <value>/journal_content/view</value>
 8        </init-param>
 9        <expiration-cache>0</expiration-cache>
10        <supports>
11            <mime-type>text/html</mime-type>
12        </supports>
13        <supports>
14            <mime-type>application/vnd.wap.xhtml+xml</mime-type>
15        </supports>
16        <resource-bundle>com.liferay.portlet.StrutsResourceBundle</resource-bundle>
17        <portlet-preferences>
18          <preference>
19            <name>portlet-setup-show-borders</name>
20            <value>false</value>
21          </preference>
22        </portlet-preferences>
23        <security-role-ref>
24            <role-name>guest</role-name>
25        </security-role-ref>
26        <security-role-ref>
27            <role-name>power-user</role-name>
28        </security-role-ref>
29        <security-role-ref>
30            <role-name>user</role-name>
31        </security-role-ref>
32    </portlet>


thanks
Renee Talabucon
RE: How to disable border by default?
21 de julio de 2010 23:17
Respuesta

Renee Talabucon

Ranking: Junior Member

Mensajes: 31

Fecha de incorporación: 28 de marzo de 2010

Mensajes recientes

Hi~

This code doesn't work for me either. :/

1
2<portlet-preferences>
3<preference>
4<name>portlet-setup-show-borders</name>
5<value>false</value>
6</preference>
7</portlet-preferences>   


Any other options?

Actually, I want to try setting the Web Content Display portlet to no borders by default because whenever I uncheck "Show borders" in Look and Feel -> Portlet Configuration , I get a " Internal Server Error - An error occurred while accessing the requested resource. " status. And that I don't get at all.

Thanks for all the help in advance. emoticon


Edit: I'm using glassfish v2, liferay 6.0.3 GA1
Vijay Chandra
RE: How to disable border by default?
4 de abril de 2013 6:49
Respuesta

Vijay Chandra

Ranking: New Member

Mensajes: 8

Fecha de incorporación: 4 de abril de 2013

Mensajes recientes

Hi All,

Recently we migrated from Liferay 6.0 to 6.1 and faced a problem that, portlets which are having view.jsp and edit.jsp , portlet border (title and preference icon) are visible.But for the portlet having only view are not displaying any thing.

Solution i tried till now
i) uncheck show border to that particular portlets but failed,
ii) Added

<portlet-preferences>
<preference>
<name>portletSetupShowBorders</name>
<value>false</value>
</preference>
</portlet-preferences>

in portlet.xml for that particular portlet but failed.

iii) Added theme.portlet.decorate.default=false in portal-ext.properties but failed.

iv) My liferay-look-and-feel.xml is having this code too

<look-and-feel>
<compatibility>
<version>6.1.0+</version>
</compatibility>
<theme id="CRPortal" name="CR Portal Theme">
<settings>
<setting key="portlet-setup-show-borders-default" value="false"></setting>
</settings>
</theme>
</look-and-feel> but its vain.

Please help me if any working solution is there to hide the titles and icon for portlets when logged in as normal user

Thanks
Vijay Chandra Kondamudi
Ahmed bouchriha
RE: How to disable border by default?
5 de abril de 2013 4:56
Respuesta

Ahmed bouchriha

Ranking: Junior Member

Mensajes: 55

Fecha de incorporación: 4 de mayo de 2012

Mensajes recientes

Hi Vijay Chandra

i think this post is describing better your problem since you posted here your liferay-look-and-feel.xml code
its wear why it didn't work for you you are using the right setting
<setting key="portlet-setup-show-borders-default" value="false"></setting>
.
try to make your
<setting key="portlet-setup-show-borders-default" value="false"></setting> configurable by replacing

1<setting key="portlet-setup-show-borders-default" value="false"></setting>


with
1<setting configurable="true" key="portlet-setup-show-borders-default" type="checkbox" value="false"/>

note the configurable="true" and type="checkbox" that will allow you to control the setting from your manage-page

go to your site open manage-page ----> select the root of your page tree ---> look and feel ----> setting you will find :

see attached file .

all you have to do is to uncheck it .
i wish it helps and good luck

for custom themes feel free to visit https://www.themeray.com.
Adjunto

archivos adjuntos: show-portlet-boreders-setting.png (2,3k)

Participate in the State of Liferay Community 2017. Help the community and even win some prizes!