Alternative Languages: 日本語

Introduction #

Liferay IDE is an extension for the Eclipse platform that supports development of plug-in projects for the Liferay Portal platform. Its available as a set of Eclipse plug-ins installable from an update-site. The latest version supports developing 5 Liferay plug-in types: portlets, hooks, layout templates, themes, and EXT-style plug-ins. Liferay IDE requires the Eclipse Java EE developer package using either Indigo or Helios versions.

Installation / Releases #

Eclipse Marketplace #

Latest Stable Release #

Latest Milestone Release #

Roadmap for future releases #

Tutorials #

Help / Support #

Contribute to Liferay IDE #

2 Anhänge
273719 Angesehen
Durchschnitt (11 Stimmen)
Die durchschnittliche Bewertung ist 4.45454545454545 von max. 5 Sternen.
Antworten im Thread Autor Datum
error when use spring sts! pls fix!can't... arron wu 8. Juli 2010 19:01
Hi. Can you post your specific issue to the... Gregory Amerson 11. Januar 2011 18:24
Hello. Why I can a "You do not have the... Lucas Raw 12. August 2010 11:32
Hi Lucas, For me both logged in and logged out... Gregory Amerson 12. August 2010 13:49
Hi.. "Working out to integrate OpenLDAP in... Sigma Infosolutions 18. August 2010 04:00
Hello all, I am not able to access Liferay IDE... Dharmender Singh 18. August 2010 05:31
Hi, Can something be done about the resolution... William Gosse 19. August 2010 08:58
Hi Bill, There is no workaround at the moment... Gregory Amerson 27. August 2010 12:13
I tried to follow the videocast... John Joseph Ryan 3. Oktober 2010 13:56
Hi John, Could you post your question over on... Gregory Amerson 6. Oktober 2010 03:15
Hi, Where can I find a changelog for new... Mathieu Hicauber 5. Juni 2012 06:36
Hi Mathieu, You can go to JIRA project for the... Gregory Amerson 11. Juni 2012 01:32
Thanks a lot. Mathieu Hicauber 18. März 2013 14:48

error when use spring sts! pls fix!can't setting the sdk path!
Gepostet am 08.07.10 19:01.
Hi. Can you post your specific issue to the Liferay IDE forums. I'll do my best to help out.
Gepostet am 11.01.11 18:24 als Antwort auf arron wu.
Hello. Why I can a "You do not have the required permissions." when trying the <•Liferay IDE Developing Liferay Portlets> link?
Or, is there a way to get this permission?
Thank you for the great work!
Gepostet am 12.08.10 11:32.
Hi Lucas,

For me both logged in and logged out I'm able to see that wiki article. Could you just try again?
Gepostet am 12.08.10 13:49 als Antwort auf Lucas Raw.

"Working out to integrate OpenLDAP in Liferay to incorporate single sign-on feature" looking for input for the same.

Gepostet am 18.08.10 04:00.
Hello all,

I am not able to access Liferay IDE Developing Liferay Portlets link, it show me the error "You do not have the required permissions".

can somebody help me of why i am not able to access this link

thanks in advance
Gepostet am 18.08.10 05:31.

Can something be done about the resolution tablibs and class references when creating a a jsp hook. I'd like to be able to use code completion when adding tags, esoecially liferay and aui tags. All the declaration seem to exit in ohter init files in various parts of the html folder.

Is any kind of work around for this issue?

Gepostet am 19.08.10 08:58.
Hi Bill,

There is no workaround at the moment for actually getting those references to validate. There is a workaround for removing those error markers so they don't dirty up your project under the validation exclusion settings on the project properties page.

I hope to extend the Eclipse JSP editor in the future to properly resolve those references.
Gepostet am 27.08.10 12:13 als Antwort auf Bill Gosse.
I tried to follow the videocast and continue to get a classNotFound error after trying to add a portlet to the portlet project. The original file edit.jsp works fine but adding the second portlet caused the issue.

WARNING: A docBase /opt/liferay/liferay-portal-6.0.5/tomcat-6.0.26/webapps/JohnDemo-portlet inside the host appBase has been specified, and will be ignored
20:42:25,338 INFO [PortletHotDeployListener:220] Registering portlets for JohnDemo-portlet
20:42:25,518 ERROR [PortletBagFactory:115] java.lang.ClassNotFoundException: com.test.JohnPortlet
java.lang.ClassNotFoundException: com.test.JohnPortlet
at org.apache.catalina.loader.WebappClassLoader.loadClass(­16)
at org.apache.catalina.loader.WebappClassLoader.loadClass(­61)
at com.liferay.portlet.PortletBagFactory.create(
at com.liferay.portal.kernel.servlet.PortletContextListener.doPortalInit(PortletCon­
at com.liferay.portal.kernel.util.BasePortalLifecycle.portalInit(BasePortalLifecycl­
at com.liferay.portal.kernel.util.PortalLifecycleUtil.register(PortalLifecycleUtil.­java:52)
at com.liferay.portal.kernel.util.BasePortalLifecycle.registerPortalLifecycle(BaseP­
at com.liferay.portal.kernel.servlet.PortletContextListener.contextInitialized(Port­
at org.apache.catalina.core.StandardContext.listenerStart(­)
at org.apache.catalina.core.StandardContext.start(
at org.apache.catalina.core.ContainerBase.addChildInternal(
­at org.apache.catalina.core.ContainerBase.addChild(
at org.apache.catalina.core.StandardHost.addChild(
at org.apache.catalina.startup.HostConfig.deployDescriptor(
at org.apache.catalina.startup.HostConfig.deployDescriptors(
at­ org.apache.catalina.startup.HostConfig.deployApps(
at org.apache.catalina.startup.HostConfig.check(
at org.apache.catalina.startup.HostConfig.lifecycleEvent(
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.ja­va:119)
at org.apache.catalina.core.ContainerBase.backgroundProcess(­)
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChild­ren(
at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChild­ren(
at org.apache.catalina.core.ContainerBase$­
20:42:25,713 INFO [PortletHotDeployListener:369] 1 portlet for JohnDemo-portlet is available for use
Gepostet am 03.10.10 13:56 als Antwort auf Gregory Amerson.
Hi John,

Could you post your question over on the liferay ide forums? I can followup with you there.
Gepostet am 06.10.10 03:15 als Antwort auf John Joseph Ryan.

Where can I find a changelog for new versions ? I saw there's a brand new 1.5.3.v201205280937, but how can I know what's insid e?


Gepostet am 05.06.12 06:36.
Hi Mathieu,

You can go to JIRA project for the IDE, click on versions and select the 1.5.3 release and there it will contain a link to the Fixed issues.

Here is a link if you want to just go straight there:­roject+%3D+IDE+AND+fixVersion+%3D+%221.5.3%22+AND+status+%3D+Closed+ORDER+BY+pri­ority+DESC&mode=hide
Gepostet am 11.06.12 01:32 als Antwort auf Mathieu Hicauber.