Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Ram Manusani
Styles Messed up in Jboss7
14. April 2012 13:20
Antwort

Ram Manusani

Rang: Regular Member

Nachrichten: 124

Eintrittsdatum: 27. Oktober 2011

Neue Beiträge

I developed a theme using Liferay 6.1 and it totally works fine in Tomcat bundle provided by liferay.

When I try and deploy the same war file into the jboss bundle included by Liferay for 6.1, all the styles are messed up. The same applies both in EE and CE.

Does anyone have any insights on this issue?
Hitoshi Ozawa
RE: Styles Messed up in Jboss7
14. April 2012 22:25
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7949

Eintrittsdatum: 23. März 2010

Neue Beiträge

The code base and Liferay war is the same on both. Is there any error when you deploy it on JBoss?

There's sometime error when deploying plugins on JBoss that deploys on Tomcat.
Ram Manusani
RE: Styles Messed up in Jboss7
14. April 2012 23:51
Antwort

Ram Manusani

Rang: Regular Member

Nachrichten: 124

Eintrittsdatum: 27. Oktober 2011

Neue Beiträge

Yes, the codebase is the same in both. Interestingly, I don't see any errors while deploying in the JBoss Server.

It deploys and registers successfully without any errors in both the servers (Tomcat and JBoss)

I am still surprised on what's causing the issue emoticon
Hitoshi Ozawa
RE: Styles Messed up in Jboss7
15. April 2012 00:13
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7949

Eintrittsdatum: 23. März 2010

Neue Beiträge

Sorry, I usually get some errors. Are the generated page source the same?
Please let us know if you find anything.
Ram Manusani
RE: Styles Messed up in Jboss7
16. April 2012 10:47
Antwort

Ram Manusani

Rang: Regular Member

Nachrichten: 124

Eintrittsdatum: 27. Oktober 2011

Neue Beiträge

For some reason I don't see custom.css getting picked up
Carlos Sierra Andrés
RE: Styles Messed up in Jboss7
17. April 2012 03:16
Antwort

Carlos Sierra Andrés

Rang: New Member

Nachrichten: 5

Eintrittsdatum: 20. Dezember 2011

Neue Beiträge

The same is happening to me. I am deploying on JBoss AS 7.1.1
Same theme deployed on tomcat alone works perfectly.

Besides this it is like some other styles are exported twice, as I can see the same css properties overriden with the same property from the same file when I use firefox's inspect element.
This does not happen on tomcat standalone.

Bests.
Ram Manusani
RE: Styles Messed up in Jboss7
17. April 2012 09:40
Antwort

Ram Manusani

Rang: Regular Member

Nachrichten: 124

Eintrittsdatum: 27. Oktober 2011

Neue Beiträge

Did you try and find a work around yet?
Carlos Sierra Andrés
RE: Styles Messed up in Jboss7
17. April 2012 09:51
Antwort

Carlos Sierra Andrés

Rang: New Member

Nachrichten: 5

Eintrittsdatum: 20. Dezember 2011

Neue Beiträge

Hi,

setting
theme.css.fast.load=false
in portal-ext.properties seems to work for me. I guess this is a bug then, because switching this property from false to true makes the styles fail having the same theme.

I hope this works for you.
Bests.
Ram Manusani
RE: Styles Messed up in Jboss7
17. April 2012 10:31
Antwort

Ram Manusani

Rang: Regular Member

Nachrichten: 124

Eintrittsdatum: 27. Oktober 2011

Neue Beiträge

Well, I tried that and that's not working either
Carlos Sierra Andrés
RE: Styles Messed up in Jboss7
17. April 2012 14:20
Antwort

Carlos Sierra Andrés

Rang: New Member

Nachrichten: 5

Eintrittsdatum: 20. Dezember 2011

Neue Beiträge

Maybe you already did this but you need to restart the server in order for the change to work. Also ensure that the property is making it to the runtime checking the server properties in the control panel (you may be overriding it to true without noticing it).
I checked again and, at least in my case, switching this property makes it either work o not work, but your mileage may vary.

Hope this helps.