Foren

Home » Liferay Portal » English » 3. Development

Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Pawal Adhikari
Password Placeholder not working on Firefox while using <aui:form>
12. April 2013 01:09
Antwort

Pawal Adhikari

Rang: New Member

Nachrichten: 18

Eintrittsdatum: 6. März 2013

Neue Beiträge

I have encountered a strange problem while using placeholder. Password Placeholder works just fine in chrome but in firefox it shows '*****' instead of intended plain text which i used in placeholder.

1   <aui:input placeholder="Password" name="password" showRequiredLabel="<%= false %>" type="password" autocomplete="off"/>


Strange thing is firefox do support placeholder and when used outside of <aui:form> it's working just fine. Moreover, when used in simple html form tag it's working fine.

What am i doing wrong? I just don't want to switch to simple html form as i am using aui validation.

Moreover, at first dot appears in the password field of same length as placeholder but when it is clicked the placeholder appears.
Subhash Pavuskar
RE: Password Placeholder not working on Firefox while using <aui:form>
12. April 2013 02:00
Antwort

Subhash Pavuskar

Rang: Regular Member

Nachrichten: 234

Eintrittsdatum: 12. März 2012

Neue Beiträge

Hi Pawan ,
Which version Firefox you are using ?
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
12. April 2013 02:51
Antwort

Pawal Adhikari

Rang: New Member

Nachrichten: 18

Eintrittsdatum: 6. März 2013

Neue Beiträge

18.0.1 and i am pretty sure that it is compatible, http://caniuse.com/input-placeholder . And, i just found that it's not only password placeholder issue but too of text field.
Subhash Pavuskar
RE: Password Placeholder not working on Firefox while using <aui:form>
12. April 2013 04:11
Antwort

Subhash Pavuskar

Rang: Regular Member

Nachrichten: 234

Eintrittsdatum: 12. März 2012

Neue Beiträge

hi,
I tested your code its working fine on my Firefox browser and i am using Ver 21.0 !!
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
12. April 2013 18:35
Antwort

Pawal Adhikari

Rang: New Member

Nachrichten: 18

Eintrittsdatum: 6. März 2013

Neue Beiträge

hi,
It's working just fine in firefox but issue appears when i use it inside <aui:form>.
Using outside of form or in simple html form doesn't show any problem.
Raffael Tregilgas
RE: Password Placeholder not working on Firefox while using <aui:form>
22. April 2013 07:56
Antwort

Raffael Tregilgas

Rang: New Member

Nachrichten: 7

Eintrittsdatum: 23. April 2012

Neue Beiträge

hi
did you have any luck finding a solution for this problem? have the same thing in ff 20.0.1 and its not working
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
8. Mai 2013 02:32
Antwort

Pawal Adhikari

Rang: New Member

Nachrichten: 18

Eintrittsdatum: 6. März 2013

Neue Beiträge

nope