Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Sreejith NP
Unable to Modify Site URL [virtual host]
15. Februar 2013 04:53
Antwort

Sreejith NP

Rang: New Member

Nachrichten: 15

Eintrittsdatum: 13. März 2012

Neue Beiträge

Dear All,
When I am trying to modify the site URL under Site Settings I am getting the following error on the console. On the interface I am getting an error "Site Settings is temporarily unavailable."


11:58:16,542 ERROR [render_portlet_jsp:154] java.lang.NullPointerException
at com.liferay.portlet.asset.util.BaseAssetEntryValidator.validate(BaseAssetEntryValidator.java:105)
at com.liferay.portlet.asset.util.BaseAssetEntryValidator.validate(BaseAssetEntryValidator.java:74)
at com.liferay.portlet.asset.service.impl.AssetEntryLocalServiceImpl.validate(AssetEntryLocalServiceImpl.java:815)
at com.liferay.portlet.asset.service.impl.AssetEntryLocalServiceImpl.updateEntry(AssetEntryLocalServiceImpl.java:572)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:112)
at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:71)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
at com.liferay.portal.spring.aop.ServiceBeanAopProxy.invoke(ServiceBeanAopProxy.java:211)
at com.liferay.portal.service.impl.GroupLocalServiceImpl.updateAsset(GroupLocalServiceImpl.java:1809)
at com.liferay.portal.service.impl.GroupLocalServiceImpl.updateGroup(GroupLocalServiceImpl.java:1962)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:112)
at com.liferay.portal.spring.transaction.TransactionInterceptor.invoke(TransactionInterceptor.java:71)
at com.liferay.portal.spring.aop.ServiceBeanMethodInvocation.proceed(ServiceBeanMethodInvocation.java:108)
at com.liferay.portal.spring.aop.ChainableMethodAdvice.invoke(ChainableMethodAdvice.java:59)


Can anyone help me to find out a solution?


Sreejith
Meera Prince
RE: Unable to Modify Site URL [virtual host]
15. Februar 2013 05:07
Antwort

Meera Prince

Rang: Liferay Legend

Nachrichten: 1110

Eintrittsdatum: 8. Februar 2011

Neue Beiträge

HI May be you portal currepted.. and also send me full stack trace.
If possible re deploy entire portal once again.

portal-web-----> ant build-themes
from portal
ant clean
ant compile
ant deploy

Note: when you run clean option before that please make sure if you are using CAS .. please take back up of cas-web.


Regards,
Meera Prince
Dhvanil Reshamwala
RE: Unable to Modify Site URL [virtual host]
18. Februar 2013 03:35
Antwort

Dhvanil Reshamwala

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 23. Dezember 2011

Neue Beiträge

Hi Sreejith,
Can you provide with the URL that you are trying to set ? Looks like the URL that you are trying to set is failing some Liferay validation.
Mika Koivisto
RE: Unable to Modify Site URL [virtual host]
20. Februar 2013 15:11
Antwort

Mika Koivisto

LIFERAY STAFF

Rang: Liferay Legend

Nachrichten: 1512

Eintrittsdatum: 7. August 2006

Neue Beiträge

That stacktrace looks familiar and I'm pretty sure it's fixed in 6.1 GA2 however I couldn't find the ticket that fixed it.
Sreejith NP
RE: Unable to Modify Site URL [virtual host]
6. Mai 2013 23:45
Antwort

Sreejith NP

Rang: New Member

Nachrichten: 15

Eintrittsdatum: 13. März 2012

Neue Beiträge

Sorry for replying late.
the issue is resolved.

whenever you create an asset vocabulary, it inserts a row in assetvocabulary table in which the last column "settings" will contain some value like
"multiValued=true
selectedClassNameIds=0"

if you see, in settings column, except for the newly created vocabulary the settings column contains blank('') value. I removed the entry of settings column; it started working.


regards
Sreejith