Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Jaron Soininen
NTLM SSO is working but users have to click the 'Sign In' link
26. Februar 2012 17:09
Antwort

Jaron Soininen

Rang: New Member

Nachrichten: 3

Eintrittsdatum: 22. Februar 2012

Neue Beiträge

Hello,

I am new to Liferay and am working my way throught it. I'm using Liferay 6.1.0 with Tomcat and a requirement for my Companies Intranet is to have SSO integration with Active Directory. I have successfully setup LDAP, imported the users and they can sign in by authenticating against our AD servers. I have also setup SSO through NTLM and a user is automatically logged in providing they click on the 'Sign In' link. How can I prevent this step, so that as soon as the browser is launched the user is logged in rather than having to click 'Sign In'.

I have seen alot of information about editing a Web.xml file and a portal-ex.properties, but I dont know where these files reside. I dont think the portal-ex.properties file exists for me because I installed Liferay through a Wizard, so I believe I have a file called portal-setup-wizard.properties instead. Is that correct?

If you know a solution that entails editing files do you mind posting file paths so I know where to locate them. Any assistance is appreciated.

Regards,

Jaron
Michael John Macrohon
RE: NTLM SSO is working but users have to click the 'Sign In' link
16. August 2012 19:30
Antwort

Michael John Macrohon

Rang: New Member

Nachrichten: 4

Eintrittsdatum: 16. August 2012

Neue Beiträge

We have both implemented successfully the NTLM and CAS (kerberos) autologin authentication. Either of the two requires the LDAP enabled.

If everything is successfully set. Please use this link to authenticate you automatically.

http://<hostname>:8080/lportal/c/portal/login?p_l_id=10183

The highlighted portion may change depending on your setup.
Jari Fredriksson
RE: NTLM SSO is working but users have to click the 'Sign In' link
13. März 2013 17:32
Antwort

Jari Fredriksson

Rang: New Member

Nachrichten: 23

Eintrittsdatum: 14. September 2010

Neue Beiträge

I have this same problem.

I can log in using AD credentials via sign-in link, but no way directly w/o it.

Also the /*/login as described above only takes me to the login form asking for user and password.

portal-ext.properties:

ntlm.auth.enabled = true
auto.login.hooks = com.liferay.portal.security.auth.NtlmAutoLogin

NTLM parameters configured in with a an AD machine account$ & password, but no joy.