« Back to Installation

Installing and Configuring Open Office

Table of Contents [-]

Introduction #

First off, let me say that you should not install OO from the Ubuntu repository. It won't work. There's about a million threads on this on the OpenOffice forums. I thought I'd document here for the rest of you who are using Liferay on a nix platform where you might not have X Windows since no one with a brain puts X Windows on an internet exposed server because of the security issues. (You didn't do that, did you???? ) This is the case for many of the other distros as well, I'm told. While these directions are debian specific, you should be able to adapt them to your platform of choice. You just need to be familiar with your package manager - RPM, YUM, etc.

If you're trying to start OO and seeing this - keep reading! This was the error message I was getting. It's not very explanatory or descriptive, especially on a headless server. I've pasted it in here so that any search will hit on it.

javaldx: Could not find a Java Runtime Environment!
/usr/lib/openoffice/program/soffice.bin X11 error: Can't open display:
Set DISPLAY environment variable, use -display option
or check permissions of your X-Server
(See "man X" resp. "man xhost" for details)

If you have installed it that way, uninstall it. If you see it taking dependencies with it, don't worry. We're going to reinstall those in a minute.

I'm running Hardy LTS (8.04) and you'll need to install some dependencies. Just paste the statement below in. You may have to put sudo in front it if you've not assumed root.

aptitude install dictionaries-common libcurl3 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libhunspell-1.1-0 libicu38 libneon27 libnss3-1d libnspr4-0d ttf-opensymbol libsm6 libice6

Wait for that to finish and it should take care of your dependencies.

Download the right package from the Open Office site

Upload that to your server and unpack it

Then go into the folder DEBS. Again you may need to put sudo in front this, if you have not assumed root.

run dpkg -i *.deb

This will install all the deb files necessary for you to run it.

THEN you can start OO headless but you need an extra command.

Following command also applies Libre Office 3.6.1, but path is different

/opt/openoffice.org3/program/soffice -headless -accept="socket,host=,port=8100;urp;" -nofirststartwizard&

Note: /opt/openoffice.org3/program is where the OpenOffice debs of OpenOffice install themselves.

0 Attachments
Average (0 Votes)
The average rating is 0.0 stars out of 5.
Threaded Replies Author Date
Just tried installing the latest version... GERALD ROMERO October 19, 2012 11:54 AM

Just tried installing the latest version (3.4.1) on Ubuntu 12.04 Server.
sudo /opt/openoffice.org3/program/soffice -headless -accept="socket,host=,port=8100;urp;" -nofirststartwizard

results in the following...
no suitable windowing system found, exiting.

Of course there is no windowing system and I do not want to install one. Any suggestions?
Posted on 10/19/12 11:54 AM.