WebSphere 8 Auto Deploy #

Log in to the Admin console and click "Global deployment Settings" from the Applications section of the Left-Hand-Side navigation menu.

Check the "Monitor directory to automatically deploy applications". You can change the monitored directory too.

Click apply and save the changes to persist the settings to configuration repository. You will have to restart the server for the settings to take effect.

java.lang.NullPointerException on HookHotDeployListener #

If you experience the following exception:

Caused by: java.lang.NullPointerException
	at com.liferay.portal.deploy.hot.HookHotDeployListener$ServletFiltersContainer.registerFilter(HookHotDeployListener.java:2916)
	at com.liferay.portal.deploy.hot.HookHotDeployListener.doInvokeDeploy(HookHotDeployListener.java:820)
	at com.liferay.portal.deploy.hot.HookHotDeployListener.invokeDeploy(HookHotDeployListener.java:261)

then see next section.

Filter initalization on WebSphere #

On Websphere previous to,, and there is a problem with filters - they are not initialized on web application startup; but on first access. In portal/portlet environment that might be a problem, for example when deploying some plugin).

In order to have servlet filters initialized on application startup (i.e. on deployment) you need to turn on this feature, by setting following webcontainer custom properties.

com.ibm.ws.webcontainer.initFilterBeforeInitServlet = true
com.ibm.ws.webcontainer.invokeFilterInitAtStartup = true

Read more about this issue here:


However, thats might not be all! It make sense to delay execution of plugins web application, by setting the higher order. In WAS admin console select the plugin web app, go to Startup behavior and set Startup order to a higher number.

Set a webcontainer custom property #

On IBM WebSphere Application Server Version 7 or Version 8:

  1. In the administrative console, click "Servers" and under Servers click "Server Types" and under Server Types click "WebSphere application servers"
  2. Click on the server to which the custom property is to be applied
  3. Under "Configuration" and "Container settings" click "Web Container Settings" and under Web Container Settings click "Web container"
  4. Under "Configuration" and "Additional Properties" click "Custom Properties". In the Custom Properties page, click "New"
  5. In the settings page, enter the name of the custom property to be added in the "Name" field and the value to be set for the custom property in the "Value" field.
  6. Click "Apply" or "OK" . Click "Save" in the "Messages" box that appears
  7. Restart the server for the custom property to take effect

WAS installation #

     When portal is installed on WAS, the following exception is thrown:

Caused by: java.lang.VerifyError: JVMVRFY013 class loading constraint violated; class=org/springframework/aop/aspectj/MethodInvocationProceedingJoinPoint, method=getSourceLocation()Lorg/aspectj/lang/reflect/SourceLocation;, pc=0

There is a known issue documented under APAR PM90932. An ifix has been published for this issue and you can read about it and download it from HERE. Once the ifix is installed, the issue won't appear again.

Note: This fix (and others) is included in the automatic updates handled by the Installation Manager, as long as you return iteratively after each successfull set of updates is installed.

0 Attachments
Average (1 Vote)
The average rating is 5.0 stars out of 5.
Threaded Replies Author Date
Hi, I have patched WAS with required files... Ciprian Pavel June 15, 2014 6:00 AM
Hi, I solved this issue by using shared... Tomas Mayer August 27, 2015 8:06 AM


I have patched WAS with required files (also used which already includes the patch) but I run into the same issue always.
Basic configuration works fine and a portal config is getting created, but whenever I try to do anything besides viewing the same error is thrown:

JVMVRFY013 class loading constraint violated; class=com/liferay/portlet/StateAwareResponseImpl, method=setEvent(Ljavax/xml/namespace/QName;Ljava/io/Serializable;)V, pc=0

I did not find anything on the web. I am using Liferay 6.2 CE GA2 on WAS ND 8.5.5 (.0, .1 and .2 ).

Posted on 6/15/14 6:00 AM.

I solved this issue by using shared library attached to the application.

Do not copy the jar files from the liferay-portal-dependencies-......zip to the /ext/lib folder. Create any directory in the profile directory, run the /ibm/console and set up a Shared Library (Evnironment / Shared Libraries menu) rather. Then set up the application to use this library (Enterprise Applications / liferay-portal-application / References / Shared libraries references / ).

The application will use the application class loader to load the libraries and it avoids the constraint violation error.

Posted on 8/27/15 8:06 AM in reply to Ciprian Pavel.