Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Hubert Felber
different context (root_path) with Liferay 6.0.1 does not work
May 4, 2010 6:18 AM
Answer

Hubert Felber

Rank: Regular Member

Posts: 157

Join Date: November 23, 2009

Recent Posts

Hi,

I try do deploy Liferay 6.0.1 JBoss 5.1 bundle to different context and it does not work.
The context is set to http://localhost:8080/flow/
If I change context I cannot configure anything in the control panel in the blue form navigation (see pic's attached below).
Neither can I change user settings nor configure other things like portal settings.
This worked fine in Liferay 5.2.3.
To me this looks like a bug in 6.0.1. Does anybody else have the same problem?

I portal-ext-properties I set
1
2portal.ctx=/flow


my jboss-web.xml is
 1
 2<?xml version="1.0"?>
 3<!DOCTYPE jboss-web PUBLIC "-//JBoss//DTD Web Application 2.4//EN" "http://www.jboss.org/j2ee/dtd/jboss-web_4_0.dtd">
 4<jboss-web>
 5    <class-loading java2ClassLoadingCompliance="false">
 6        <loader-repository>
 7            com.liferay.portal:loader=liferay-portal
 8            <loader-repository-config>
 9                java2ParentDelegation=false
10            </loader-repository-config>
11        </loader-repository>
12    </class-loading>
13    <security-domain>java:/jaas/PortalRealm</security-domain>
14    <context-root>flow</context-root>
15</jboss-web>


in web.xml I added

1
2...
3    <context-param>
4        <param-name>root_path</param-name>
5        <param-value>/flow</param-value>
6    </context-param>
7...


Thank you
Hubert

Nothing happens if I click in anywhere in any of the blue form navigations
Attachment

Attachments: nothing2.PNG (21.7k)
Hubert Felber
RE: different context (root_path) with Liferay 6.0.1 does not work
May 5, 2010 1:50 AM
Answer

Hubert Felber

Rank: Regular Member

Posts: 157

Join Date: November 23, 2009

Recent Posts

Hi

I tested the same with the Liferay 6.0.0 preview version where this worked fine. I changed context to /flow, logged in and was able to configure Liferay in the control panel via the blue form navigation panes.
I did both the tests with clean installations of liferay jboss bundle from 6.0.0 preview and 6.0.0 release candidate by just changing the context path in jboss-web.xml, web.xml and portal-ext.properties.
I think this is a bug and will file an issue.
Hubert

P.S.
Also noticed that Add->More... drops down but selecting e.g. Collaboration does not open the list.
Eduardo Lundgren
RE: different context (root_path) with Liferay 6.0.1 does not work
July 1, 2010 1:45 PM
Answer

Eduardo Lundgren

LIFERAY STAFF

Rank: Junior Member

Posts: 25

Join Date: June 18, 2008

Recent Posts

Hi Hubert,

I committed a fix on rev. 57198, can you double check if it's working on JBOSS?
Hubert Felber
RE: different context (root_path) with Liferay 6.0.1 does not work
July 2, 2010 8:43 AM
Answer

Hubert Felber

Rank: Regular Member

Posts: 157

Join Date: November 23, 2009

Recent Posts

Hi Eduardo,
I can confirm that this works fine with revision 57288

Thanks a lot.
Rahul Bhattacharya
RE: different context (root_path) with Liferay 6.0.1 does not work
August 20, 2010 10:24 AM
Answer

Rahul Bhattacharya

Rank: Junior Member

Posts: 59

Join Date: January 16, 2010

Recent Posts

Hi,
this error again started to happen in the latest release of liferay GA 3. Some changes pertaining to revision 57198 might be lost

regards
Rahul
Sindhu Varshini
RE: different context (root_path) with Liferay 6.0.1 does not work
January 21, 2016 10:40 AM
Answer

Sindhu Varshini

Rank: New Member

Posts: 6

Join Date: April 18, 2013

Recent Posts

Hi Everyone,

I am using Liferay 6.2 CE GA4 version. I have a requirement for using context path in my application. Ex: http://localhost:8080/liferay/
Before using context path, I installed chat-portlet MUC plugin or any other plugin from marketplace which is working fine in the application with all chat features. When I am using context path, chat portlet plugin view is either distorted or not able to load everything.jsp, css files, images etc which is not working. I can see the errors with respect to file loads in the firebug console. These errors are showing up for any plugin from marketplace when linked with context path.

Is this a bug in liferay or am I missing something? If I have to use any plugins from marketplace then how can I make them work while using context path. Please help me.


Thanks,
Sindhu
Olaf Kock
RE: different context (root_path) with Liferay 6.0.1 does not work
January 21, 2016 1:32 PM
Answer

Olaf Kock

LIFERAY STAFF

Rank: Liferay Legend

Posts: 3464

Join Date: September 23, 2008

Recent Posts

Sindhu Varshini:
I am using Liferay 6.2 CE GA4 version.


If you have problems with 6.2 GA 4, please don't post on a thread that explicitly discusses a problem in 6.0.1 - rather start a new one. There's enough room here, and the people that answered back in 2010 might not keep an eye on this thread anyway.

That being said, when you start a new thread, please give us a hint as to which exact errors you do see (not just that you can see errors) and what the configuration is that you've tried. That will make it so much more easy to help you.
Sindhu Koganti
RE: different context (root_path) with Liferay 6.0.1 does not work
January 25, 2016 10:20 AM
Answer

Sindhu Koganti

Rank: New Member

Posts: 4

Join Date: January 19, 2016

Recent Posts

Hi Olaf Kock,

I am sorry to start the discussion related to liferay 6.2 in same thread. I created a new thread (please check the url below) and included the errors I am facing.
https://www.liferay.com/community/forums/-/message_boards/message/68582798

Please help me with your ideas.


Thanks,
Sindhu