Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Bhanu P Kondeti
Blogs not displayed
September 3, 2009 12:09 PM
Answer

Bhanu P Kondeti

Rank: New Member

Posts: 6

Join Date: August 5, 2009

Recent Posts

Hi,
I can see the blogs in the blog aggregator. But when I click on the link an empty blog is displayed.

Below is the stack trace.. Please help me in this regard. We are using Oracle 10g

02:50:41,087 ERROR [JDBCExceptionReporter:101] Conversion to String failed
02:50:41,099 ERROR [IncludeTag:79] Current URL /group/instructor-collaboration/blog/-/blogs/test-1?_33_redirect=%2Fgroup%2Finstructor-collaboration%2Fblog%2F generates exception: An exception occurred processing JSP page /html/portlet/blogs/view_entry.jsp at line 40

37:
38: long entryId = BeanParamUtil.getLong(entry, request, "entryId");
39:
40: BlogsEntry[] prevAndNext = BlogsEntryLocalServiceUtil.getEntriesPrevAndNext(entryId);
41:
42: BlogsEntry previousEntry = prevAndNext[0];
43: BlogsEntry nextEntry = prevAndNext[2];


Stacktrace:
02:50:41,101 ERROR [IncludeTag:165] com.liferay.portal.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: could not read next row of results
at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.processException(BasePersistenceImpl.java:91)
at com.liferay.portlet.blogs.service.persistence.BlogsEntryPersistenceImpl.findByGroupId_PrevAndNext(BlogsEntryPersistenceImpl.java:1135)
at com.liferay.portlet.blogs.service.impl.BlogsEntryLocalServiceImpl.getEntriesPrevAndNext(BlogsEntryLocalServiceImpl.java:364)
at com.liferay.portlet.blogs.service.BlogsEntryLocalServiceUtil.getEntriesPrevAndNext(BlogsEntryLocalServiceUtil.java:239)
at org.apache.jsp.html.portlet.blogs.view_005fentry_jsp._jspService(view_005fentry_jsp.java:997)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:630)
at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:535)
at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:472)
at com.liferay.taglib.util.IncludeTag.doEndTag(IncludeTag.java:67)
at org.apache.jsp.html.common.themes.portlet_jsp._jspService(portlet_jsp.java:2736)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)


Caused by: com.liferay.portal.kernel.dao.orm.ORMException: could not read next row of results
at com.liferay.portal.dao.orm.hibernate.ExceptionTranslator.translate(ExceptionTranslator.java:41)
at com.liferay.portal.dao.orm.hibernate.ScrollableResultsImpl.first(ScrollableResultsImpl.java:47)
at com.liferay.portal.kernel.dao.orm.QueryUtil.getPrevAndNext(QueryUtil.java:158)
at com.liferay.portlet.blogs.service.persistence.BlogsEntryPersistenceImpl.findByGroupId_PrevAndNext(BlogsEntryPersistenceImpl.java:1123)
at com.liferay.portlet.blogs.service.impl.BlogsEntryLocalServiceImpl.getEntriesPrevAndNext(BlogsEntryLocalServiceImpl.java:364)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
Bhanu P Kondeti
RE: Blogs not displayed
September 3, 2009 2:58 PM
Answer

Bhanu P Kondeti

Rank: New Member

Posts: 6

Join Date: August 5, 2009

Recent Posts

We observed that this is happening when we the "content" column is fetched from the "BlogsEntry" table. "Content" is of "Clob" datatype.

In a stand alone program we called getString() on a clob and were able to reproduce this error. So seems like liferay 5.2.3 it is trying to do the same.

Interesting thing here is we can see the blog summary correctly. I think they implement it in a different way.

Only when we click on the blog title to see blog details and comments we get this error and nothing is displayed.
Felix Kalka
RE: Blogs not displayed
September 9, 2009 4:41 AM
Answer

Felix Kalka

Rank: New Member

Posts: 2

Join Date: September 9, 2009

Recent Posts

i have the same problem. did you find any solution yet?

greetings,
felix
Felix Kalka
RE: Blogs not displayed
September 9, 2009 6:29 AM
Answer

Felix Kalka

Rank: New Member

Posts: 2

Join Date: September 9, 2009

Recent Posts

i think its more a problem of the scrollableresultsimpl from hibernate...
if you remove the catch block in BlogsEntryPersistenceImpl.findByGroupId_PrevAndNext, the stacktrace leads you into the hibernate framework...
ill do some more debugging and then maybe make a post somewhere on the hibernate homapage.
Stephan Huber
RE: Blogs not displayed
September 14, 2009 7:11 AM
Answer

Stephan Huber

Rank: Junior Member

Posts: 28

Join Date: March 27, 2009

Recent Posts

Has nobody a solution to this problem? Or do we have to wait for the next update (5.2.4?)?

I get the exception when clicking an a blog entry in the asset publisher with 5.2.3.
Paul Martin
RE: Blogs not displayed
September 22, 2009 2:51 PM
Answer

Paul Martin

Rank: New Member

Posts: 11

Join Date: July 24, 2008

Recent Posts

This is still a bug in 5.2.5 . Pls see the details on JIRA: http://issues.liferay.com/browse/LPS-4843
Lisa Simpson
RE: Blogs not displayed
September 22, 2009 3:08 PM
Answer

Lisa Simpson

Rank: Liferay Legend

Posts: 2034

Join Date: March 5, 2009

Recent Posts

Just as a stupid question for the Liferay developers, why is a blog entry a CLOB data-type???
Ashraf Nabil
RE: Blogs not displayed
February 4, 2010 6:02 AM
Answer

Ashraf Nabil

Rank: New Member

Posts: 1

Join Date: February 4, 2010

Recent Posts

Hi all,

I faced this problem and I had found that it is a bug between Liferay and Oracle DB, I fixed this bug on my system using the latest update of oracle driver downloaded from oracle's site

thanks,
Ashraf
bharath dg
RE: Blogs not displayed
February 9, 2010 1:41 AM
Answer

bharath dg

Rank: New Member

Posts: 19

Join Date: June 10, 2009

Recent Posts

Hi Bhanu!!!

Did u get solution? Please let me know. I am facing the same problem.


Thank u